aboutsummaryrefslogtreecommitdiffstats
path: root/devel/understand_c
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-10-16 23:47:13 +0800
committerlioux <lioux@FreeBSD.org>2001-10-16 23:47:13 +0800
commite2a1e5a9ea5189297ef62ebf4651bdffc75cbbfa (patch)
tree220824998f7f384c59130d66e6bdc1dd49d793ea /devel/understand_c
parent19fe81ed9ba852de53e53a365faf1bcb6edaa036 (diff)
downloadfreebsd-ports-gnome-e2a1e5a9ea5189297ef62ebf4651bdffc75cbbfa.tar.gz
freebsd-ports-gnome-e2a1e5a9ea5189297ef62ebf4651bdffc75cbbfa.tar.zst
freebsd-ports-gnome-e2a1e5a9ea5189297ef62ebf4651bdffc75cbbfa.zip
o make stripping the binaries conditional to the existence of the
strip command o this is important since the current emulators/linux_base-7 does not carry a strip command and no appropriate port carrying it currently exists Prompted by: John Merryweather Cooper <john_m_cooper@yahoo.com>
Diffstat (limited to 'devel/understand_c')
-rw-r--r--devel/understand_c/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/understand_c/Makefile b/devel/understand_c/Makefile
index dcd93905b62a..e2bbe6e8c4e9 100644
--- a/devel/understand_c/Makefile
+++ b/devel/understand_c/Makefile
@@ -100,7 +100,9 @@ do-install:
.for file in ${BIN_FILES}
@${INSTALL_SCRIPT} ${WRKSRC}/bin/pc-linux_elf/${file} \
${PREFIX}/lib/understand_c/bin/pc-linux_elf
+.if exists(${STRIP})
@${STRIP} ${PREFIX}/lib/understand_c/bin/pc-linux_elf/${file}
+.endif
@${BRANDELF} -t Linux ${PREFIX}/lib/understand_c/bin/pc-linux_elf/${file}
@if [ ! -f ${PREFIX}/bin/${file} ]; \
then \