aboutsummaryrefslogtreecommitdiffstats
path: root/devel/upnp/Makefile
diff options
context:
space:
mode:
authorclive <clive@FreeBSD.org>2002-08-04 15:31:27 +0800
committerclive <clive@FreeBSD.org>2002-08-04 15:31:27 +0800
commitdd360dbfa58983e03cbfcff941586473b63ad3b4 (patch)
tree90e4a35eea9f00e79126d12a776a9ca12e45d6e7 /devel/upnp/Makefile
parent1be3b234a31e23698aac47b4bc2de8de2076da58 (diff)
downloadfreebsd-ports-gnome-dd360dbfa58983e03cbfcff941586473b63ad3b4.tar.gz
freebsd-ports-gnome-dd360dbfa58983e03cbfcff941586473b63ad3b4.tar.zst
freebsd-ports-gnome-dd360dbfa58983e03cbfcff941586473b63ad3b4.zip
New port: SDK for UPnP Devices
This is Linux SDK for UPnP Devices 1.0, an Open Source Universal Plug and Play Development Kit. PR: ports/41294 Submitted by: Yen-Ming Lee <leeym@utopia.leeym.com>
Diffstat (limited to 'devel/upnp/Makefile')
-rw-r--r--devel/upnp/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/devel/upnp/Makefile b/devel/upnp/Makefile
new file mode 100644
index 000000000000..b6f1ec651362
--- /dev/null
+++ b/devel/upnp/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: upnp
+# Date created: 02 August 2002
+# Whom: Yen-Ming Lee <leeym@leeym.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= upnp
+PORTVERSION= 1.0.4
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}sdk-${PORTVERSION}
+
+MAINTAINER= leeym@leeym.com
+
+LIB_DEPENDS= uuid.1:${PORTSDIR}/sysutils/e2fsprogs
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+MAKEFILE= makefile
+MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,MAKE = make,MAKE = ${GMAKE},' \
+ src/genlib/makefile src/makefile
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,' \
+ src/inc/genlib/client_table/client_table.h \
+ src/inc/genlib/http_client/http_client.h \
+ src/inc/genlib/service_table/service_table.h \
+ src/inc/genlib/timer_thread/timer_thread.h \
+ src/upnpdom/domCif.cpp
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,MSG_NOSIGNAL,0,' \
+ src/genlib/http_client/http_client.c \
+ src/genlib/net/http/readwrite.cpp
+
+.include <bsd.port.mk>