aboutsummaryrefslogtreecommitdiffstats
path: root/devel/upnp
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-08-17 17:44:53 +0800
committerrafan <rafan@FreeBSD.org>2006-08-17 17:44:53 +0800
commitc6af302fab7345ff93f4ad2effb55a3caf159ba4 (patch)
treec457494c3686da341afb056b1142bc4460d4714e /devel/upnp
parentbf839ab7a71e6563a94046bc54b3c8fa69eb4238 (diff)
downloadfreebsd-ports-gnome-c6af302fab7345ff93f4ad2effb55a3caf159ba4.tar.gz
freebsd-ports-gnome-c6af302fab7345ff93f4ad2effb55a3caf159ba4.tar.zst
freebsd-ports-gnome-c6af302fab7345ff93f4ad2effb55a3caf159ba4.zip
- Update to 1.4.1
- Mark BROKEN on 4.x - Pass maintainership to submitter PR: ports/102147 Submitted by: Babak Farrokhi <babak at farrokhi.net>
Diffstat (limited to 'devel/upnp')
-rw-r--r--devel/upnp/Makefile10
-rw-r--r--devel/upnp/distinfo6
-rw-r--r--devel/upnp/files/patch-ithread.h13
-rw-r--r--devel/upnp/files/patch-threadutil-src-ThreadPool.c11
-rw-r--r--devel/upnp/files/patch-upnp-inc-upnp.h18
-rw-r--r--devel/upnp/files/patch-upnp-src-urlconfig-urlconfig.c10
-rw-r--r--devel/upnp/files/patch-upnp-src-uuid-uuid.c10
-rw-r--r--devel/upnp/pkg-plist254
8 files changed, 276 insertions, 56 deletions
diff --git a/devel/upnp/Makefile b/devel/upnp/Makefile
index a7a0cc3c4463..5e7bc0c5a2ae 100644
--- a/devel/upnp/Makefile
+++ b/devel/upnp/Makefile
@@ -6,29 +6,31 @@
#
PORTNAME= upnp
-PORTVERSION= 1.4.0
+PORTVERSION= 1.4.1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pupnp
DISTNAME= lib${PORTNAME}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= babak@farrokhi.net
COMMENT= Universal Plug and Play Software Development Kit
CONFLICTS= upnp-1.0.*
.include <bsd.port.pre.mk>
-.if ${ARCH}==amd64
-BROKEN=does not compile on amd64
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on FreeBSD 4.X
.endif
+NOT_FOR_ARCH= amd64 sparc64
GNU_CONFIGURE= yes
USE_DOS2UNIX= yes
MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
NOT_FOR_ARCHS= sparc64
USE_LDCONFIG= yes
+CONFIGURE_ENV+= LIBS="-llwres -lcompat"
.if defined(NOPORTDOCS)
CONFIGURE_ARGS= --without-docdir
diff --git a/devel/upnp/distinfo b/devel/upnp/distinfo
index c6a7cd0e15ec..2c25368c3593 100644
--- a/devel/upnp/distinfo
+++ b/devel/upnp/distinfo
@@ -1,3 +1,3 @@
-MD5 (libupnp-1.4.0.tar.gz) = 581c8017dc1b36d29ba034ce1e178c83
-SHA256 (libupnp-1.4.0.tar.gz) = 816c22d7163f2b74e7dab52b1adf81f5248d760da94fa79672337333a048e906
-SIZE (libupnp-1.4.0.tar.gz) = 763352
+MD5 (libupnp-1.4.1.tar.gz) = f3b55c24ff77ee6789d758ec1634d5e7
+SHA256 (libupnp-1.4.1.tar.gz) = 0c549192c00f5a494032a370ff1cc84f66b752cd756a0d7ba707ee4332137a8a
+SIZE (libupnp-1.4.1.tar.gz) = 1289149
diff --git a/devel/upnp/files/patch-ithread.h b/devel/upnp/files/patch-ithread.h
new file mode 100644
index 000000000000..e40fe8e5141d
--- /dev/null
+++ b/devel/upnp/files/patch-ithread.h
@@ -0,0 +1,13 @@
+--- threadutil/inc/ithread.h.orig Wed Aug 16 15:52:47 2006
++++ threadutil/inc/ithread.h Wed Aug 16 15:53:52 2006
+@@ -47,6 +47,10 @@
+ #include <unistd.h>
+ #endif
+
++#ifdef __FreeBSD__
++#define PTHREAD_MUTEX_RECURSIVE_NP PTHREAD_MUTEX_RECURSIVE
++#endif
++
+ #define ITHREAD_MUTEX_FAST_NP PTHREAD_MUTEX_FAST_NP
+ #define ITHREAD_MUTEX_RECURSIVE_NP PTHREAD_MUTEX_RECURSIVE_NP
+ #define ITHREAD_MUTEX_ERRORCHECK_NP PTHREAD_MUTEX_ERRORCHECK_NP
diff --git a/devel/upnp/files/patch-threadutil-src-ThreadPool.c b/devel/upnp/files/patch-threadutil-src-ThreadPool.c
deleted file mode 100644
index 9ff966d5ae70..000000000000
--- a/devel/upnp/files/patch-threadutil-src-ThreadPool.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- threadutil/src/ThreadPool.c.orig Mon May 22 15:22:46 2006
-+++ threadutil/src/ThreadPool.c Mon Jun 12 19:25:28 2006
-@@ -341,7 +341,7 @@
- struct timeb t;
-
- ftime( &t );
-- srand( ( unsigned int )t.millitm + ithread_get_current_thread_id( ) );
-+ srand( ( unsigned int )t.millitm + ( unsigned int )ithread_get_current_thread_id( ) );
- }
-
- /****************************************************************************
diff --git a/devel/upnp/files/patch-upnp-inc-upnp.h b/devel/upnp/files/patch-upnp-inc-upnp.h
deleted file mode 100644
index 4308b3a4c483..000000000000
--- a/devel/upnp/files/patch-upnp-inc-upnp.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- upnp/inc/upnp.h.orig Sat Jun 17 11:57:02 2006
-+++ upnp/inc/upnp.h Sat Jun 17 12:01:43 2006
-@@ -37,6 +37,7 @@
- //@{
-
- #include <stdio.h>
-+#include <time.h>
- #include "ixml.h"
- #include "upnpconfig.h"
- #if UPNP_HAVE_DEBUG
-@@ -48,6 +49,7 @@
- #define UPNP_INVALID_SOCKET -1
- #define SOCKET int
-
-+#include <sys/types.h>
- #include <netinet/in.h>
-
- #define LINE_SIZE 180
diff --git a/devel/upnp/files/patch-upnp-src-urlconfig-urlconfig.c b/devel/upnp/files/patch-upnp-src-urlconfig-urlconfig.c
deleted file mode 100644
index 175d35ecf855..000000000000
--- a/devel/upnp/files/patch-upnp-src-urlconfig-urlconfig.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- upnp/src/urlconfig/urlconfig.c.orig Sat Jun 17 12:18:32 2006
-+++ upnp/src/urlconfig/urlconfig.c Sat Jun 17 12:21:52 2006
-@@ -31,6 +31,7 @@
-
- #include "config.h"
- #include <assert.h>
-+#include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
diff --git a/devel/upnp/files/patch-upnp-src-uuid-uuid.c b/devel/upnp/files/patch-upnp-src-uuid-uuid.c
deleted file mode 100644
index 26d12747c34d..000000000000
--- a/devel/upnp/files/patch-upnp-src-uuid-uuid.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- upnp/src/uuid/uuid.c.orig Sat Jun 17 12:16:38 2006
-+++ upnp/src/uuid/uuid.c Sat Jun 17 12:16:52 2006
-@@ -22,6 +22,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <time.h>
-+#include <sys/types.h>
- #include <netinet/in.h>
- #include "sysdep.h"
- #include "uuid.h"
diff --git a/devel/upnp/pkg-plist b/devel/upnp/pkg-plist
index 6197316c9dbf..684abf68b057 100644
--- a/devel/upnp/pkg-plist
+++ b/devel/upnp/pkg-plist
@@ -21,6 +21,7 @@ lib/libupnp.la
lib/libupnp.so
lib/libupnp.so.2
libdata/pkgconfig/libupnp.pc
+%%PORTDOCS%%%%DOCSDIR%%/IXML_Programming_Guide.pdf
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
@@ -35,6 +36,259 @@ libdata/pkgconfig/libupnp.pc
%%PORTDOCS%%%%DOCSDIR%%/examples/upnp_tv_device.c
%%PORTDOCS%%%%DOCSDIR%%/examples/upnp_tv_device.h
%%PORTDOCS%%%%DOCSDIR%%/examples/upnp_tv_device_main.c
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/DOMInterfaces.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/General.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/IXMLAPI.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/InterfaceitAttr.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/InterfaceitCDATASection.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/InterfaceitDocument.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/InterfaceitElement.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/InterfaceitNamedNodeMap.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/InterfaceitNode.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/InterfaceitNodeList.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/Introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/License.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/icon1.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/icon2.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlAttr_free.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlCDATASection_free.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlCDATASection_init.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlCloneDOMString.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createAttribute.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createAttributeEx.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createAttributeNS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createAttributeNSEx.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createCDATASection.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createCDATASectionEx.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createDocument.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createDocumentEx.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createElement.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createElementEx.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createElementNS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createElementNSEx.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createTextNode.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createTextNodeEx.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_free.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_getElementById.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_getElementsByTagName.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_getElementsByTagNameNS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_importNode.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_init.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocumenttoString.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_free.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_getAttribute.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_getAttributeNS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_getAttributeNode.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_getAttributeNodeNS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_getElementsByTagName.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_getElementsByTagNameNS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_getTagName.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_hasAttribute.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_hasAttributeNS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_init.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_removeAttribute.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_removeAttributeNS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_removeAttributeNode.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_setAttribute.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_setAttributeNS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_setAttributeNode.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_setAttributeNodeNS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlFreeDOMString.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlLoadDocument.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlLoadDocumentEx.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_free.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_getLength.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_getNamedItem.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_getNamedItemNS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_item.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_removeNamedItem.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_removeNamedItemNS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_setNamedItem.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_setNamedItemNS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNodeList_free.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNodeList_item.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNodeList_length.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_appendChild.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_cloneNode.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_free.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getAttributes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getChildNodes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getFirstChild.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getLastChild.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getLocalName.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getNamespaceURI.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getNextSibling.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getNodeName.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getNodeType.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getNodeValue.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getOwnerDocument.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getParentNode.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getPrefix.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getPreviousSibling.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_hasAttributes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_hasChildNodes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_insertBefore.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_removeChild.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_replaceChild.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_setNodeValue.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNodetoString.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlParseBuffer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlParseBufferEx.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlPrintDocument.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlPrintNode.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlRelaxParser.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ixml/toc.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/AboutCallbacks.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/ConstantsStructuresandTypes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Control.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/ControlPointHTTPAPI.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Discovery.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Errorcodes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Eventing.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/General.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/InitializationandRegistration.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/License.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/OptionalToolAPIs.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/TheAPI.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNPREG_BUF_DESC.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNPREG_FILENAME_DESC.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNPREG_URL_DESC.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_CONTROL_ACTION_COMPLETE.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_CONTROL_ACTION_REQUEST.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_CONTROL_GET_VAR_COMPLETE.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_CONTROL_GET_VAR_REQUEST.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_DISCOVERY_ADVERTISEMENT_ALIVE.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_DISCOVERY_ADVERTISEMENT_BYEBYE.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_DISCOVERY_SEARCH_RESULT.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_DISCOVERY_SEARCH_TIMEOUT.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_EVENT_AUTORENEWAL_FAILED.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_EVENT_RECEIVED.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_EVENT_RENEWAL_COMPLETE.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_EVENT_SUBSCRIBE_COMPLETE.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_EVENT_SUBSCRIPTION_EXPIRED.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_EVENT_SUBSCRIPTION_REQUEST.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_EVENT_UNSUBSCRIBE_COMPLETE.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_ALREADY_REGISTERED-120.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_BAD_HTTPMSG-119.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_BAD_RESPONSE-113.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_CANCELED-210.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_EXT_NOT_XML-504.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_FILE_NOT_FOUND-502.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_FILE_READ_ERROR-503.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_FINISH-116.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INIT-105.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INIT_FAILED-117.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INTERNAL_ERROR-911.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INVALID_ACTION-115.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INVALID_ARGUMENT-501.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INVALID_DESC-107.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INVALID_HANDLE-100.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INVALID_PARAM-101.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INVALID_SERVICE-111.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INVALID_URL-108.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_LISTEN-206.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_NETWORK_ERROR-200.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_NOTIFY_UNACCEPTED-303.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_NOT_FOUND-507.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_OUTOF_HANDLE-102.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_OUTOF_MEMORY-104.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_OUTOF_SOCKET-205.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_SOCKET_BIND-203.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_SOCKET_CONNECT-204.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_SOCKET_ERROR-208.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_SOCKET_READ-202.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_SOCKET_WRITE-201.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_SUBSCRIBE_UNACCEPTED-301.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_SUCCESS0.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_TIMEDOUT-207.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_UNSUBSCRIBE_UNACCAPTED-302.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_S_ALL.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_S_DEVICE.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_S_ROOT.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_S_SERVICE.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPnP_EventType.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpAcceptSubscription.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpAcceptSubscriptionExt.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpAddToAction.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpAddToActionResponse.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpAddToPropertySet.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpAddVirtualDir.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpCancelHttpGet.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpClient_Handle.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpCloseHttpGet.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpCloseHttpPost.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpCreatePropertySet.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpDevice_Handle.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpDownloadUrlItem.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpDownloadXmlDoc.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpEnableWebserver.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpFinish.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpGetErrorMessage.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpGetServerIpAddress.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpGetServerPort.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpGetServiceVarStatus.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpGetServiceVarStatusAsync.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpHttpGetProgress.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpInit.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpIsWebserverEnabled.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpMakeAction.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpMakeActionResponse.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpNotify.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpNotifyExt.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpOpenHttpGet.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpOpenHttpGetEx.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpOpenHttpGetProxy.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpOpenHttpPost.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpReadHttpGet.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpRegisterClient.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpRegisterRootDevice.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpRegisterRootDevice2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpRemoveAllVirtualDirs.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpRemoveVirtualDir.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpRenewSubscription.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpRenewSubscriptionAsync.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpResolveURL.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSearchAsync.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSendAction.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSendActionAsync.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSendActionEx.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSendActionExAsync.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSendAdvertisement.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSetContentLength.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSetMaxContentLength.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSetMaxSubscriptionTimeOut.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSetMaxSubscriptions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSetVirtualDirCallbacks.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSetWebServerRootDir.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSubscribe.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSubscribeAsync.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpUnRegisterClient.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpUnRegisterRootDevice.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpUnSubscribe.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpUnSubscribeAsync.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpVirtualDirCallbacks.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpWriteHttpPost.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_Action_Request.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_DescType.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_Discovery.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_Event.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_Event_Subscribe.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_FunPtr.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_SID44.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_SType.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_State_Var_Complete.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_State_Var_Request.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_Subscription_Request.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/WebServerAPI.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/icon1.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/icon2.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/upnp/toc.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/upnp
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/ixml
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%/examples
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/upnp