aboutsummaryrefslogtreecommitdiffstats
path: root/devel/upp
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-10-07 17:17:33 +0800
committermiwi <miwi@FreeBSD.org>2006-10-07 17:17:33 +0800
commit8125f87922f69a96efbbf1c646ded4a38f5d3741 (patch)
tree2b9ed6dca7d171d954287a948397aa510dfd1205 /devel/upp
parent951aeb2cef1ddeddbddae0c3f2c332eb5a675097 (diff)
downloadfreebsd-ports-gnome-8125f87922f69a96efbbf1c646ded4a38f5d3741.tar.gz
freebsd-ports-gnome-8125f87922f69a96efbbf1c646ded4a38f5d3741.tar.zst
freebsd-ports-gnome-8125f87922f69a96efbbf1c646ded4a38f5d3741.zip
- Added socket patch to fix (non-)blocking behaviour
- Fixed a few library dependencies for upp packages - Changed SDL usage (to reflect recent change in devel/sdl12) PR: ports/104030 Submitted by: Matthias Sund <m.sund@arcor.de> (maintainer)
Diffstat (limited to 'devel/upp')
-rw-r--r--devel/upp/Makefile3
-rw-r--r--devel/upp/files/patch-examples-SDLExample-SDLExample.upp10
-rw-r--r--devel/upp/files/patch-examples-SDLExample-main.cpp11
-rw-r--r--devel/upp/files/patch-uppsrc-Core-Core.upp11
-rw-r--r--devel/upp/files/patch-uppsrc-Draw-Draw.upp15
-rw-r--r--devel/upp/files/patch-uppsrc-Web-socket.cpp42
6 files changed, 74 insertions, 18 deletions
diff --git a/devel/upp/Makefile b/devel/upp/Makefile
index 3dce953e6451..92a9b88d0fa4 100644
--- a/devel/upp/Makefile
+++ b/devel/upp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= upp
PORTVERSION= 605
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -24,6 +24,7 @@ USE_ZIP= yes
USE_DOS2UNIX= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
+USE_XLIB= yes
.if defined(WITH_SDL)
USE_SDL= sdl
diff --git a/devel/upp/files/patch-examples-SDLExample-SDLExample.upp b/devel/upp/files/patch-examples-SDLExample-SDLExample.upp
index dd2d4e739669..dce9c841ab27 100644
--- a/devel/upp/files/patch-examples-SDLExample-SDLExample.upp
+++ b/devel/upp/files/patch-examples-SDLExample-SDLExample.upp
@@ -1,12 +1,10 @@
---- examples/SDLExample/SDLExample.upp.orig Tue Jun 6 20:57:56 2006
-+++ examples/SDLExample/SDLExample.upp Tue Jun 6 21:18:25 2006
-@@ -7,6 +7,10 @@
+--- examples/SDLExample/SDLExample.upp.orig Wed Oct 4 23:58:12 2006
++++ examples/SDLExample/SDLExample.upp Thu Oct 5 00:00:08 2006
+@@ -7,6 +7,8 @@
library(LINUX) "SDL SDLmain";
-+library(FREEBSD) "SDL-1.1 m vgl X11 Xext vga aa usbhid";
-+
-+link(FREEBSD) -pthread;
++library(FREEBSD) "SDL SDLmain X11 Xext Xrandr Xrender vga vgl aa usbhid ncurses";
+
file
main.cpp;
diff --git a/devel/upp/files/patch-examples-SDLExample-main.cpp b/devel/upp/files/patch-examples-SDLExample-main.cpp
deleted file mode 100644
index 4248aa882a27..000000000000
--- a/devel/upp/files/patch-examples-SDLExample-main.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- examples/SDLExample/main.cpp.orig Tue Jun 6 21:18:47 2006
-+++ examples/SDLExample/main.cpp Tue Jun 6 21:18:58 2006
-@@ -3,7 +3,7 @@
- #ifdef PLATFORM_WIN32
- #include <SDL.h>
- #else
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
- #endif
-
- const int maxpoint = 1000;
diff --git a/devel/upp/files/patch-uppsrc-Core-Core.upp b/devel/upp/files/patch-uppsrc-Core-Core.upp
new file mode 100644
index 000000000000..25fe2c47bcdc
--- /dev/null
+++ b/devel/upp/files/patch-uppsrc-Core-Core.upp
@@ -0,0 +1,11 @@
+--- uppsrc/Core/Core.upp.orig Thu Oct 5 00:00:40 2006
++++ uppsrc/Core/Core.upp Thu Oct 5 00:01:06 2006
+@@ -7,6 +7,8 @@
+
+ library(LINUX) "pthread dl";
+
++library(FREEBSD) "pthread";
++
+ library(WIN32) "advapi32 shell32 winmm";
+
+ library(SOLARIS) "posix4 dl";
diff --git a/devel/upp/files/patch-uppsrc-Draw-Draw.upp b/devel/upp/files/patch-uppsrc-Draw-Draw.upp
new file mode 100644
index 000000000000..d3a7118bb6d9
--- /dev/null
+++ b/devel/upp/files/patch-uppsrc-Draw-Draw.upp
@@ -0,0 +1,15 @@
+--- uppsrc/Draw/Draw.upp.orig Thu Oct 5 00:01:36 2006
++++ uppsrc/Draw/Draw.upp Thu Oct 5 00:03:16 2006
+@@ -11,11 +11,9 @@
+
+ library(FREEBSD) X11;
+
+-library(FREEBSD !XLFD) "Xft fontconfig";
++library(FREEBSD !XLFD) "Xft fontconfig Xrender freetype expat";
+
+ library(LINUX !XLFD !SHARED) "fontconfig Xrender freetype expat";
+-
+-library(FREEBSD) "Xrender freetype expat";
+
+ file
+ Draw.h,
diff --git a/devel/upp/files/patch-uppsrc-Web-socket.cpp b/devel/upp/files/patch-uppsrc-Web-socket.cpp
new file mode 100644
index 000000000000..8a84547e90fc
--- /dev/null
+++ b/devel/upp/files/patch-uppsrc-Web-socket.cpp
@@ -0,0 +1,42 @@
+--- uppsrc/Web/socket.cpp.orig Thu Oct 5 00:43:27 2006
++++ uppsrc/Web/socket.cpp Thu Oct 5 20:33:14 2006
+@@ -12,6 +12,12 @@
+ {
+ NB_TIMEOUT = 30000,
+ SOCKBUFSIZE = 65536,
++
++#ifdef PLATFORM_WIN32
++ IS_BLOCKED = SOCKERR(EWOULDBLOCK),
++#else
++ IS_BLOCKED = SOCKERR(EINPROGRESS),
++#endif
+ };
+
+ static bool LogSocketFlag = false;
+@@ -202,7 +208,7 @@
+ return true;
+
+ int err = GetLastError();
+- if(err != SOCKERR(EWOULDBLOCK)) {
++ if(err != IS_BLOCKED) {
+ SetSockError(NFormat("connect(%s:%d)", host, port));
+ SLOG("Socket::Data::OpenClient -> connect error, returning false");
+ return false;
+@@ -274,7 +280,7 @@
+ #endif
+ if(res == 0)
+ is_eof = true;
+- else if(res < 0 && GetLastError() != SOCKERR(EWOULDBLOCK))
++ else if(res < 0 && GetLastError() != IS_BLOCKED)
+ SetSockError("recv");
+ return res;
+ }
+@@ -282,7 +288,7 @@
+ int Socket::Data::Write(const void *buf, int amount)
+ {
+ int res = send(socket, (const char *)buf, amount, 0);
+- if(res == 0 || res < 0 && GetLastError() != SOCKERR(EWOULDBLOCK))
++ if(res == 0 || res < 0 && GetLastError() != IS_BLOCKED)
+ SetSockError("send");
+ return res;
+ }