aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ups-debug
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1999-05-10 02:00:35 +0800
committerobrien <obrien@FreeBSD.org>1999-05-10 02:00:35 +0800
commit83a5716685a068d67c5762cdf2c83e0eba085ef4 (patch)
treea42e58f1d563df1e60ff41a69f8e0f74bb4b01ae /devel/ups-debug
parentb134e1eddff69de8d9b078884dce4e74889a6bb5 (diff)
downloadfreebsd-ports-gnome-83a5716685a068d67c5762cdf2c83e0eba085ef4.tar.gz
freebsd-ports-gnome-83a5716685a068d67c5762cdf2c83e0eba085ef4.tar.zst
freebsd-ports-gnome-83a5716685a068d67c5762cdf2c83e0eba085ef4.zip
Update to 3.33-03. Ups now supports both ELF and a.out debugging on FreeBSD.
Diffstat (limited to 'devel/ups-debug')
-rw-r--r--devel/ups-debug/files/patch-0429
-rw-r--r--devel/ups-debug/pkg-plist1
2 files changed, 9 insertions, 21 deletions
diff --git a/devel/ups-debug/files/patch-04 b/devel/ups-debug/files/patch-04
index 01fc130159aa..4fcb59509d60 100644
--- a/devel/ups-debug/files/patch-04
+++ b/devel/ups-debug/files/patch-04
@@ -1,19 +1,6 @@
---- ups/xc_builtins.c.orig Thu Oct 1 12:30:57 1998
-+++ ups/xc_builtins.c Fri Nov 13 20:08:21 1998
-@@ -33,7 +33,11 @@
- #include <ctype.h>
- #include <errno.h>
-
--#if defined (OS_SUNOS_5) && defined (__CLCC__)
-+#if defined(OS_BSD44)
-+#include <sys/ioctl.h>
-+#endif
-+
-+#if defined (OS_SUNOS_5) && defined (__CLCC__) || defined(OS_BSD44)
- #include <unistd.h>
- #endif
-
-@@ -77,7 +81,7 @@
+--- ups/xc_builtins.c.orig Fri Feb 19 07:14:51 1999
++++ ups/xc_builtins.c Sun May 9 10:45:18 1999
+@@ -61,7 +61,7 @@
static int builtin_read PROTO((int fd, void *buf, size_t nbytes));
static int builtin_write PROTO((int fd, const void *buf, size_t nbytes));
static int builtin_pipe PROTO((int *fds));
@@ -22,16 +9,16 @@
static int builtin_fcntl PROTO((int fd, int cmd, char *arg));
static int builtin_dup2 PROTO((int fd, int newfd));
static int builtin_dup PROTO((int fd));
-@@ -87,7 +91,7 @@
- #ifdef BUILTIN_FLOCK
+@@ -71,7 +71,7 @@
+ #if HAVE_FLOCK
static int builtin_flock PROTO((int fd, int op));
#endif
-static int builtin_ftruncate PROTO((int fd, long length));
+static int builtin_ftruncate PROTO((int fd, off_t length));
static int builtin_ioctl PROTO((int fd, unsigned cmd, caddr_t arg));
static int builtin_fstat PROTO((int fd, struct stat *stbuf));
- static Display *builtin_XOpenDisplay PROTO((const char *display_name));
-@@ -298,7 +302,7 @@
+ #if HAVE_X_WINDOWS
+@@ -306,7 +306,7 @@
static int
builtin_ftruncate(fd, length)
int fd;
@@ -40,7 +27,7 @@
{
return fd_ok(fd) ? ftruncate(fd, (off_t)length) : -1;
}
-@@ -321,7 +325,7 @@
+@@ -329,7 +329,7 @@
return res;
}
diff --git a/devel/ups-debug/pkg-plist b/devel/ups-debug/pkg-plist
index 70d27a2c6ff6..bb100b85d281 100644
--- a/devel/ups-debug/pkg-plist
+++ b/devel/ups-debug/pkg-plist
@@ -2,3 +2,4 @@ bin/ups
share/doc/ups/FAQ
share/doc/ups/README
share/doc/ups/Ups
+@dirrm share/doc/ups