aboutsummaryrefslogtreecommitdiffstats
path: root/devel/varconf/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2003-07-08 04:15:37 +0800
committeroliver <oliver@FreeBSD.org>2003-07-08 04:15:37 +0800
commite38167ffe6d38efd08e9bdf92121a9d7f479077b (patch)
tree50184f9735d0e3d56ef1180a82d73e6f0b13556f /devel/varconf/Makefile
parent0ad7e52b70aaf5af25445e7c09d978007b4693ae (diff)
downloadfreebsd-ports-gnome-e38167ffe6d38efd08e9bdf92121a9d7f479077b.tar.gz
freebsd-ports-gnome-e38167ffe6d38efd08e9bdf92121a9d7f479077b.tar.zst
freebsd-ports-gnome-e38167ffe6d38efd08e9bdf92121a9d7f479077b.zip
update varconf to 0.6.0
Diffstat (limited to 'devel/varconf/Makefile')
-rw-r--r--devel/varconf/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/devel/varconf/Makefile b/devel/varconf/Makefile
index 8a8d60a67871..f28e3d8c636f 100644
--- a/devel/varconf/Makefile
+++ b/devel/varconf/Makefile
@@ -6,20 +6,32 @@
#
PORTNAME= varconf
-PORTVERSION= 0.5.4
+PORTVERSION= 0.6.0
CATEGORIES= devel
MASTER_SITES= ftp://victor.worldforge.org/%SUBDIR%/ \
http://purple.worldforge.org/wf/downloads/libs/varconf/ \
- http://grimicus.dyndns.org:8080/%SUBDIR%/ \
ftp://ftp.fr.gnome.org/%SUBDIR%/
MASTER_SITE_SUBDIR= pub/worldforge/libs/varconf
-MAINTAINER= oliver@freebsd.org
+MAINTAINER= oliver@FreeBSD.org
COMMENT= A Configuration System for the STAGE Server
-LIB_DEPENDS= sigc.1:${PORTSDIR}/devel/libsigc++
+LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12
USE_LIBTOOL= YES
+USE_REINPLACE= YES
GNU_CONFIGURE= YES
+post-patch:
+ @${REINPLACE_CMD} -e 's|^doc_DATA = .*|#&|g' \
+ -e 's|\(^pkgconfigdir =\) .*|\1 ${PREFIX}/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in README COPYING AUTHORS THANKS NEWS
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>