aboutsummaryrefslogtreecommitdiffstats
path: root/devel/viewvc/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-24 20:40:03 +0800
committeredwin <edwin@FreeBSD.org>2003-08-24 20:40:03 +0800
commit56aea0b2f23112bcb4e6f2bf8287efa119c48175 (patch)
tree22ca07022c1c596278972b0b99845612bc860ef5 /devel/viewvc/Makefile
parent5eece73963fd8d14568162f3a5dbbd912bdc2336 (diff)
downloadfreebsd-ports-gnome-56aea0b2f23112bcb4e6f2bf8287efa119c48175.tar.gz
freebsd-ports-gnome-56aea0b2f23112bcb4e6f2bf8287efa119c48175.tar.zst
freebsd-ports-gnome-56aea0b2f23112bcb4e6f2bf8287efa119c48175.zip
i[Patch Port] devel/viewcvs (unforbidden)
This patch solves two problems of the actual ViewCVs port: 1. it is forbidden as it is CSS-vulnerable, ViewCVS's CVS contains a patch but a new release was still not created by the authors 2. it overwrites the configuration files on installation To solve problem 1 I "back-ported" the patch 1.117 to lib/viewcvs.py http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/viewcvs/viewcvs/lib/viewcvs.py#rev1.117 as the author itself says, it solves the problem: http://mailman.lyra.org/pipermail/viewcvs-dev/2002-July/000776.html To solve problem 2 I changed the install script to install viewcvs.conf.dist directly instead of renaming it to viewcvs.conf, leaving it up to the user and specifying it in the pkg-message. PR: ports/51464 Submitted by: Lapo Luchini <lapo@m4d.sm>
Diffstat (limited to 'devel/viewvc/Makefile')
-rw-r--r--devel/viewvc/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/devel/viewvc/Makefile b/devel/viewvc/Makefile
index d45725cad75f..ba1267d87a00 100644
--- a/devel/viewvc/Makefile
+++ b/devel/viewvc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= viewcvs
PORTVERSION= 0.9.2
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,17 +20,12 @@ NO_BUILD= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
INSTDIR?= ${PORTNAME}-${PORTVERSION}
PLIST_SUB= INSTDIR=${INSTDIR}
-FORBIDDEN= "due to cross-site scripting vulnerabilities"
do-install:
@ cd ${WRKSRC} && INSTDIR=${PREFIX}/${INSTDIR} ${PYTHON_CMD} viewcvs-install
post-install:
@ ${SED} -e "s:%%INSTDIR%%:${PREFIX}/${INSTDIR}:g" pkg-message >${PKGMESSAGE}
-.if !defined(BATCH)
- @ ${ECHO}
@ ${CAT} ${PKGMESSAGE}
- @ ${ECHO}
-.endif
.include <bsd.port.mk>