aboutsummaryrefslogtreecommitdiffstats
path: root/devel/viewvc
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-01-17 18:16:48 +0800
committervs <vs@FreeBSD.org>2005-01-17 18:16:48 +0800
commit600cc13e5f42d86bf989ecf2208401152095939a (patch)
tree658ce5ac40d38f7f0d7c31cfd0f5c9f92a2cb61b /devel/viewvc
parent288ba57347ae7059b2963c4e0fc30777fd5271d7 (diff)
downloadfreebsd-ports-gnome-600cc13e5f42d86bf989ecf2208401152095939a.tar.gz
freebsd-ports-gnome-600cc13e5f42d86bf989ecf2208401152095939a.tar.zst
freebsd-ports-gnome-600cc13e5f42d86bf989ecf2208401152095939a.zip
The "-W html" args to enscript no longer seem to work, but the
longer form of "--language=html" does: http://mailman.lyra.org/pipermail/viewcvs/2003q3/002189.html PR: ports/75993 Submitted by: Tim Bishop
Diffstat (limited to 'devel/viewvc')
-rw-r--r--devel/viewvc/Makefile2
-rw-r--r--devel/viewvc/files/patch-lib::viewcvs.py30
2 files changed, 25 insertions, 7 deletions
diff --git a/devel/viewvc/Makefile b/devel/viewvc/Makefile
index 5ae981e9066b..c3d584ad2056 100644
--- a/devel/viewvc/Makefile
+++ b/devel/viewvc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= viewcvs
PORTVERSION= 0.9.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/devel/viewvc/files/patch-lib::viewcvs.py b/devel/viewvc/files/patch-lib::viewcvs.py
index 0e1123ec43a1..e9d2e4ad4cff 100644
--- a/devel/viewvc/files/patch-lib::viewcvs.py
+++ b/devel/viewvc/files/patch-lib::viewcvs.py
@@ -1,5 +1,5 @@
---- lib/viewcvs.py.orig Tue Jan 15 10:35:55 2002
-+++ lib/viewcvs.py Fri Apr 25 19:18:22 2003
+--- lib/viewcvs.py.orig Tue Jan 15 09:35:55 2002
++++ lib/viewcvs.py Sun Jan 9 13:35:45 2005
@@ -174,6 +174,10 @@
# parse the query params into a dictionary (and use defaults)
query_dict = default_settings.copy()
@@ -11,11 +11,10 @@
query_dict[name] = values[0]
# set up query strings, prefixed by question marks and ampersands
-@@ -228,6 +232,77 @@
- self.branch = branch
+@@ -229,6 +233,77 @@
self.taginfo = taginfo
-+
+
+def _validate_param(name, value):
+ """Validate whether the given value is acceptable for the param name.
+
@@ -86,6 +85,25 @@
+ 'rev' : _re_validate_revnum,
+ 'content-type' : _re_validate_mimetype,
+ }
-
++
class LogEntry:
"Hold state for each revision entry in an 'rlog' output."
+ def __init__(self, rev, date, author, state, changed, log):
+@@ -478,7 +553,7 @@
+ def markup_stream_enscript(lang, fp):
+ sys.stdout.flush()
+ enscript = popen.pipe_cmds([(os.path.normpath(os.path.join(cfg.options.enscript_path,'enscript')),
+- '--color', '-W', 'html', '-E' + lang, '-o',
++ '--color', '--language=html', '-E' + lang, '-o',
+ '-', '-'),
+ ('sed', '-n', '/^<PRE>$/,/<\\/PRE>$/p')])
+
+@@ -494,7 +569,7 @@
+ except IOError, v:
+ print "<h3>Failure during use of an external program:</h3>"
+ print "<pre>"
+- print os.path.normpath(os.path.join(cfg.options.enscript_path,'enscript')) + " --color -W html -E"+lang+" -o - -"
++ print os.path.normpath(os.path.join(cfg.options.enscript_path,'enscript')) + " --color --language=html -E"+lang+" -o - -"
+ print "</pre>"
+ raise
+