aboutsummaryrefslogtreecommitdiffstats
path: root/devel/wftk/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-07-02 21:47:31 +0800
committerijliao <ijliao@FreeBSD.org>2002-07-02 21:47:31 +0800
commitee79706e611b50949d5e5148a4111b2748578e6a (patch)
treee9963cb8169f17136da40e24c99573a655cb1518 /devel/wftk/Makefile
parent053822d3b95fc4035bc83015beb5cbba4d5e6de4 (diff)
downloadfreebsd-ports-gnome-ee79706e611b50949d5e5148a4111b2748578e6a.tar.gz
freebsd-ports-gnome-ee79706e611b50949d5e5148a4111b2748578e6a.tar.zst
freebsd-ports-gnome-ee79706e611b50949d5e5148a4111b2748578e6a.zip
upgrade to 0.4.1
PR: 40083 Submitted by: maintainer
Diffstat (limited to 'devel/wftk/Makefile')
-rw-r--r--devel/wftk/Makefile44
1 files changed, 37 insertions, 7 deletions
diff --git a/devel/wftk/Makefile b/devel/wftk/Makefile
index 3814e11514e1..f9392bdd1c29 100644
--- a/devel/wftk/Makefile
+++ b/devel/wftk/Makefile
@@ -6,21 +6,51 @@
#
PORTNAME= libuta
-PORTVERSION= 0.3.38
+PORTVERSION= 0.4.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= lehmann@ans-netz.de
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
sigc.1:${PORTSDIR}/devel/libsigc++ \
- SDL-1.1.4:${PORTSDIR}/devel/sdl12 \
- SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
+ SDL-1.1.4:${PORTSDIR}/devel/sdl12
USE_FREETYPE= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --prefix=${PREFIX}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype1"
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-.include <bsd.port.mk>
+CONFIGURE_ENV= SDL_CONFIG="${LOCALBASE}/bin/sdl11-config" \
+ LIBS="-L${LOCALBASE}/lib"
+
+SDL11_FILES= configure uta/color.h uta/event.h uta/keysym.h uta/mutex.h \
+ uta/pixelformat.h uta/rect.h uta/sge_blib.cc uta/sge_blib.h \
+ uta/sge_draw.cc uta/sge_draw.h uta/sound.h uta/surface_io.cc \
+ uta/surface.h uta/timer.cc
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libSDL_mixer.so.2)
+WITH_SDL_MIXER= yes
+.endif
+
+.if defined(WITH_SDL_MIXER)
+LIB_DEPENDS+= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
+.endif
+
+
+pre-everything::
+ @${ECHO} ""
+ @${ECHO} "You may use the following build options:"
+ @${ECHO} ""
+ @${ECHO} " WITH_SDL_MIXER=yes Enable music and sound support"
+ @${ECHO} ""
+
+post-patch:
+.for i in ${SDL11_FILES}
+ ${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/$i
+.endfor
+
+.include <bsd.port.post.mk>