aboutsummaryrefslogtreecommitdiffstats
path: root/devel/wfut
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-10-06 01:59:01 +0800
committeroliver <oliver@FreeBSD.org>2005-10-06 01:59:01 +0800
commit408a105782104c2298359f9dfab54c83de7c40f5 (patch)
treeecea0f3ab1408173771e3a977169d236199d9998 /devel/wfut
parent21c3eb4c2c45dd3ee4d90e6e69fe5ead3f940dd4 (diff)
downloadfreebsd-ports-gnome-408a105782104c2298359f9dfab54c83de7c40f5.tar.gz
freebsd-ports-gnome-408a105782104c2298359f9dfab54c83de7c40f5.tar.zst
freebsd-ports-gnome-408a105782104c2298359f9dfab54c83de7c40f5.zip
Software updater tool for WorldForge applications.
WFUT allows the automatic updating of "channels" which are available on a server. The channels are specified by an XML file (which also has an XSL file associated with it for viewing in a web browser). Each channel has an associated XML document listing the files available in the channel and the current version number.WFUT compares this file list with a similar file on the local machine to determine what files need updating. WFUT performs a CRC32 check on each file downloaded before overwriting any existing ones. WFUT keeps a list of files downloaded in a temporary file (which will not be completely valid XML due to missing end tag) in something happens during an update which does not allow the local list to be saved. WWW: http://www.worldforge.org/dev/eng/tools/wfut
Diffstat (limited to 'devel/wfut')
-rw-r--r--devel/wfut/Makefile31
-rw-r--r--devel/wfut/distinfo2
-rw-r--r--devel/wfut/pkg-descr13
-rw-r--r--devel/wfut/pkg-plist4
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/wfut/Makefile b/devel/wfut/Makefile
new file mode 100644
index 000000000000..b316ee88ab3e
--- /dev/null
+++ b/devel/wfut/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: wfut
+# Date Created: 04 Oct 2005
+# Whom: Oliver Lehmann <oliver@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wfut
+PORTVERSION= 38
+CATEGORIES= devel java
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= oliver
+
+MAINTAINER= oliver@FreeBSD.org
+COMMENT= Software updater tool for WorldForge applications
+
+USE_BZIP2= yes
+USE_JAVA= 1.5+
+NO_BUILD= yes
+USE_X_PREFIX= yes
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/WFUT.jar ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docfile in README COPYING
+ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/wfut/distinfo b/devel/wfut/distinfo
new file mode 100644
index 000000000000..0c2dfb6f97c9
--- /dev/null
+++ b/devel/wfut/distinfo
@@ -0,0 +1,2 @@
+MD5 (wfut-38.tar.bz2) = cd2fbfb93b208a97772060bc88757d1b
+SIZE (wfut-38.tar.bz2) = 109962
diff --git a/devel/wfut/pkg-descr b/devel/wfut/pkg-descr
new file mode 100644
index 000000000000..310d1b47ee6d
--- /dev/null
+++ b/devel/wfut/pkg-descr
@@ -0,0 +1,13 @@
+Software updater tool for WorldForge applications.
+WFUT allows the automatic updating of "channels" which are available on a
+server. The channels are specified by an XML file (which also has an XSL file
+associated with it for viewing in a web browser). Each channel has an
+associated XML document listing the files available in the channel and the
+current version number.WFUT compares this file list with a similar file on the
+local machine to determine what files need updating.
+WFUT performs a CRC32 check on each file downloaded before overwriting any
+existing ones. WFUT keeps a list of files downloaded in a temporary file (which
+will not be completely valid XML due to missing end tag) in something happens
+during an update which does not allow the local list to be saved.
+
+WWW: http://www.worldforge.org/dev/eng/tools/wfut
diff --git a/devel/wfut/pkg-plist b/devel/wfut/pkg-plist
new file mode 100644
index 000000000000..bb16b8c43e12
--- /dev/null
+++ b/devel/wfut/pkg-plist
@@ -0,0 +1,4 @@
+bin/WFUT.jar
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%@dirrm %%DOCSDIR%%