aboutsummaryrefslogtreecommitdiffstats
path: root/devel/xfc/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2005-06-02 01:10:24 +0800
committerdemon <demon@FreeBSD.org>2005-06-02 01:10:24 +0800
commited46ae2cf802a78bba6b0699bd53081d55a10b7b (patch)
tree575891f900ca113183306638b185899853352a3e /devel/xfc/Makefile
parent4411b01fb03a6b5dd8ac7bab1f6599cd2db7bc1a (diff)
downloadfreebsd-ports-gnome-ed46ae2cf802a78bba6b0699bd53081d55a10b7b.tar.gz
freebsd-ports-gnome-ed46ae2cf802a78bba6b0699bd53081d55a10b7b.tar.zst
freebsd-ports-gnome-ed46ae2cf802a78bba6b0699bd53081d55a10b7b.zip
New port: Xfce Foundation Classes.
The Xfce Foundation Classes (XFC) is a set of well integrated C++ classes for developing Xfce applications on UNIX-like operating systems. XFC combines the power of GTK+ and the power of C++ into a state-of-the-art application development framework for the Xfce Desktop Environment. XFC judiciously uses C++ language features to avoid layering on too much extra C++ complexity. Its API is easy to understand and use, and should feel immediately familiar to most GTK+ programmers.
Diffstat (limited to 'devel/xfc/Makefile')
-rw-r--r--devel/xfc/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/xfc/Makefile b/devel/xfc/Makefile
new file mode 100644
index 000000000000..f9a43d20867e
--- /dev/null
+++ b/devel/xfc/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Xfce Foundation Classes
+# Date created: 1 Jun 2005
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfc
+PORTVERSION= 4.3.1
+CATEGORIES= devel xfce
+MASTER_SITES= http://xfc.xfce.org/download/${PORTVERSION}/src/
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= The Xfce Foundation Classes
+
+LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_GCC= 3.3+
+USE_GNOME= glib20 gtk20 atk pango pkgconfig libglade2 gnomehack
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
+ CPPFLAGS=-I${LOCALBASE}/include \
+ LIBS=-L${LOCALBASE}/lib
+
+.include <bsd.port.mk>