aboutsummaryrefslogtreecommitdiffstats
path: root/devel/xwpe
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-07-14 01:53:44 +0800
committerijliao <ijliao@FreeBSD.org>2002-07-14 01:53:44 +0800
commit23990ba4f6fc99c8e44da1ca1283f5e2e531c7c6 (patch)
tree222d8ef0fb85add571f80343cf36415de9a5bfe7 /devel/xwpe
parent952d041de60f4bcdf298f22daf1dd631b8249074 (diff)
downloadfreebsd-ports-gnome-23990ba4f6fc99c8e44da1ca1283f5e2e531c7c6.tar.gz
freebsd-ports-gnome-23990ba4f6fc99c8e44da1ca1283f5e2e531c7c6.tar.zst
freebsd-ports-gnome-23990ba4f6fc99c8e44da1ca1283f5e2e531c7c6.zip
upgrade to 1.5.29a
PR: 40493 Submitted by: Ports Fury
Diffstat (limited to 'devel/xwpe')
-rw-r--r--devel/xwpe/Makefile23
-rw-r--r--devel/xwpe/distinfo2
-rw-r--r--devel/xwpe/files/patch-0929
3 files changed, 27 insertions, 27 deletions
diff --git a/devel/xwpe/Makefile b/devel/xwpe/Makefile
index 1a120b4c4c46..6aa31633eb23 100644
--- a/devel/xwpe/Makefile
+++ b/devel/xwpe/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= xwpe
-PORTVERSION= 1.5.22a
+PORTVERSION= 1.5.29a
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
http://www.identicalsoftware.com/xwpe/ \
@@ -16,22 +16,23 @@ MASTER_SITE_SUBDIR= apps/editors/X
MAINTAINER= ports@FreeBSD.org
-# LD_LIBRARY_PATH is to deal with a braindead libX11.a search in configure
-# (once again author assumes too many Linux'isms)
-# it is not exptected to be set at runtime.
-MAKE_ENV= LD_LIBRARY_PATH="${X11BASE}/lib"
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= LD_LIBRARY_PATH="${X11BASE}/lib"
-CONFIGURE_ARGS= --libdir=${PREFIX}/share
USE_XLIB= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
-ALL_TARGET=
+GNU_CONFIGURE= yes
+CONFIGURE_ENV=
+CONFIGURE_ARGS= --libdir=${PREFIX}/share
+ALL_TARGET= # none
+
MAN1= xwpe.1
MLINKS= xwpe.1 xwe.1 \
xwpe.1 wpe.1 \
xwpe.1 we.1
-pre-configure:
- @${PERL} -pi.in -e "s:%%LOCALBASE%%:${LOCALBASE}:g" ${WRKSRC}/*.c
+post-patch:
+.for file in we_prog.c we_fl_unix.c
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/${file}
+.endfor
.include <bsd.port.mk>
diff --git a/devel/xwpe/distinfo b/devel/xwpe/distinfo
index f85db224511d..1ffb1ecb45ad 100644
--- a/devel/xwpe/distinfo
+++ b/devel/xwpe/distinfo
@@ -1 +1 @@
-MD5 (xwpe-1.5.22a.tar.gz) = 6f89fe3da57ac67fdff6297f078630b6
+MD5 (xwpe-1.5.29a.tar.gz) = fa529db0a3f1cc5ac35ff0cc7bb3f588
diff --git a/devel/xwpe/files/patch-09 b/devel/xwpe/files/patch-09
index cbfcb0c09d28..47bc8a4e0a37 100644
--- a/devel/xwpe/files/patch-09
+++ b/devel/xwpe/files/patch-09
@@ -1,5 +1,5 @@
---- we_fl_unix.c.orig Mon Dec 27 08:11:38 1999
-+++ we_fl_unix.c Sat Feb 26 05:55:53 2000
+--- we_fl_unix.c.orig Wed Jun 5 11:53:50 2002
++++ we_fl_unix.c Fri Jul 12 02:37:37 2002
@@ -13,6 +13,10 @@
#include <sys/stat.h>
#include <errno.h>
@@ -10,19 +10,18 @@
+
struct dirfile *e_make_win_list(FENSTER * f);
extern char *e_tmp_dir;
- extern int (*e_u_system) (char *exe);
-@@ -3546,7 +3550,13 @@
- if(getenv("MANPATH"))
- strcpy(manpath, getenv("MANPATH"));
- if(manpath[0] == '\0')
-- strcpy(manpath, "/usr/man:/usr/local/man");
-+ strcpy(manpath,
+
+@@ -3532,7 +3536,12 @@
+ }
+ if ((!manpath) || (manpath[0] == '\0'))
+ {
+- manpath = strdup("/usr/man:/usr/share/man:/usr/X11R6/man:/usr/local/man");
++ manpath = strdup(
+#if (defined(BSD) && (BSD >= 199306)) || (defined(sun) && defined(__svr4__))
-+ "/usr/share/man:%%LOCALBASE%%/man");
++ "/usr/share/man:%%X11BASE%%/man:%%LOCALBASE%%/man");
+#else
-+ "/usr/man:/usr/local/man");
++ "/usr/man:%%X11BASE%%/man:%%LOCALBASE%%/man");
+#endif
-+
- while(manpath[i])
- {
- for(n = 0; (subpath[n] = manpath[i]) && manpath[i] != PTHD; i++, n++);
+ }
+ /* Allocate the maximum possible rather than continually realloc. */
+ sustr = malloc(strlen(manpath) + 10);