aboutsummaryrefslogtreecommitdiffstats
path: root/devel/xxl
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-08-15 00:08:54 +0800
committerrafan <rafan@FreeBSD.org>2006-08-15 00:08:54 +0800
commite028c733d85e977f59a186018d94647295c45c59 (patch)
tree75b2f11ca1596af67c131c3286a7db69004e5a58 /devel/xxl
parent22fdcf2e1a45e013d7d519f03b92e0d92c5f5093 (diff)
downloadfreebsd-ports-gnome-e028c733d85e977f59a186018d94647295c45c59.tar.gz
freebsd-ports-gnome-e028c733d85e977f59a186018d94647295c45c59.tar.zst
freebsd-ports-gnome-e028c733d85e977f59a186018d94647295c45c59.zip
- Enable threading (it works well even on 4.x). Can be disabled
- Install supplimentary docs - Bump PORTREVISION for changes above - Fix comment - Replace deprecated variable (INSTALLS_SHLIB) - Pass maintainership to submitter PR: ports/101943 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Diffstat (limited to 'devel/xxl')
-rw-r--r--devel/xxl/Makefile34
1 files changed, 24 insertions, 10 deletions
diff --git a/devel/xxl/Makefile b/devel/xxl/Makefile
index f6779f93d79f..fade1be3e211 100644
--- a/devel/xxl/Makefile
+++ b/devel/xxl/Makefile
@@ -5,17 +5,31 @@
# $FreeBSD$
#
-PORTNAME= xxl
-PORTVERSION= 1.0.1
-CATEGORIES= devel
-MASTER_SITES= http://www.zork.org/software/
+PORTNAME= xxl
+PORTVERSION= 1.0.1
+PORTREVISION= 1
+CATEGORIES= devel
+MASTER_SITES= http://www.zork.org/software/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= C and C++ that provides exception handling and asset management
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= C/C++ library for exception handling and asset management
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --without-threads
-INSTALLS_SHLIB= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+GNU_CONFIGURE= yes
+USE_GNOME= gnometarget
+USE_LDCONFIG= yes
+
+.if defined(WITHOUT_THREADS)
+CONFIGURE_ARGS= --without-threads
+.endif
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= xxl.pdf xxl.html
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+.endif
.include <bsd.port.mk>