aboutsummaryrefslogtreecommitdiffstats
path: root/devel/zthread/Makefile
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-10-05 22:18:32 +0800
committervs <vs@FreeBSD.org>2005-10-05 22:18:32 +0800
commit117ca5f5a175d3f502d5a877725f6a4d7fd14ed5 (patch)
tree40cc88cfb1e09ed8f302fd3fc9c21a28443651fb /devel/zthread/Makefile
parent02e434b247601f57e3f152274b8b6f6224b27b99 (diff)
downloadfreebsd-ports-gnome-117ca5f5a175d3f502d5a877725f6a4d7fd14ed5.tar.gz
freebsd-ports-gnome-117ca5f5a175d3f502d5a877725f6a4d7fd14ed5.tar.zst
freebsd-ports-gnome-117ca5f5a175d3f502d5a877725f6a4d7fd14ed5.zip
Use less patches by virtue of MAKE_ARGS and USE_LIBTOOL.
USE_GCC=3.3+ and nuke static lib while here.
Diffstat (limited to 'devel/zthread/Makefile')
-rw-r--r--devel/zthread/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/devel/zthread/Makefile b/devel/zthread/Makefile
index cc3fefba2589..1411195c7fff 100644
--- a/devel/zthread/Makefile
+++ b/devel/zthread/Makefile
@@ -15,9 +15,12 @@ DISTNAME= ZThread-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A platform-independent object-oriented C++ threading library
+USE_INC_LIBTOOL_VER=15
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-ftime
+CONFIGURE_ARGS= --without-ftime --disable-static
USE_GMAKE= yes
+MAKE_ARGS+= INSTALL_PROGRAM="${INSTALL_SCRIPT}"
+MAKE_ENV+= SED=sed # req'd for LIBTOOL?!
INSTALLS_SHLIB= yes
.if !defined(NOPORTDOCS)
@@ -27,12 +30,15 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-USE_GCC= 3.3
+USE_GCC= 3.3+
.endif
post-extract:
@${FIND} ${WRKSRC} -name CVS -type d -delete
+post-patch:
+ @${CP} ${LTMAIN} ${WRKSRC}
+
post-install:
@${FIND} ${PREFIX}/include/zthread -type f | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}