aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-02-18 09:05:35 +0800
committermiwi <miwi@FreeBSD.org>2013-02-18 09:05:35 +0800
commit4bb6dd5b248a707c2ab39d75a3217be7ee7412e4 (patch)
tree78b15dbb3622130931ea7e3764a5138ab364fbf6 /devel
parentaf7568535561b829274e9f6b0432f4336862edd2 (diff)
downloadfreebsd-ports-gnome-4bb6dd5b248a707c2ab39d75a3217be7ee7412e4.tar.gz
freebsd-ports-gnome-4bb6dd5b248a707c2ab39d75a3217be7ee7412e4.tar.zst
freebsd-ports-gnome-4bb6dd5b248a707c2ab39d75a3217be7ee7412e4.zip
The PHP Project Wizard (PPW) is a commandline tool that can be used to generate
the scripts and configuration files necessary for the build automation of a PHP project. WWW: https://github.com/sebastianbergmann/php-project-wizard PR: ports/176074 Submitted by: Gasol Wu <gasol.wu@gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-PPW/Makefile29
-rw-r--r--devel/pear-PPW/distinfo2
-rw-r--r--devel/pear-PPW/pkg-descr5
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a7834ad07493..33753d7ef3df 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3106,6 +3106,7 @@
SUBDIR += pear-PHP_Timer
SUBDIR += pear-PHP_TokenStream
SUBDIR += pear-PHP_UML
+ SUBDIR += pear-PPW
SUBDIR += pear-Pager
SUBDIR += pear-PhpDocumentor
SUBDIR += pear-Pirum
diff --git a/devel/pear-PPW/Makefile b/devel/pear-PPW/Makefile
new file mode 100644
index 000000000000..694e8de9e1cd
--- /dev/null
+++ b/devel/pear-PPW/Makefile
@@ -0,0 +1,29 @@
+# Created by: Gasol Wu <gasol.wu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= PPW
+PORTVERSION= 1.0.4
+CATEGORIES= devel pear
+MASTER_SITES= http://pear.phpunit.de/get/
+PKGNAMEPREFIX= pear-
+DISTNAME= ppw-${DISTVERSION}
+
+MAINTAINER= gasol.wu@gmail.com
+COMMENT= PHP Project Wizard
+
+LICENSE= BSD
+
+BUILD_DEPENDS= pear>=1.9.4:${PORTSDIR}/devel/pear \
+ pear-ezc_ConsoleTools>=1.6:${PORTSDIR}/devel/pear-ezc_ConsoleTools \
+ pear-Text_Template>=1.1.0:${PORTSDIR}/textproc/pear-Text_Template
+RUN_DEPENDS= pear>=1.9.4:${PORTSDIR}/devel/pear \
+ pear-ezc_ConsoleTools>=1.6:${PORTSDIR}/devel/pear-ezc_ConsoleTools \
+ pear-Text_Template>=1.1.0:${PORTSDIR}/textproc/pear-Text_Template
+
+PEAR_CHANNEL= phpunit
+PEAR_AUTOINSTALL= yes
+IGNORE_WITH_PHP=52
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-PPW/distinfo b/devel/pear-PPW/distinfo
new file mode 100644
index 000000000000..69cfa5b32bf8
--- /dev/null
+++ b/devel/pear-PPW/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PEAR/ppw-1.0.4.tgz) = 4b465c0376fc8c9076f516791ff925ca222f2bfdaad897d6a6300cc8095cfc0b
+SIZE (PEAR/ppw-1.0.4.tgz) = 6122
diff --git a/devel/pear-PPW/pkg-descr b/devel/pear-PPW/pkg-descr
new file mode 100644
index 000000000000..cfaeb522a598
--- /dev/null
+++ b/devel/pear-PPW/pkg-descr
@@ -0,0 +1,5 @@
+The PHP Project Wizard (PPW) is a commandline tool that can be used to generate
+the scripts and configuration files necessary for the build automation of a PHP
+project.
+
+WWW: https://github.com/sebastianbergmann/php-project-wizard