aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-07-11 05:36:07 +0800
committerrakuco <rakuco@FreeBSD.org>2016-07-11 05:36:07 +0800
commitf12fc7b29e8c1fcff4df757bf8d2fe3c98b60182 (patch)
tree99fecdd98ab9d2ee1ade7e7dda6fad7a0206538a /devel
parent0b9d9b631c20ef03810328da0e2d5fa49c627b5c (diff)
downloadfreebsd-ports-gnome-f12fc7b29e8c1fcff4df757bf8d2fe3c98b60182.tar.gz
freebsd-ports-gnome-f12fc7b29e8c1fcff4df757bf8d2fe3c98b60182.tar.zst
freebsd-ports-gnome-f12fc7b29e8c1fcff4df757bf8d2fe3c98b60182.zip
Add missing dependencies to pass `make stage-qa'.
Error: /usr/local/bin/cmake-gui is linked to /usr/local/lib/libexecinfo.so.1 from devel/libexecinfo but it is not declared as a dependency Warning: you need USES+=execinfo Error: /usr/local/bin/cmake-gui is linked to /usr/local/lib/libjsoncpp.so.1 from devel/jsoncpp but it is not declared as a dependency Warning: you need LIB_DEPENDS+=libjsoncpp.so:devel/jsoncpp
Diffstat (limited to 'devel')
-rw-r--r--devel/cmake-gui/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/cmake-gui/Makefile b/devel/cmake-gui/Makefile
index 8c33edb06336..0a53b45f5d14 100644
--- a/devel/cmake-gui/Makefile
+++ b/devel/cmake-gui/Makefile
@@ -2,6 +2,7 @@
PORTNAME= cmake
PORTVERSION= 3.5.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://www.cmake.org/files/v${PORTVERSION:R}/
PKGNAMESUFFIX= -gui
@@ -14,10 +15,12 @@ LICENSE_FILE= ${WRKSRC}/Copyright.txt
BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
LIB_DEPENDS= libcurl.so:ftp/curl \
- libexpat.so:textproc/expat2
+ libexpat.so:textproc/expat2 \
+ libjsoncpp.so:devel/jsoncpp
USE_QT5= core gui widgets buildtools_build qmake_build
-USES= cmake:run desktop-file-utils libarchive shared-mime-info
+USES= cmake:run desktop-file-utils execinfo libarchive \
+ shared-mime-info
CMAKE_ARGS= -DBUILD_QtDialog:bool=on \
-DBUILD_CursesDialog:BOOL=OFF \
-DSPHINX_MAN:BOOL=ON \