aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-09-25 05:36:03 +0800
committermiwi <miwi@FreeBSD.org>2006-09-25 05:36:03 +0800
commit02529500d1d5ba9e319c4f03614dc7a07bf9d7a4 (patch)
tree52b04d27a71910390b069e55642a9e46014f8cff /devel
parent553bcc6f36bd64b20dca5e7f187a6d8323c8b7a3 (diff)
downloadfreebsd-ports-gnome-02529500d1d5ba9e319c4f03614dc7a07bf9d7a4.tar.gz
freebsd-ports-gnome-02529500d1d5ba9e319c4f03614dc7a07bf9d7a4.tar.zst
freebsd-ports-gnome-02529500d1d5ba9e319c4f03614dc7a07bf9d7a4.zip
- Update to 0.30
PR: ports/103524 Submitted by: Lapo Luchini <lapo(at)lapo.it> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/monotone/Makefile2
-rw-r--r--devel/monotone/distinfo6
-rw-r--r--devel/monotone/files/patch-Makefile.in10
-rw-r--r--devel/monotone/files/patch-configure6
-rw-r--r--devel/monotone/files/patch-monotone.cc22
5 files changed, 23 insertions, 23 deletions
diff --git a/devel/monotone/Makefile b/devel/monotone/Makefile
index d0204ca32ad8..5c8454c671e0 100644
--- a/devel/monotone/Makefile
+++ b/devel/monotone/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= monotone
-PORTVERSION= 0.29
+PORTVERSION= 0.30
CATEGORIES= devel
MASTER_SITES= http://www.venge.net/monotone/downloads/
diff --git a/devel/monotone/distinfo b/devel/monotone/distinfo
index 5ac1170d349c..f68a4f48218c 100644
--- a/devel/monotone/distinfo
+++ b/devel/monotone/distinfo
@@ -1,3 +1,3 @@
-MD5 (monotone-0.29.tar.gz) = 2261177af47621902c97719b94756994
-SHA256 (monotone-0.29.tar.gz) = 9ccda631303c96a2d6101ee1cfbc320de2de0ecb4e6503b573e29933ce68512d
-SIZE (monotone-0.29.tar.gz) = 4544609
+MD5 (monotone-0.30.tar.gz) = 94a1f8369162f7a7df8596b365a1d846
+SHA256 (monotone-0.30.tar.gz) = 5442515299d0281419d1a1922165b4dc7c6158d72032d3c15a672886f5c81f2c
+SIZE (monotone-0.30.tar.gz) = 4663418
diff --git a/devel/monotone/files/patch-Makefile.in b/devel/monotone/files/patch-Makefile.in
index 1ee1184d46fa..be4a72ee0d52 100644
--- a/devel/monotone/files/patch-Makefile.in
+++ b/devel/monotone/files/patch-Makefile.in
@@ -1,7 +1,7 @@
---- Makefile.in.orig Sat Jun 17 22:50:36 2006
-+++ Makefile.in Sun Jun 25 23:30:15 2006
-@@ -1909,13 +1909,13 @@
- -test -z "$(noinst_PROGRAMS)" || rm -f $(noinst_PROGRAMS)
+--- Makefile.in.orig Sun Sep 17 11:58:18 2006
++++ Makefile.in Sat Sep 23 18:38:33 2006
+@@ -1960,13 +1960,13 @@
+ unix/$(DEPDIR)/$(am__dirstamp)
mtn$(EXEEXT): $(mtn_OBJECTS) $(mtn_DEPENDENCIES)
@rm -f mtn$(EXEEXT)
- $(CXXLINK) $(mtn_LDFLAGS) $(mtn_OBJECTS) $(mtn_LDADD) $(LIBS)
@@ -17,7 +17,7 @@
contrib/$(am__dirstamp):
@$(mkdir_p) contrib
@: > contrib/$(am__dirstamp)
-@@ -1926,7 +1926,7 @@
+@@ -1977,7 +1977,7 @@
contrib/$(DEPDIR)/$(am__dirstamp)
usher$(EXEEXT): $(usher_OBJECTS) $(usher_DEPENDENCIES)
@rm -f usher$(EXEEXT)
diff --git a/devel/monotone/files/patch-configure b/devel/monotone/files/patch-configure
index 6cd64ab0d66c..b577cee0f733 100644
--- a/devel/monotone/files/patch-configure
+++ b/devel/monotone/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Fri Dec 31 03:17:44 2004
-+++ configure Wed Jan 26 22:20:17 2005
-@@ -5143,7 +5143,7 @@
+--- configure.orig Sun Sep 17 21:28:11 2006
++++ configure Sat Sep 23 18:38:33 2006
+@@ -10827,7 +10827,7 @@
#ifdef __cplusplus
"C"
#endif
diff --git a/devel/monotone/files/patch-monotone.cc b/devel/monotone/files/patch-monotone.cc
index 03387326c2d1..37bb59278295 100644
--- a/devel/monotone/files/patch-monotone.cc
+++ b/devel/monotone/files/patch-monotone.cc
@@ -1,13 +1,13 @@
---- monotone.cc.orig Fri Sep 30 11:50:05 2005
-+++ monotone.cc Fri Oct 14 11:31:14 2005
-@@ -238,8 +238,10 @@
- // go-go gadget i18n
-
- setlocale(LC_ALL, "");
+--- monotone.cc.orig Sun Sep 17 11:56:38 2006
++++ monotone.cc Sat Sep 23 18:42:05 2006
+@@ -188,8 +188,10 @@
+ if (!init)
+ {
+ setlocale(LC_ALL, "");
+#ifdef ENABLE_NLS
- bindtextdomain(PACKAGE, LOCALEDIR);
- textdomain(PACKAGE);
+ bindtextdomain(PACKAGE, LOCALEDIR);
+ textdomain(PACKAGE);
+#endif
-
-
- // we want to catch any early informative_failures due to charset
+ init = 1;
+ }
+ }