aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-05-10 22:36:46 +0800
committermiwi <miwi@FreeBSD.org>2013-05-10 22:36:46 +0800
commit0a7c38706cdd75535df6d9a306ac53ec4e0e6a8b (patch)
treed378e2c04ca9d3d7f76b11768e349e43e1e406a1 /devel
parent7ab5e4621ccd3760ae7d74203d438a30afebcb87 (diff)
downloadfreebsd-ports-gnome-0a7c38706cdd75535df6d9a306ac53ec4e0e6a8b.tar.gz
freebsd-ports-gnome-0a7c38706cdd75535df6d9a306ac53ec4e0e6a8b.tar.zst
freebsd-ports-gnome-0a7c38706cdd75535df6d9a306ac53ec4e0e6a8b.zip
- Fix build
PR: 176914 Submitted by: Gasol Wu <gasol.wu@gmail.com> Approved by: Ports Fury
Diffstat (limited to 'devel')
-rw-r--r--devel/pear-Net_Gearman/Makefile1
-rw-r--r--devel/pear-Net_Gearman/files/patch-Net__Gearman__Client.php26
2 files changed, 27 insertions, 0 deletions
diff --git a/devel/pear-Net_Gearman/Makefile b/devel/pear-Net_Gearman/Makefile
index f10a22b46f69..dc868e6e4544 100644
--- a/devel/pear-Net_Gearman/Makefile
+++ b/devel/pear-Net_Gearman/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Net_Gearman
PORTVERSION= 0.2.3
+PORTREVISION= 1
CATEGORIES= devel pear
MAINTAINER= gslin@gslin.org
diff --git a/devel/pear-Net_Gearman/files/patch-Net__Gearman__Client.php b/devel/pear-Net_Gearman/files/patch-Net__Gearman__Client.php
new file mode 100644
index 000000000000..284346500a93
--- /dev/null
+++ b/devel/pear-Net_Gearman/files/patch-Net__Gearman__Client.php
@@ -0,0 +1,26 @@
+--- ./Net/Gearman/Client.php.orig 2013-03-13 17:50:59.000000000 +0800
++++ ./Net/Gearman/Client.php 2013-03-13 17:51:18.000000000 +0800
+@@ -166,11 +166,11 @@
+ $s = $this->getConnection();
+ Net_Gearman_Connection::send($s, $type, $params);
+
+- if (!is_array(Net_Gearman_Connection::$waiting[$s])) {
+- Net_Gearman_Connection::$waiting[$s] = array();
++ if (!is_array(Net_Gearman_Connection::$waiting[(int) $s])) {
++ Net_Gearman_Connection::$waiting[(int) $s] = array();
+ }
+
+- array_push(Net_Gearman_Connection::$waiting[$s], $task);
++ array_push(Net_Gearman_Connection::$waiting[(int) $s], $task);
+ }
+
+ /**
+@@ -244,7 +244,7 @@
+ $task->fail();
+ break;
+ case 'job_created':
+- $task = array_shift(Net_Gearman_Connection::$waiting[$s]);
++ $task = array_shift(Net_Gearman_Connection::$waiting[(int) $s]);
+ $task->handle = $resp['data']['handle'];
+ if ($task->type == Net_Gearman_Task::JOB_BACKGROUND) {
+ $task->finished = true;