aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2004-02-05 05:38:34 +0800
committerjeh <jeh@FreeBSD.org>2004-02-05 05:38:34 +0800
commit0b3d011f944f0780af23eedd157ce153eb354043 (patch)
tree132f8708ffc205470473e0926408d1b59df3218f /devel
parent748e0ccd790d6ef965b29da801e1e04cdc3650cc (diff)
downloadfreebsd-ports-gnome-0b3d011f944f0780af23eedd157ce153eb354043.tar.gz
freebsd-ports-gnome-0b3d011f944f0780af23eedd157ce153eb354043.tar.zst
freebsd-ports-gnome-0b3d011f944f0780af23eedd157ce153eb354043.zip
Switch to using WITHOUT_CPU_CFLAGS again.
Diffstat (limited to 'devel')
-rw-r--r--devel/i386-rtems-g77/Makefile7
-rw-r--r--devel/i386-rtems-gcc/Makefile7
-rw-r--r--devel/i386-rtems-objc/Makefile7
3 files changed, 3 insertions, 18 deletions
diff --git a/devel/i386-rtems-g77/Makefile b/devel/i386-rtems-g77/Makefile
index aeeb836b7f86..af6aed8c7f18 100644
--- a/devel/i386-rtems-g77/Makefile
+++ b/devel/i386-rtems-g77/Makefile
@@ -56,14 +56,9 @@ CONFIGURE_SCRIPT?= ../${G77NAME}/configure
PATCH_WRKSRC= ${WRKDIR}
PATCH_STRIP= -p
-NO_CPU_FLAGS= true
+WITHOUT_CPU_CFLAGS= yes
MAKE_FLAGS= LANGUAGES="f77"
MAKE_ENV= MACHINE_ARCH=${RTEMS_ARCH} NO_CPU_CFLAGS=true
-# Since once mk/bsd.cpu.mk adds the _CPUCFLAGS they can't be removed
-# by NO_CPU_FLAGS, and since they are added long before here we are
-# stuck with this hack.
-CFLAGS:= ${CFLAGS:C/-mcpu=[^ ]*//:C/-march=[^ ]*//:C/-mtune=[^ ]*//}
-CXXFLAGS:= ${CXXFLAGS:C/-mcpu=[^ ]*//:C/-march=[^ ]*//:C/-mtune=[^ ]*//}
pre-configure:
@(cd ${WRKDIR} ; \
diff --git a/devel/i386-rtems-gcc/Makefile b/devel/i386-rtems-gcc/Makefile
index 419f09514593..b90de3577f2e 100644
--- a/devel/i386-rtems-gcc/Makefile
+++ b/devel/i386-rtems-gcc/Makefile
@@ -61,14 +61,9 @@ CONFIGURE_SCRIPT?= ../${GCCNAME}/configure
PATCH_WRKSRC= ${WRKDIR}
PATCH_STRIP= -p
-NO_CPU_FLAGS= true
+WITHOUT_CPU_CFLAGS= yes
MAKE_FLAGS= LANGUAGES="c c++ java"
MAKE_ENV= MACHINE_ARCH=${RTEMS_ARCH} NO_CPU_CFLAGS=true
-# Since once mk/bsd.cpu.mk adds the _CPUCFLAGS they can't be removed
-# by NO_CPU_FLAGS, and since they are added long before here we are
-# stuck with this hack.
-CFLAGS:= ${CFLAGS:C/-mcpu=[^ ]*//:C/-march=[^ ]*//:C/-mtune=[^ ]*//}
-CXXFLAGS:= ${CXXFLAGS:C/-mcpu=[^ ]*//:C/-march=[^ ]*//:C/-mtune=[^ ]*//}
MAN1= ${LCLTARGET}-gcc.1 ${LCLTARGET}-g++.1 ${LCLTARGET}-gcj.1 \
cpp.1 gcov.1 gcjh.1 jv-scan.1 jcf-dump.1 gij.1 \
diff --git a/devel/i386-rtems-objc/Makefile b/devel/i386-rtems-objc/Makefile
index 2806a503b970..30e7184f1d6a 100644
--- a/devel/i386-rtems-objc/Makefile
+++ b/devel/i386-rtems-objc/Makefile
@@ -56,14 +56,9 @@ CONFIGURE_SCRIPT?= ../${OBJCNAME}/configure
PATCH_WRKSRC= ${WRKDIR}
PATCH_STRIP= -p
-NO_CPU_FLAGS= true
+WITHOUT_CPU_CFLAGS= yes
MAKE_FLAGS= LANGUAGES="objc"
MAKE_ENV= MACHINE_ARCH=${RTEMS_ARCH} NO_CPU_CFLAGS=true
-# Since once mk/bsd.cpu.mk adds the _CPUCFLAGS they can't be removed
-# by NO_CPU_FLAGS, and since they are added long before here we are
-# stuck with this hack.
-CFLAGS:= ${CFLAGS:C/-mcpu=[^ ]*//:C/-march=[^ ]*//:C/-mtune=[^ ]*//}
-CXXFLAGS:= ${CXXFLAGS:C/-mcpu=[^ ]*//:C/-march=[^ ]*//:C/-mtune=[^ ]*//}
pre-configure:
@(cd ${WRKDIR} ; \