aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-04-09 11:29:54 +0800
committerswills <swills@FreeBSD.org>2012-04-09 11:29:54 +0800
commit0b90ecbaa82534a9673c3335bb7529466c041453 (patch)
treeee4d30a6252c0d206e15a21227c69c4e2d259626 /devel
parent8956d9f5b2f242d52eb88511a4729d0d3165b7cc (diff)
downloadfreebsd-ports-gnome-0b90ecbaa82534a9673c3335bb7529466c041453.tar.gz
freebsd-ports-gnome-0b90ecbaa82534a9673c3335bb7529466c041453.tar.zst
freebsd-ports-gnome-0b90ecbaa82534a9673c3335bb7529466c041453.zip
Perl module which implements the Null Class design pattern
WWW: http://search.cpan.org/dist/Class-Null/ Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Null/Makefile21
-rw-r--r--devel/p5-Class-Null/distinfo2
-rw-r--r--devel/p5-Class-Null/pkg-descr3
-rw-r--r--devel/p5-Class-Null/pkg-plist5
5 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index abafe13a457a..5b74fee0538d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1420,6 +1420,7 @@
SUBDIR += p5-Class-Multimethods
SUBDIR += p5-Class-Multimethods-Pure
SUBDIR += p5-Class-NamedParms
+ SUBDIR += p5-Class-Null
SUBDIR += p5-Class-OOorNO
SUBDIR += p5-Class-ObjectTemplate
SUBDIR += p5-Class-ObjectTemplate-DB
diff --git a/devel/p5-Class-Null/Makefile b/devel/p5-Class-Null/Makefile
new file mode 100644
index 000000000000..fbfb881926f8
--- /dev/null
+++ b/devel/p5-Class-Null/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Class-Null
+# Date created: 2012-04-08
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Null
+PORTVERSION= 2.110730
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl module which implements the Null Class design pattern
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::Null.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Null/distinfo b/devel/p5-Class-Null/distinfo
new file mode 100644
index 000000000000..ff035fd7f731
--- /dev/null
+++ b/devel/p5-Class-Null/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Class-Null-2.110730.tar.gz) = 5c3b46b3158a61edee72e7556e350191832b62936f6595e18852e18721d4d637
+SIZE (Class-Null-2.110730.tar.gz) = 19657
diff --git a/devel/p5-Class-Null/pkg-descr b/devel/p5-Class-Null/pkg-descr
new file mode 100644
index 000000000000..c89316356aeb
--- /dev/null
+++ b/devel/p5-Class-Null/pkg-descr
@@ -0,0 +1,3 @@
+Perl module which implements the Null Class design pattern
+
+WWW: http://search.cpan.org/dist/Class-Null/
diff --git a/devel/p5-Class-Null/pkg-plist b/devel/p5-Class-Null/pkg-plist
new file mode 100644
index 000000000000..3f746fc7e44c
--- /dev/null
+++ b/devel/p5-Class-Null/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Class/Null.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Null/.packlist
+@dirrmtry %%SITE_PERL%%/Class
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Null
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class