aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-07-13 23:04:57 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-07-13 23:04:57 +0800
commit126cf95a520458fb8498d15f266e4b7ff4801169 (patch)
tree4c18c05758f5c722aa61fbf95cba7b501f222864 /devel
parentafbf195e4b07ab544c162389a3d9dce5effed075 (diff)
downloadfreebsd-ports-gnome-126cf95a520458fb8498d15f266e4b7ff4801169.tar.gz
freebsd-ports-gnome-126cf95a520458fb8498d15f266e4b7ff4801169.tar.zst
freebsd-ports-gnome-126cf95a520458fb8498d15f266e4b7ff4801169.zip
- Take maintainership
- Update pkg-descr
Diffstat (limited to 'devel')
-rw-r--r--devel/py-gevent/Makefile6
-rw-r--r--devel/py-gevent/pkg-descr21
2 files changed, 21 insertions, 6 deletions
diff --git a/devel/py-gevent/Makefile b/devel/py-gevent/Makefile
index 01ab8380da78..77a779c898a7 100644
--- a/devel/py-gevent/Makefile
+++ b/devel/py-gevent/Makefile
@@ -11,15 +11,15 @@ CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Python co-routine networking library based on greenlet/libevent
LICENSE= MIT
LIB_DEPENDS= event:${PORTSDIR}/devel/libevent
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}greenlet>=0.3.1:${PORTSDIR}/devel/py-greenlet
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}greenlet>=0:${PORTSDIR}/devel/py-greenlet
-USE_PYTHON= -2.7
+USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
PYDISTUTILS_BUILDARGS= -I${LOCALBASE}/include -L${LOCALBASE}/lib
diff --git a/devel/py-gevent/pkg-descr b/devel/py-gevent/pkg-descr
index 070008bc1d23..65e7b73f61e3 100644
--- a/devel/py-gevent/pkg-descr
+++ b/devel/py-gevent/pkg-descr
@@ -1,4 +1,19 @@
-A coroutine-based Python networking library that uses greenlet to
-provide a high-level synchronous API on top of an libevent event loop.
+gevent is a coroutine-based Python networking library that uses greenlet to
+provide a high-level synchronous API on top of the libevent event loop.
-WWW: http://www.gevent.org/
+Features include:
+- Fast event loop based on libevent (epoll on Linux, kqueue on FreeBSD).
+- Lightweight execution units based on greenlet.
+- API that re-uses concepts from the Python standard library (for example there
+ are Events and Queues).
+- Cooperative sockets with SSL support.
+- DNS queries performed through libevent-dns.
+- Monkey patching utility to get 3rd party modules to become cooperative.
+- Fast WSGI server based on libevent-http
+
+gevent is inspired by eventlet but features more consistent API, simpler
+implementation and better performance. Read why others use gevent and check out
+the list of the open source projects based on gevent.
+
+WWW: http://www.gevent.org/
+WWW: http://pypi.python.org/pypi/gevent