aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-05-30 22:31:37 +0800
committerantoine <antoine@FreeBSD.org>2014-05-30 22:31:37 +0800
commit164023ae2e51ea44a0bfe51d20acfbdd38b7c789 (patch)
tree77be0fe2899b9d8676fc74061aa221f413c81116 /devel
parent55d9c16475f5b97c2734121ae3eb964e7b239f77 (diff)
downloadfreebsd-ports-gnome-164023ae2e51ea44a0bfe51d20acfbdd38b7c789.tar.gz
freebsd-ports-gnome-164023ae2e51ea44a0bfe51d20acfbdd38b7c789.tar.zst
freebsd-ports-gnome-164023ae2e51ea44a0bfe51d20acfbdd38b7c789.zip
New port: devel/libvmdk
Library and tools to access the VMware Virtual Disk (VMDK) image format WWW: http://code.google.com/p/libvmdk/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libvmdk/Makefile32
-rw-r--r--devel/libvmdk/distinfo2
-rw-r--r--devel/libvmdk/pkg-descr3
-rw-r--r--devel/libvmdk/pkg-plist18
5 files changed, 56 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6e89b2e14efa..0b5972c2ba5c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1148,6 +1148,7 @@
SUBDIR += libvirt
SUBDIR += libvirt-glib
SUBDIR += libvirt-java
+ SUBDIR += libvmdk
SUBDIR += libvolume_id
SUBDIR += libvshadow
SUBDIR += libwfut
diff --git a/devel/libvmdk/Makefile b/devel/libvmdk/Makefile
new file mode 100644
index 000000000000..4adb1a20b410
--- /dev/null
+++ b/devel/libvmdk/Makefile
@@ -0,0 +1,32 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libvmdk
+# If/When moving from experimental to alpha, override DISTNAME to prevent PORTEPOCH
+DISTVERSION= experimental-20140421
+CATEGORIES= devel
+MASTER_SITES= https://googledrive.com/host/0B3fBvzttpiiSQ1dOUmhqMkR2cm8/ \
+ LOCAL/antoine
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Library and tools to access the VMware Virtual Disk (VMDK) format
+
+LICENSE= LGPL3
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-python --with-libintl-prefix=${LOCALBASE} ${ICONV_CONFIGURE_ARG}
+USES= fuse gettext iconv libtool pathfix pkgconfig
+USE_PYTHON= 2
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:E}
+
+PORTDOCS= AUTHORS ChangeLog
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/libvmdk/distinfo b/devel/libvmdk/distinfo
new file mode 100644
index 000000000000..c74a4ab78542
--- /dev/null
+++ b/devel/libvmdk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libvmdk-experimental-20140421.tar.gz) = 0d4fa5a4748cd684896d00f7eaa75b36c2495f548d7c75158240ccaca1416ad0
+SIZE (libvmdk-experimental-20140421.tar.gz) = 1388714
diff --git a/devel/libvmdk/pkg-descr b/devel/libvmdk/pkg-descr
new file mode 100644
index 000000000000..742f155d2ac3
--- /dev/null
+++ b/devel/libvmdk/pkg-descr
@@ -0,0 +1,3 @@
+Library and tools to access the VMware Virtual Disk (VMDK) format.
+
+WWW: http://code.google.com/p/libvmdk/
diff --git a/devel/libvmdk/pkg-plist b/devel/libvmdk/pkg-plist
new file mode 100644
index 000000000000..65e05e7c96f6
--- /dev/null
+++ b/devel/libvmdk/pkg-plist
@@ -0,0 +1,18 @@
+bin/vmdkinfo
+bin/vmdkmount
+include/libvmdk.h
+include/libvmdk/definitions.h
+include/libvmdk/error.h
+include/libvmdk/extern.h
+include/libvmdk/features.h
+include/libvmdk/types.h
+lib/libvmdk.a
+lib/libvmdk.so
+lib/libvmdk.so.1
+lib/libvmdk.so.1.0.0
+%%PYTHON_SITELIBDIR%%/pyvmdk.a
+%%PYTHON_SITELIBDIR%%/pyvmdk.so
+libdata/pkgconfig/libvmdk.pc
+man/man1/vmdkinfo.1.gz
+man/man3/libvmdk.3.gz
+@dirrm include/libvmdk