aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2008-08-21 06:31:26 +0800
committerbrooks <brooks@FreeBSD.org>2008-08-21 06:31:26 +0800
commit1cae7fa77123c7805104623cbc84f19b3a9c639c (patch)
treeeb7925500cdce9203c0945b2484d6ac67f2cc397 /devel
parent3cc24f334b2433819b889c72a9ee3e6491f69db0 (diff)
downloadfreebsd-ports-gnome-1cae7fa77123c7805104623cbc84f19b3a9c639c.tar.gz
freebsd-ports-gnome-1cae7fa77123c7805104623cbc84f19b3a9c639c.tar.zst
freebsd-ports-gnome-1cae7fa77123c7805104623cbc84f19b3a9c639c.zip
Upgrade to a snapshot from 8/17.
Temporarily put the regression-test target under if defined(MAINTAINER_MODE) because it eats /dev/null if run as root and the package cluster runs it as root.
Diffstat (limited to 'devel')
-rw-r--r--devel/llvm-devel/Makefile4
-rw-r--r--devel/llvm-devel/distinfo6
-rw-r--r--devel/llvm-devel/pkg-plist26
3 files changed, 23 insertions, 13 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index d1c3dce7f522..32149e810f4b 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -25,7 +25,7 @@ BUILD_DEPENDS+= f2c:${PORTSDIR}/lang/f2c
.if defined(BOOTSTRAP)
SVN_SNAPDATE!= date -v-1d +%Y-%m-%d
.else
-SVN_SNAPDATE= 2008-08-05
+SVN_SNAPDATE= 2008-08-17
.endif
SNAPDATE= ${SVN_SNAPDATE:S/-//g}
@@ -81,7 +81,9 @@ post-install:
@${RM} ${PREFIX}/bin/.dir \
${PREFIX}/lib/.dir
+.if defined(MAINTAINER_MODE)
regression-test: ${BUILD_COOKIE}
(cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${GMAKE} check)
+.endif
.include <bsd.port.mk>
diff --git a/devel/llvm-devel/distinfo b/devel/llvm-devel/distinfo
index 1ff4b515fe7e..67902c1a11e1 100644
--- a/devel/llvm-devel/distinfo
+++ b/devel/llvm-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (llvm-2.4.snap20080805.tar.bz2) = 55961fd6c07054445eb7be08a6326b73
-SHA256 (llvm-2.4.snap20080805.tar.bz2) = 4451deae1ca92098e5806adcec5103e4301b07e4295d6a29b91fe04bd748e258
-SIZE (llvm-2.4.snap20080805.tar.bz2) = 6018013
+MD5 (llvm-2.4.snap20080817.tar.bz2) = d139c92cefb1f4a273a7860047f69f44
+SHA256 (llvm-2.4.snap20080817.tar.bz2) = 8b74597f76b82a559be5fb250ece965f5e08066686294382837ed8667871ca44
+SIZE (llvm-2.4.snap20080817.tar.bz2) = 6018126
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index 4cf25d6439a2..23714014c0fd 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -89,7 +89,6 @@ include/llvm/Analysis/IntervalIterator.h
include/llvm/Analysis/IntervalPartition.h
include/llvm/Analysis/LibCallAliasAnalysis.h
include/llvm/Analysis/LibCallSemantics.h
-include/llvm/Analysis/LoadValueNumbering.h
include/llvm/Analysis/LoopInfo.h
include/llvm/Analysis/LoopPass.h
include/llvm/Analysis/LoopVR.h
@@ -104,7 +103,6 @@ include/llvm/Analysis/ScalarEvolutionExpander.h
include/llvm/Analysis/ScalarEvolutionExpressions.h
include/llvm/Analysis/SparsePropagation.h
include/llvm/Analysis/Trace.h
-include/llvm/Analysis/ValueNumbering.h
include/llvm/Analysis/ValueTracking.h
include/llvm/Analysis/Verifier.h
include/llvm/Argument.h
@@ -129,14 +127,17 @@ include/llvm/CallingConv.h
include/llvm/CodeGen/AsmPrinter.h
include/llvm/CodeGen/BreakCriticalMachineEdge.h
include/llvm/CodeGen/CallingConvLower.h
-include/llvm/CodeGen/Collector.h
-include/llvm/CodeGen/CollectorMetadata.h
-include/llvm/CodeGen/Collectors.h
include/llvm/CodeGen/DAGISelHeader.h
include/llvm/CodeGen/DwarfWriter.h
include/llvm/CodeGen/ELFRelocation.h
+include/llvm/CodeGen/FastISel.h
include/llvm/CodeGen/FileWriters.h
+include/llvm/CodeGen/GCMetadata.h
+include/llvm/CodeGen/GCMetadataPrinter.h
+include/llvm/CodeGen/GCStrategy.h
+include/llvm/CodeGen/GCs.h
include/llvm/CodeGen/IntrinsicLowering.h
+include/llvm/CodeGen/LinkAllAsmWriterComponents.h
include/llvm/CodeGen/LinkAllCodegenComponents.h
include/llvm/CodeGen/LiveInterval.h
include/llvm/CodeGen/LiveIntervalAnalysis.h
@@ -229,6 +230,7 @@ include/llvm/Support/Casting.h
include/llvm/Support/CommandLine.h
include/llvm/Support/Compiler.h
include/llvm/Support/ConstantRange.h
+include/llvm/Support/ConstantFolder.h
include/llvm/Support/DOTGraphTraits.h
include/llvm/Support/DataFlow.h
include/llvm/Support/DataTypes.h
@@ -248,6 +250,7 @@ include/llvm/Support/Mangler.h
include/llvm/Support/MathExtras.h
include/llvm/Support/MemoryBuffer.h
include/llvm/Support/MutexGuard.h
+include/llvm/Support/NoFolder.h
include/llvm/Support/OutputBuffer.h
include/llvm/Support/PassNameParser.h
include/llvm/Support/PatternMatch.h
@@ -261,7 +264,9 @@ include/llvm/Support/StableBasicBlockNumbering.h
include/llvm/Support/Streams.h
include/llvm/Support/StringPool.h
include/llvm/Support/SystemUtils.h
+include/llvm/Support/TargetFolder.h
include/llvm/Support/Timer.h
+include/llvm/Support/raw_ostream.h
include/llvm/Support/type_traits.h
include/llvm/SymbolTableListTraits.h
include/llvm/System/Alarm.h
@@ -316,7 +321,8 @@ include/llvm/Use.h
include/llvm/User.h
include/llvm/Value.h
include/llvm/ValueSymbolTable.h
-lib/LLVMARM.o
+lib/LLVMARMAsmPrinter.o
+lib/LLVMARMCodeGen.o
lib/LLVMAlpha.o
lib/LLVMCBackend.o
lib/LLVMCellSPU.o
@@ -331,13 +337,16 @@ lib/LLVMInterpreter.o
lib/LLVMJIT.o
lib/LLVMMSIL.o
lib/LLVMMips.o
-lib/LLVMPowerPC.o
lib/LLVMPIC16.o
+lib/LLVMPowerPCAsmPrinter.o
+lib/LLVMPowerPCCodeGen.o
lib/LLVMSparc.o
-lib/LLVMX86.o
+lib/LLVMX86AsmPrinter.o
+lib/LLVMX86CodeGen.o
lib/libLLVMAnalysis.a
lib/libLLVMArchive.a
lib/libLLVMAsmParser.a
+lib/libLLVMAsmPrinter.a
lib/libLLVMBitReader.a
lib/libLLVMBitWriter.a
lib/libLLVMCodeGen.a
@@ -404,7 +413,6 @@ lib/libLLVMipo.a
%%DOCSDIR%%/html/Projects.html
%%DOCSDIR%%/html/ReleaseNotes.html
%%DOCSDIR%%/html/SourceLevelDebugging.html
-%%DOCSDIR%%/html/Stacker.html
%%DOCSDIR%%/html/SystemLibrary.html
%%DOCSDIR%%/html/TableGenFundamentals.html
%%DOCSDIR%%/html/TestingGuide.html