aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2010-09-11 22:07:18 +0800
committerswills <swills@FreeBSD.org>2010-09-11 22:07:18 +0800
commit2234acc6085e896e0f2dfc256ff0b034ae01dd38 (patch)
tree3cc74c3370347b84c67fab9efae42f97c396e967 /devel
parent178b944ed5cf6cf976f333d9ae2c9af078475a71 (diff)
downloadfreebsd-ports-gnome-2234acc6085e896e0f2dfc256ff0b034ae01dd38.tar.gz
freebsd-ports-gnome-2234acc6085e896e0f2dfc256ff0b034ae01dd38.tar.zst
freebsd-ports-gnome-2234acc6085e896e0f2dfc256ff0b034ae01dd38.zip
Perl module which allows logging to RabbitMQ
WWW: http://search.cpan.org/~bundacia/Log-Log4perl-Appender-RabbitMQ/ Approved by: wxs (co-mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Log-Log4perl-Appender-RabbitMQ/Makefile33
-rw-r--r--devel/p5-Log-Log4perl-Appender-RabbitMQ/distinfo3
-rw-r--r--devel/p5-Log-Log4perl-Appender-RabbitMQ/pkg-descr3
-rw-r--r--devel/p5-Log-Log4perl-Appender-RabbitMQ/pkg-plist4
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 985565531d04..37ed6b455753 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1817,6 +1817,7 @@
SUBDIR += p5-Log-Dispatch-Scribe
SUBDIR += p5-Log-Handler
SUBDIR += p5-Log-Log4perl
+ SUBDIR += p5-Log-Log4perl-Appender-RabbitMQ
SUBDIR += p5-Log-Message
SUBDIR += p5-Log-Message-Simple
SUBDIR += p5-Log-Report
diff --git a/devel/p5-Log-Log4perl-Appender-RabbitMQ/Makefile b/devel/p5-Log-Log4perl-Appender-RabbitMQ/Makefile
new file mode 100644
index 000000000000..d84330f86101
--- /dev/null
+++ b/devel/p5-Log-Log4perl-Appender-RabbitMQ/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Log-Log4perl-Appender-RabbitMQ
+# Date created: 2010-09-09
+# Whom: Steve Wills <swills@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Log-Log4perl-Appender-RabbitMQ
+PORTVERSION= 0.102220
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/B/BU/BUNDACIA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= swills@freebsd.org
+COMMENT= Perl module which allows logging to RabbitMQ via log4perl
+
+RUN_DEPENDS= ${LOCALBASE}/bin/l4p-tmpl:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Net-RabbitMQ>0:${PORTSDIR}/net/p5-Net-RabbitMQ \
+ p5-Readonly>0:${PORTSDIR}/devel/p5-Readonly \
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/l4p-tmpl:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Net-RabbitMQ>0:${PORTSDIR}/net/p5-Net-RabbitMQ \
+ p5-Readonly>0:${PORTSDIR}/devel/p5-Readonly \
+ p5-Test-Output>0:${PORTSDIR}/devel/p5-Test-Output \
+ p5-Test-Net-RabbitMQ>0:${PORTSDIR}/devel/p5-Test-Net-RabbitMQ
+
+MAN3= Log::Log4perl::Appender::RabbitMQ.3
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Log-Log4perl-Appender-RabbitMQ/distinfo b/devel/p5-Log-Log4perl-Appender-RabbitMQ/distinfo
new file mode 100644
index 000000000000..5c5258163c2f
--- /dev/null
+++ b/devel/p5-Log-Log4perl-Appender-RabbitMQ/distinfo
@@ -0,0 +1,3 @@
+MD5 (Log-Log4perl-Appender-RabbitMQ-0.102220.tar.gz) = 2317524f136f4ab80fc58907df627d06
+SHA256 (Log-Log4perl-Appender-RabbitMQ-0.102220.tar.gz) = 6af081fa8b3b3588b81aee9ac3363c8e3b571bf965ce989078d2f3d17a5166b1
+SIZE (Log-Log4perl-Appender-RabbitMQ-0.102220.tar.gz) = 12207
diff --git a/devel/p5-Log-Log4perl-Appender-RabbitMQ/pkg-descr b/devel/p5-Log-Log4perl-Appender-RabbitMQ/pkg-descr
new file mode 100644
index 000000000000..a44c4b20e17c
--- /dev/null
+++ b/devel/p5-Log-Log4perl-Appender-RabbitMQ/pkg-descr
@@ -0,0 +1,3 @@
+Perl module which allows logging to RabbitMQ
+
+WWW: http://search.cpan.org/~bundacia/Log-Log4perl-Appender-RabbitMQ/
diff --git a/devel/p5-Log-Log4perl-Appender-RabbitMQ/pkg-plist b/devel/p5-Log-Log4perl-Appender-RabbitMQ/pkg-plist
new file mode 100644
index 000000000000..af62b8d50179
--- /dev/null
+++ b/devel/p5-Log-Log4perl-Appender-RabbitMQ/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Log/Log4perl/Appender/RabbitMQ.pm
+%%SITE_PERL%%/mach/auto/Log/Log4perl/Appender/RabbitMQ/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/Log/Log4perl/Appender/RabbitMQ
+@dirrm %%SITE_PERL%%/mach/auto/Log/Log4perl/Appender