aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-08-03 19:28:43 +0800
committerwg <wg@FreeBSD.org>2014-08-03 19:28:43 +0800
commit23c0c53a4b4c19b99e6e8f70541724dae7b42187 (patch)
tree3da0add77ff782a3446bdc5a8b0ff20b735be82d /devel
parentf78fce465226d591a78261caed795fe87fe4f811 (diff)
downloadfreebsd-ports-gnome-23c0c53a4b4c19b99e6e8f70541724dae7b42187.tar.gz
freebsd-ports-gnome-23c0c53a4b4c19b99e6e8f70541724dae7b42187.tar.zst
freebsd-ports-gnome-23c0c53a4b4c19b99e6e8f70541724dae7b42187.zip
devel/py-tzlocal
This Python module returns a tzinfo object with the local timezone information under Unix and Win-32. It requires pytz, and returns pytz tzinfo objects. This module attempts to fix a glaring hole in pytz, that there is no way to get the local timezone information, unless you know the zoneinfo name, and under several Linux distros that's hard or impossible to figure out. WWW: https://pypi.python.org/pypi/tzlocal PR: 191659 Submitted by: melvyn magemana nl
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-tzlocal/Makefile34
-rw-r--r--devel/py-tzlocal/distinfo2
-rw-r--r--devel/py-tzlocal/pkg-descr10
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 67e243a6a98a..8bf8ba849da8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3912,6 +3912,7 @@
SUBDIR += py-twistedCore
SUBDIR += py-twistedFlow
SUBDIR += py-twistedRunner
+ SUBDIR += py-tzlocal
SUBDIR += py-ua_parser
SUBDIR += py-ujson
SUBDIR += py-uncompyle2
diff --git a/devel/py-tzlocal/Makefile b/devel/py-tzlocal/Makefile
new file mode 100644
index 000000000000..7eccf63bf469
--- /dev/null
+++ b/devel/py-tzlocal/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= tzlocal
+PORTVERSION= 1.1.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= melvyn@magemana.nl
+COMMENT= Returns the tzinfo object for the local timezone
+
+LICENSE= CC0-1.0
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz
+
+OPTIONS_DEFINE= TEST
+OPTIONS_DEFAULT= TEST
+TEST_DESC= Run test suite
+
+USES= zip
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.options.mk>
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+
+.if !empty(PORT_OPTIONS:MTEST)
+pre-install: regression-test
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-tzlocal/distinfo b/devel/py-tzlocal/distinfo
new file mode 100644
index 000000000000..44922c86dd44
--- /dev/null
+++ b/devel/py-tzlocal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tzlocal-1.1.1.zip) = 696bfd8d7c888de039af6c6fdf86fd52e32508277d89c75d200eb2c150487ed4
+SIZE (tzlocal-1.1.1.zip) = 21921
diff --git a/devel/py-tzlocal/pkg-descr b/devel/py-tzlocal/pkg-descr
new file mode 100644
index 000000000000..b0952f8c1d4f
--- /dev/null
+++ b/devel/py-tzlocal/pkg-descr
@@ -0,0 +1,10 @@
+This Python module returns a tzinfo object with the local timezone
+information under Unix and Win-32. It requires pytz, and returns pytz
+tzinfo objects.
+
+This module attempts to fix a glaring hole in pytz, that there is no way
+to get the local timezone information, unless you know the zoneinfo
+name, and under several Linux distros that's hard or impossible to
+figure out.
+
+WWW: https://pypi.python.org/pypi/tzlocal