aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2014-06-30 19:38:15 +0800
committerashish <ashish@FreeBSD.org>2014-06-30 19:38:15 +0800
commit290e3dc99540ce7e805d07a9bdc96421206e7357 (patch)
tree7f328f3b6722403b90d4d5b3159ba4aee77cb05f /devel
parent08a779d03442b42507de7628edf4c0963aedabe4 (diff)
downloadfreebsd-ports-gnome-290e3dc99540ce7e805d07a9bdc96421206e7357.tar.gz
freebsd-ports-gnome-290e3dc99540ce7e805d07a9bdc96421206e7357.tar.zst
freebsd-ports-gnome-290e3dc99540ce7e805d07a9bdc96421206e7357.zip
- Add STAGE support
- Move LICENSE to its own block - Fix pkg-descr - OptionsNG-ify port
Diffstat (limited to 'devel')
-rw-r--r--devel/gtkparasite/Makefile12
-rw-r--r--devel/gtkparasite/pkg-descr2
2 files changed, 9 insertions, 5 deletions
diff --git a/devel/gtkparasite/Makefile b/devel/gtkparasite/Makefile
index 7feed03e1b63..ceca7496a3ea 100644
--- a/devel/gtkparasite/Makefile
+++ b/devel/gtkparasite/Makefile
@@ -11,6 +11,9 @@ MASTER_SITE_SUBDIR= pav
MAINTAINER= ashish@FreeBSD.org
COMMENT= GTK+ UI debugging tool
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= pkgconfig
USE_PYTHON= yes
USE_GNOME= gtk20 pygtk2
@@ -22,15 +25,16 @@ PLIST_FILES= lib/gtk-2.0/modules/libgtkparasite.a \
lib/gtk-2.0/modules/libgtkparasite.so
USE_AUTOTOOLS= autoconf automake libtool
-NO_STAGE= yes
pre-configure:
cd ${WRKSRC} && ${REINPLACE_CMD} -e '/.\/configure/d' ./autogen.sh \
&& ./autogen.sh
+.include <bsd.port.options.mk>
+
post-install:
-.ifndef NOPORTDOCS
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/USAGE ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/USAGE ${STAGEDIR}/${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/gtkparasite/pkg-descr b/devel/gtkparasite/pkg-descr
index 43b7805f8437..4934ce2813d8 100644
--- a/devel/gtkparasite/pkg-descr
+++ b/devel/gtkparasite/pkg-descr
@@ -17,4 +17,4 @@ giving you detailed information on your UI, such as the hierarchy,
X window IDs, widget properties, and more. You can modify properties
on the fly in order to experiment with the look of your UI.
-WWW: http://chipx86.github.com/gtkparasite/
+WWW: http://chipx86.github.com/gtkparasite/