aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2007-02-06 19:04:30 +0800
committerdelphij <delphij@FreeBSD.org>2007-02-06 19:04:30 +0800
commit2fefa019f14d2766355eeffe1cc5759f222063aa (patch)
treed61a0421400128c74282f55e5909c93818352a24 /devel
parent379e1f56ec5e4873770bc5ddae5c8d782c874093 (diff)
downloadfreebsd-ports-gnome-2fefa019f14d2766355eeffe1cc5759f222063aa.tar.gz
freebsd-ports-gnome-2fefa019f14d2766355eeffe1cc5759f222063aa.tar.zst
freebsd-ports-gnome-2fefa019f14d2766355eeffe1cc5759f222063aa.zip
New port: check is a unit testing framework for C. It
features a simple interface for defining unit tests, putting little in the way of the developer. Tests are run in a separate address space, so Check can catch both assertion failures and code errors that cause segmentation faults or other signals. The output from unit tests can be used within source code editors and IDEs. Homepage: http://check.sourceforge.net/ Submitted by: rill <jiangzhixiang embedded iscas ac cn>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/check/Makefile25
-rw-r--r--devel/check/distinfo3
-rw-r--r--devel/check/files/patch-Makefile.am11
-rw-r--r--devel/check/files/patch-Makefile.in11
-rw-r--r--devel/check/pkg-descr9
-rw-r--r--devel/check/pkg-plist41
7 files changed, 101 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 692c317df07f..653c726d7c64 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -138,6 +138,7 @@
SUBDIR += cgilib
SUBDIR += cgprof
SUBDIR += charva
+ SUBDIR += check
SUBDIR += chora
SUBDIR += cil
SUBDIR += cl-asdf
diff --git a/devel/check/Makefile b/devel/check/Makefile
new file mode 100644
index 000000000000..9dc2f134d265
--- /dev/null
+++ b/devel/check/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: check
+# Date created: 02 February 2007
+# Whom: luckrill@yahoo.com.cn
+#
+# $FreeBSD$
+#
+
+PORTNAME= check
+PORTVERSION= 0.9.5
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= check
+
+MAINTAINER= luckrill@yahoo.com.cn
+COMMENT= Check is a unit testing framework for C
+
+INFO= check
+
+MANCOMPRESSED= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/check/distinfo b/devel/check/distinfo
new file mode 100644
index 000000000000..3bb9f8630a1a
--- /dev/null
+++ b/devel/check/distinfo
@@ -0,0 +1,3 @@
+MD5 (check-0.9.5.tar.gz) = 30143c7974b547a12a7da47809a90951
+SHA256 (check-0.9.5.tar.gz) = 961b3c66869018d02226bbbc394e79362cd898962ce810bce8417b3c497f7ad6
+SIZE (check-0.9.5.tar.gz) = 520625
diff --git a/devel/check/files/patch-Makefile.am b/devel/check/files/patch-Makefile.am
new file mode 100644
index 000000000000..1b9da237f136
--- /dev/null
+++ b/devel/check/files/patch-Makefile.am
@@ -0,0 +1,11 @@
+--- ./Makefile.am.orig Wed Nov 22 07:19:11 2006
++++ ./Makefile.am Tue Feb 6 10:58:26 2007
+@@ -27,7 +27,7 @@
+ m4data_DATA = check.m4
+
+ ## install check.pc
+-pcdatadir = $(libdir)/pkgconfig
++pcdatadir = $(libdir)/../libdata/pkgconfig
+ pcdata_DATA = check.pc
+
+ SVNChangeLog:
diff --git a/devel/check/files/patch-Makefile.in b/devel/check/files/patch-Makefile.in
new file mode 100644
index 000000000000..1f76a89643d5
--- /dev/null
+++ b/devel/check/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- ./Makefile.in.orig Wed Nov 22 07:19:11 2006
++++ ./Makefile.in Tue Feb 6 10:58:39 2007
+@@ -207,7 +207,7 @@
+ doc_DATA = SVNChangeLog ChangeLog ChangeLogOld NEWS README COPYING.LESSER
+ m4datadir = $(datadir)/aclocal
+ m4data_DATA = check.m4
+-pcdatadir = $(libdir)/pkgconfig
++pcdatadir = $(libdir)/../libdata/pkgconfig
+ pcdata_DATA = check.pc
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
diff --git a/devel/check/pkg-descr b/devel/check/pkg-descr
new file mode 100644
index 000000000000..b96b9e6b69b9
--- /dev/null
+++ b/devel/check/pkg-descr
@@ -0,0 +1,9 @@
+Check is a unit testing framework for C. It features
+a simple interface for defining unit tests, putting
+little in the way of the developer. Tests are run in
+a separate address space, so Check can catch both
+assertion failures and code errors that cause segmentation
+faults or other signals. The output from unit tests can be
+used within source code editors and IDEs.
+
+WWW: http://check.sourceforge.net/
diff --git a/devel/check/pkg-plist b/devel/check/pkg-plist
new file mode 100644
index 000000000000..0d9b4153227a
--- /dev/null
+++ b/devel/check/pkg-plist
@@ -0,0 +1,41 @@
+include/check.h
+lib/libcheck.a
+lib/libcheck.la
+lib/libcheck.so
+lib/libcheck.so.0
+libdata/pkgconfig/check.pc
+share/aclocal/check.m4
+%%DOCSDIR%%/COPYING.LESSER
+%%DOCSDIR%%/ChangeLog
+%%DOCSDIR%%/ChangeLogOld
+%%DOCSDIR%%/NEWS
+%%DOCSDIR%%/README
+%%DOCSDIR%%/SVNChangeLog
+%%DOCSDIR%%/example/Makefile.am
+%%DOCSDIR%%/example/README
+%%DOCSDIR%%/example/configure.ac
+%%DOCSDIR%%/example/src/Makefile.am
+%%DOCSDIR%%/example/src/main.c
+%%DOCSDIR%%/example/src/money.1.c
+%%DOCSDIR%%/example/src/money.1.h
+%%DOCSDIR%%/example/src/money.2.h
+%%DOCSDIR%%/example/src/money.3.c
+%%DOCSDIR%%/example/src/money.4.c
+%%DOCSDIR%%/example/src/money.5.c
+%%DOCSDIR%%/example/src/money.6.c
+%%DOCSDIR%%/example/src/money.c
+%%DOCSDIR%%/example/src/money.h
+%%DOCSDIR%%/example/tests/Makefile.am
+%%DOCSDIR%%/example/tests/check_money.1.c
+%%DOCSDIR%%/example/tests/check_money.2.c
+%%DOCSDIR%%/example/tests/check_money.3.c
+%%DOCSDIR%%/example/tests/check_money.6.c
+%%DOCSDIR%%/example/tests/check_money.7.c
+%%DOCSDIR%%/example/tests/check_money.c
+share/nls/POSIX
+share/nls/en_US.US-ASCII
+@dirrm %%DOCSDIR%%/example/tests
+@dirrm %%DOCSDIR%%/example/src
+@dirrm %%DOCSDIR%%/example
+@dirrm %%DOCSDIR%%
+@dirrmtry libdata/pkgconfig