aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2006-06-10 21:41:26 +0800
committermnag <mnag@FreeBSD.org>2006-06-10 21:41:26 +0800
commit310fb39881905739eabd67bf03a8464e0d83cb35 (patch)
treee48d560905f801b46df6476750a7f1cc87cb7aff /devel
parent28c9d0c074206c93ccbbce87200e4165c3c52c36 (diff)
downloadfreebsd-ports-gnome-310fb39881905739eabd67bf03a8464e0d83cb35.tar.gz
freebsd-ports-gnome-310fb39881905739eabd67bf03a8464e0d83cb35.tar.zst
freebsd-ports-gnome-310fb39881905739eabd67bf03a8464e0d83cb35.zip
- Update to 1.5.1
PR: 97988 Approved by: maintainer timeout (14 days)
Diffstat (limited to 'devel')
-rw-r--r--devel/py-psyco/Makefile3
-rw-r--r--devel/py-psyco/distinfo6
-rw-r--r--devel/py-psyco/files/patch-c__platform.c13
3 files changed, 17 insertions, 5 deletions
diff --git a/devel/py-psyco/Makefile b/devel/py-psyco/Makefile
index be3f782d11ea..ef44ceb1471d 100644
--- a/devel/py-psyco/Makefile
+++ b/devel/py-psyco/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= psyco
-PORTVERSION= 1.5
-PORTREVISION= 1
+PORTVERSION= 1.5.1
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= psyco
diff --git a/devel/py-psyco/distinfo b/devel/py-psyco/distinfo
index 5f2f66c35143..019aa60ecb94 100644
--- a/devel/py-psyco/distinfo
+++ b/devel/py-psyco/distinfo
@@ -1,3 +1,3 @@
-MD5 (psyco-1.5-src.tar.gz) = ff79e5daf94924fc7401d336d33edebf
-SHA256 (psyco-1.5-src.tar.gz) = c9e49d11eb63cb92e37dc6439455368a384ab8e5aa04a53a4253e5acfd9d3682
-SIZE (psyco-1.5-src.tar.gz) = 351449
+MD5 (psyco-1.5.1-src.tar.gz) = 89e629d27acda765f01aa870230d1162
+SHA256 (psyco-1.5.1-src.tar.gz) = 10852198770af1d1562b1330012f6ecc4c6c1f192d6623cdf0553b0490184359
+SIZE (psyco-1.5.1-src.tar.gz) = 361314
diff --git a/devel/py-psyco/files/patch-c__platform.c b/devel/py-psyco/files/patch-c__platform.c
new file mode 100644
index 000000000000..bc39db83c70c
--- /dev/null
+++ b/devel/py-psyco/files/patch-c__platform.c
@@ -0,0 +1,13 @@
+#
+# 4.x require sys/types.h to mmap()
+#
+--- ./c/platform.c.orig Fri May 26 17:45:34 2006
++++ ./c/platform.c Fri May 26 17:45:51 2006
+@@ -32,6 +32,7 @@
+ /************************************************************/
+
+ #include <stdlib.h>
++#include <sys/types.h>
+ #include <sys/mman.h>
+ #if defined(MAP_ANON) && !defined(MAP_ANONYMOUS)
+ # define MAP_ANONYMOUS MAP_ANON