aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2009-03-10 00:22:04 +0800
committerpgj <pgj@FreeBSD.org>2009-03-10 00:22:04 +0800
commit33b3de5d2ad3808104d138e934870648b30c2367 (patch)
tree7eca9cc63dd0fd20d37a885812e80208766be2b0 /devel
parentd5ae2d60af2b036b329d27dcaedcc0b9de0a3581 (diff)
downloadfreebsd-ports-gnome-33b3de5d2ad3808104d138e934870648b30c2367.tar.gz
freebsd-ports-gnome-33b3de5d2ad3808104d138e934870648b30c2367.tar.zst
freebsd-ports-gnome-33b3de5d2ad3808104d138e934870648b30c2367.zip
Bobcat is an acronym of `Brokken's Own Base Classes And Templates'. It
is a shared library implementing C++ classes that are frequently used in software developed by Frank Brokken. Frank's existing programs will depend on `bobcat' in the near future. WWW: http://bobcat.sourceforge.net/ Approved by: tabthorpe
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libbobcat/Makefile75
-rw-r--r--devel/libbobcat/distinfo3
-rw-r--r--devel/libbobcat/files/patch-INSTALL.im11
-rw-r--r--devel/libbobcat/files/patch-hostname-hostname.ih10
-rw-r--r--devel/libbobcat/files/patch-icmake-man29
-rw-r--r--devel/libbobcat/files/patch-inetaddress-inetaddress10
-rw-r--r--devel/libbobcat/files/patch-inetaddress-inetaddress.ih10
-rw-r--r--devel/libbobcat/files/patch-process-process.ih10
-rw-r--r--devel/libbobcat/pkg-descr6
-rw-r--r--devel/libbobcat/pkg-plist69
11 files changed, 234 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a2e4e10c3250..c92c686e5677 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -597,6 +597,7 @@
SUBDIR += libbfd
SUBDIR += libbinio
SUBDIR += libbnr
+ SUBDIR += libbobcat
SUBDIR += libbonobo
SUBDIR += libbonobo-reference
SUBDIR += libbonobomm
diff --git a/devel/libbobcat/Makefile b/devel/libbobcat/Makefile
new file mode 100644
index 000000000000..19a8a2257b29
--- /dev/null
+++ b/devel/libbobcat/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: libbobcat
+# Date created: March 4, 2009
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libbobcat
+PORTVERSION= 2.00.1
+CATEGORIES= devel
+MASTER_SITES= SF
+DISTNAME= bobcat_${PORTVERSION}
+EXTRACT_SUFX= .orig.tar.gz
+
+MAINTAINER= pgj@FreeBSD.org
+COMMENT= Brokken's Own Base Classes And Templates
+
+BUILD_DEPENDS= icmake:${PORTSDIR}/devel/icmake \
+ ${LOCALBASE}/include/X11/Xlib.h:${PORTSDIR}/x11/libX11 \
+ yodl>=2.0:${PORTSDIR}/textproc/yodl
+
+MANCOMPRESSED= yes
+MAN3= a2x.3bobcat align.3bobcat arg.3bobcat argconfig.3bobcat \
+ autoptr.3bobcat binarysearch.3bobcat cgi.3bobcat \
+ clientsocket.3bobcat cmdfinder.3bobcat cmdfinderbase.3bobcat \
+ configfile.3bobcat datetime.3bobcat errno.3bobcat \
+ fnwrap1.3bobcat fnwrap1c.3bobcat fnwrap2.3bobcat \
+ fnwrap2c.3bobcat foreach.3bobcat fork.3bobcat \
+ gethostent.3bobcat glob.3bobcat hash.3bobcat hostent.3bobcat \
+ hostname.3bobcat ifdstream.3bobcat ifdstreambuf.3bobcat \
+ indent.3bobcat inetaddress.3bobcat iostream.3bobcat \
+ iostreambuf.3bobcat irandstream.3bobcat level.3bobcat \
+ localclientsocket.3bobcat localserversocket.3bobcat \
+ localsocketbase.3bobcat log.3bobcat logbuffer.3bobcat \
+ mailheaders.3bobcat manipulators.3bobcat milter.3bobcat \
+ msg.3bobcat multistreambuf.3bobcat ofdstream.3bobcat \
+ ofdstreambuf.3bobcat onekey.3bobcat pattern.3bobcat \
+ pipe.3bobcat process.3bobcat randbuffer.3bobcat \
+ redirector.3bobcat refcount.3bobcat repeat.3bobcat \
+ selector.3bobcat serversocket.3bobcat socketbase.3bobcat \
+ stat.3bobcat string.3bobcat syslogbuf.3bobcat \
+ syslogstream.3bobcat table.3bobcat tablesupport.3bobcat \
+ typetrait.3bobcat user.3bobcat x2a.3bobcat xpointer.3bobcat
+MAN7= bobcat.7
+
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= *
+
+USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/bobcat-${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|"/usr"|"${PREFIX}"| ; \
+ s|"/share/doc/libbobcat2"|"/share/doc/${PORTNAME}-${PORTVERSION}"| ; \
+ s|"/share/doc/libbobcat2-dev"|"/share/doc/${PORTNAME}-${PORTVERSION}/dev"| ; \
+ s|"/share/man"|"/man"|' \
+ ${WRKSRC}/INSTALL.im
+ @${REINPLACE_CMD} -e 's|#!/usr/bin/icmake|#!${LOCALBASE}/bin/icmake| ; \
+ s|"-Itmp -Wall -O3"|"-Itmp -I${LOCALBASE}/include -Wall ${CXXFLAGS}"|' \
+ ${WRKSRC}/build
+ @${REINPLACE_CMD} -e 's|"cp -d |"cp -Pp | ; \
+ s|"cp -r |"cp -R |' \
+ ${WRKSRC}/icmake/install
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|#define DOCOTHER||' \
+ ${WRKSRC}/INSTALL.im
+.endif
+
+do-build:
+ @cd ${WRKSRC} && ./build libraries all strip && ./build man
+
+do-install:
+ @cd ${WRKSRC} && ./build install
+
+.include <bsd.port.mk>
diff --git a/devel/libbobcat/distinfo b/devel/libbobcat/distinfo
new file mode 100644
index 000000000000..42b561ecefed
--- /dev/null
+++ b/devel/libbobcat/distinfo
@@ -0,0 +1,3 @@
+MD5 (bobcat_2.00.1.orig.tar.gz) = 967356328cbc29f825f52d2f606e9c21
+SHA256 (bobcat_2.00.1.orig.tar.gz) = cf652b66b9bd5542d979c1465f0c5478df6a441fde3c9d95bdef149313731710
+SIZE (bobcat_2.00.1.orig.tar.gz) = 495892
diff --git a/devel/libbobcat/files/patch-INSTALL.im b/devel/libbobcat/files/patch-INSTALL.im
new file mode 100644
index 000000000000..760d005cb134
--- /dev/null
+++ b/devel/libbobcat/files/patch-INSTALL.im
@@ -0,0 +1,11 @@
+--- INSTALL.im.orig 2008-11-21 15:06:28.000000000 +0100
++++ INSTALL.im 2009-03-04 20:15:22.000000000 +0100
+@@ -9,8 +9,6 @@
+ // Install the headers, remove if not requested
+ #define MANPAGES
+ // Install the manpages, remove if not requested
+-#define MANHTML
+- // Install the html-versions of the manpages, remove if not requested
+ #define DOCOTHER
+ // Install remaining docs (README, examples, etc), remove if not requested
+
diff --git a/devel/libbobcat/files/patch-hostname-hostname.ih b/devel/libbobcat/files/patch-hostname-hostname.ih
new file mode 100644
index 000000000000..61ca53163e73
--- /dev/null
+++ b/devel/libbobcat/files/patch-hostname-hostname.ih
@@ -0,0 +1,10 @@
+--- hostname/hostname.ih.orig 2007-02-13 13:29:39.000000000 +0100
++++ hostname/hostname.ih 2009-03-04 12:30:14.000000000 +0100
+@@ -3,6 +3,7 @@
+ #include <bobcat/inetaddress>
+ #include <bobcat/gethostent>
+ #include <netdb.h>
++#include <sys/socket.h>
+
+ using namespace std;
+ using namespace FBB;
diff --git a/devel/libbobcat/files/patch-icmake-man b/devel/libbobcat/files/patch-icmake-man
new file mode 100644
index 000000000000..75ba17cba76e
--- /dev/null
+++ b/devel/libbobcat/files/patch-icmake-man
@@ -0,0 +1,29 @@
+--- icmake/man.orig 2007-02-13 13:29:38.000000000 +0100
++++ icmake/man 2009-03-04 20:38:35.000000000 +0100
+@@ -9,7 +9,7 @@
+
+ special(0, 0);
+
+- md("tmp/man/man3 tmp/man/man7 tmp/manhtml");
++ md("tmp/man/man3 tmp/man/man7");
+
+ chdir("documentation/man");
+
+@@ -35,8 +35,6 @@
+
+ run("yodl2man --no-warnings -o ../../tmp/man/man3/" +
+ base + ".3bobcat " + yodl);
+- run("yodl2html --no-warnings -o ../../tmp/manhtml/" +
+- base + ".3.html " + yodl);
+ }
+ }
+
+@@ -44,8 +42,6 @@
+ {
+ run("yodl2man --no-warnings -o ../../tmp/man/man7/bobcat.7 "
+ "bobcat.yo");
+- run("yodl2html --no-warnings -o ../../tmp/manhtml/bobcat.7.html "
+- "bobcat.yo");
+ }
+
+ run("touch man-stamp");
diff --git a/devel/libbobcat/files/patch-inetaddress-inetaddress b/devel/libbobcat/files/patch-inetaddress-inetaddress
new file mode 100644
index 000000000000..765671cf79fd
--- /dev/null
+++ b/devel/libbobcat/files/patch-inetaddress-inetaddress
@@ -0,0 +1,10 @@
+--- inetaddress/inetaddress.orig 2009-03-05 23:39:43.000000000 +0100
++++ inetaddress/inetaddress 2009-03-05 23:37:27.000000000 +0100
+@@ -4,6 +4,7 @@
+ #include <netinet/in.h>
+ #include <string>
+ #include <bobcat/errno>
++#include <sys/socket.h>
+
+ /*
+ int-info coming in or going out: host byte order
diff --git a/devel/libbobcat/files/patch-inetaddress-inetaddress.ih b/devel/libbobcat/files/patch-inetaddress-inetaddress.ih
new file mode 100644
index 000000000000..d2a86a359453
--- /dev/null
+++ b/devel/libbobcat/files/patch-inetaddress-inetaddress.ih
@@ -0,0 +1,10 @@
+--- inetaddress/inetaddress.ih.orig 2007-02-13 13:29:39.000000000 +0100
++++ inetaddress/inetaddress.ih 2009-03-04 12:16:16.000000000 +0100
+@@ -2,6 +2,7 @@
+
+ #include <netdb.h>
+ #include <bobcat/gethostent>
++#include <sys/socket.h>
+
+ using namespace std;
+ using namespace FBB;
diff --git a/devel/libbobcat/files/patch-process-process.ih b/devel/libbobcat/files/patch-process-process.ih
new file mode 100644
index 000000000000..60a2ea0bb0d2
--- /dev/null
+++ b/devel/libbobcat/files/patch-process-process.ih
@@ -0,0 +1,10 @@
+--- process/process.ih.orig 2008-11-03 16:24:04.000000000 +0100
++++ process/process.ih 2009-03-04 12:19:54.000000000 +0100
+@@ -6,6 +6,7 @@
+ #include <sys/types.h>
+ // #include <sys/stat.h>
+ #include <sys/wait.h>
++#include <signal.h>
+
+ #include <bobcat/errno>
+ #include <bobcat/redirector>
diff --git a/devel/libbobcat/pkg-descr b/devel/libbobcat/pkg-descr
new file mode 100644
index 000000000000..ddbfde4c77cf
--- /dev/null
+++ b/devel/libbobcat/pkg-descr
@@ -0,0 +1,6 @@
+Bobcat is an acronym of `Brokken's Own Base Classes And Templates'. It
+is a shared library implementing C++ classes that are frequently used in
+software developed by Frank Brokken. Frank's existing programs will
+depend on `bobcat' in the near future.
+
+WWW: http://bobcat.sourceforge.net/
diff --git a/devel/libbobcat/pkg-plist b/devel/libbobcat/pkg-plist
new file mode 100644
index 000000000000..ab567a5b87c6
--- /dev/null
+++ b/devel/libbobcat/pkg-plist
@@ -0,0 +1,69 @@
+@comment $FreeBSD$
+include/bobcat/xpointer
+include/bobcat/milter
+include/bobcat/argconfig
+include/bobcat/cgi
+include/bobcat/foreach
+include/bobcat/repeat
+include/bobcat/serversocket
+include/bobcat/clientsocket
+include/bobcat/socketbase
+include/bobcat/inetaddress
+include/bobcat/cmdfinderbase
+include/bobcat/table
+include/bobcat/process
+include/bobcat/localserversocket
+include/bobcat/localclientsocket
+include/bobcat/level
+include/bobcat/gethostent
+include/bobcat/configfile
+include/bobcat/cmdfinder
+include/bobcat/arg
+include/bobcat/user
+include/bobcat/tablesupport
+include/bobcat/syslogstream
+include/bobcat/string
+include/bobcat/stat
+include/bobcat/selector
+include/bobcat/redirector
+include/bobcat/pipe
+include/bobcat/pattern
+include/bobcat/onekey
+include/bobcat/ofdstream
+include/bobcat/multistreambuf
+include/bobcat/msg
+include/bobcat/mailheaders
+include/bobcat/log
+include/bobcat/localsocketbase
+include/bobcat/irandstream
+include/bobcat/iostream
+include/bobcat/ifdstream
+include/bobcat/hostname
+include/bobcat/glob
+include/bobcat/fork
+include/bobcat/fnwrap2c
+include/bobcat/fnwrap2
+include/bobcat/fnwrap1c
+include/bobcat/fnwrap1
+include/bobcat/autoptr
+include/bobcat/x2a
+include/bobcat/typetrait
+include/bobcat/syslogbuf
+include/bobcat/refcount
+include/bobcat/randbuffer
+include/bobcat/logbuffer
+include/bobcat/ofdstreambuf
+include/bobcat/iostreambuf
+include/bobcat/indent
+include/bobcat/ifdstreambuf
+include/bobcat/hostent
+include/bobcat/hash
+include/bobcat/errno
+include/bobcat/datetime
+include/bobcat/align
+include/bobcat/a2x
+lib/libbobcat.a
+lib/libbobcat.so.2.00.1
+lib/libbobcat.so.2
+lib/libbobcat.so
+@dirrm include/bobcat