aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2012-01-03 17:36:00 +0800
committergahr <gahr@FreeBSD.org>2012-01-03 17:36:00 +0800
commit358beb66f75811310c9327c457fdb7620af0a510 (patch)
tree88d500a27a826e0c1317ff0542d496421bd22dff /devel
parentc58b09244c36c003b8c6fa6b8be1200024e41424 (diff)
downloadfreebsd-ports-gnome-358beb66f75811310c9327c457fdb7620af0a510.tar.gz
freebsd-ports-gnome-358beb66f75811310c9327c457fdb7620af0a510.tar.zst
freebsd-ports-gnome-358beb66f75811310c9327c457fdb7620af0a510.zip
- Update to 5.1.0
Diffstat (limited to 'devel')
-rw-r--r--devel/ucommon/Makefile2
-rw-r--r--devel/ucommon/distinfo4
-rw-r--r--devel/ucommon/files/patch-commoncpp_exception.cpp11
3 files changed, 14 insertions, 3 deletions
diff --git a/devel/ucommon/Makefile b/devel/ucommon/Makefile
index e38952af96c0..fe5009d06888 100644
--- a/devel/ucommon/Makefile
+++ b/devel/ucommon/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ucommon
-PORTVERSION= 5.0.7
+PORTVERSION= 5.1.0
CATEGORIES= devel
MASTER_SITES= GNU
MASTER_SITE_SUBDIR= commoncpp
diff --git a/devel/ucommon/distinfo b/devel/ucommon/distinfo
index 1d0d715cd5a6..a07ea037f251 100644
--- a/devel/ucommon/distinfo
+++ b/devel/ucommon/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ucommon-5.0.7.tar.gz) = de4e8bb603dd3d8556e5732483277d47222f36a46c23a4d4c1b709b3b8fc247f
-SIZE (ucommon-5.0.7.tar.gz) = 768085
+SHA256 (ucommon-5.1.0.tar.gz) = c60589df263c535896069a31878e0e5e601dc124826cb3c478cb6df969598d94
+SIZE (ucommon-5.1.0.tar.gz) = 769809
diff --git a/devel/ucommon/files/patch-commoncpp_exception.cpp b/devel/ucommon/files/patch-commoncpp_exception.cpp
new file mode 100644
index 000000000000..03006521a74d
--- /dev/null
+++ b/devel/ucommon/files/patch-commoncpp_exception.cpp
@@ -0,0 +1,11 @@
+--- commoncpp/exception.cpp.orig 2012-01-03 10:17:46.000000000 +0100
++++ commoncpp/exception.cpp 2012-01-03 10:19:18.000000000 +0100
+@@ -89,7 +89,7 @@
+ if ( !_systemErrorString )
+ _systemErrorString = new char[errStrSize];
+ #ifndef _MSWINDOWS_
+-#if (_POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600) && ! _GNU_SOURCE
++#if (_POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600) && defined(_GNU_SOURCE)
+ strerror_r(_systemError, _systemErrorString, errStrSize);
+ return _systemErrorString;
+ #else