aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-06-01 02:32:56 +0800
committeraaron <aaron@FreeBSD.org>2006-06-01 02:32:56 +0800
commit35b0ae1baecbc24fba2a0848366a28c946b758d4 (patch)
tree2693c69a51e4879166b04344cd0c368bf3def74f /devel
parent5c2a37513e370a4acef24e1cfb7f08c8ca4200d0 (diff)
downloadfreebsd-ports-gnome-35b0ae1baecbc24fba2a0848366a28c946b758d4.tar.gz
freebsd-ports-gnome-35b0ae1baecbc24fba2a0848366a28c946b758d4.tar.zst
freebsd-ports-gnome-35b0ae1baecbc24fba2a0848366a28c946b758d4.zip
Adding port devel/p5-Module-Loaded, an easy way to mark modules as loaded or unloaded.
Approved by: tobez (implicit)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Module-Loaded/Makefile30
-rw-r--r--devel/p5-Module-Loaded/distinfo3
-rw-r--r--devel/p5-Module-Loaded/pkg-descr9
-rw-r--r--devel/p5-Module-Loaded/pkg-plist5
5 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c606dd7d9288..b5ebb27cbcd3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1096,6 +1096,7 @@
SUBDIR += p5-Module-Install
SUBDIR += p5-Module-Load
SUBDIR += p5-Module-Load-Conditional
+ SUBDIR += p5-Module-Loaded
SUBDIR += p5-Module-Pluggable
SUBDIR += p5-Module-Pluggable-Fast
SUBDIR += p5-Module-Pluggable-Ordered
diff --git a/devel/p5-Module-Loaded/Makefile b/devel/p5-Module-Loaded/Makefile
new file mode 100644
index 000000000000..a1a05846279c
--- /dev/null
+++ b/devel/p5-Module-Loaded/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Module-Loaded
+# Date created: 31 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Module-Loaded
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Module
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Mark modules as loaded or unloaded
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+MAN3= Module::Loaded.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Module-Loaded/distinfo b/devel/p5-Module-Loaded/distinfo
new file mode 100644
index 000000000000..b893c6e63985
--- /dev/null
+++ b/devel/p5-Module-Loaded/distinfo
@@ -0,0 +1,3 @@
+MD5 (Module-Loaded-0.01.tar.gz) = bf2830c75b4ce78ebeee7f5ed074ea2a
+SHA256 (Module-Loaded-0.01.tar.gz) = 3a3b4fe5b70c906fd8c552011423b1c7bfa9d1230d5d53ea55ef34fd52126646
+SIZE (Module-Loaded-0.01.tar.gz) = 2848
diff --git a/devel/p5-Module-Loaded/pkg-descr b/devel/p5-Module-Loaded/pkg-descr
new file mode 100644
index 000000000000..3af7d0673e7a
--- /dev/null
+++ b/devel/p5-Module-Loaded/pkg-descr
@@ -0,0 +1,9 @@
+When testing applications, often you find yourself needing to provide
+functionality in your test environment that would usually be provided by
+external modules. Rather than munging the %INC by hand to mark these
+external modules as loaded, so they are not attempted to be loaded by
+perl, this module offers you a very simple way to mark modules as loaded
+and/or unloaded.
+
+WWW: http://search.cpan.org/dist/Module-Loaded
+Author: Jos Boumans <kane@cpan.org>
diff --git a/devel/p5-Module-Loaded/pkg-plist b/devel/p5-Module-Loaded/pkg-plist
new file mode 100644
index 000000000000..a26ccc7354f6
--- /dev/null
+++ b/devel/p5-Module-Loaded/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Module/Loaded.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Module/Loaded/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Module/Loaded
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Module
+@dirrmtry %%SITE_PERL%%/Module