aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2003-01-28 05:08:42 +0800
committertobez <tobez@FreeBSD.org>2003-01-28 05:08:42 +0800
commit35df91e5da1518eb0eb1e563f6c140402d9ebde2 (patch)
tree62a2f0113e89d8cda31277f81da1416126317eaf /devel
parent6fdae52f70224e8915375cb74dc8fc72314ff40e (diff)
downloadfreebsd-ports-gnome-35df91e5da1518eb0eb1e563f6c140402d9ebde2.tar.gz
freebsd-ports-gnome-35df91e5da1518eb0eb1e563f6c140402d9ebde2.tar.zst
freebsd-ports-gnome-35df91e5da1518eb0eb1e563f6c140402d9ebde2.zip
Add p5-Attribute-Handlers 0.78, a perl module that provides simple
definition of attribute handlers. PR: 47558 Submitted by: Erwin Lansing <erwin@lansing.dk>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Attribute-Handlers/Makefile31
-rw-r--r--devel/p5-Attribute-Handlers/distinfo1
-rw-r--r--devel/p5-Attribute-Handlers/pkg-comment1
-rw-r--r--devel/p5-Attribute-Handlers/pkg-descr9
-rw-r--r--devel/p5-Attribute-Handlers/pkg-plist6
6 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 030867fb3544..a334b70d7393 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -417,6 +417,7 @@
SUBDIR += p5-AppConfig
SUBDIR += p5-AppConfig-Std
SUBDIR += p5-AtExit
+ SUBDIR += p5-Attribute-Handlers
SUBDIR += p5-B-Graph
SUBDIR += p5-BSD-Resource
SUBDIR += p5-BSD-stat
diff --git a/devel/p5-Attribute-Handlers/Makefile b/devel/p5-Attribute-Handlers/Makefile
new file mode 100644
index 000000000000..83ec00dbd2a9
--- /dev/null
+++ b/devel/p5-Attribute-Handlers/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Attribute-Handlers
+# Date created: January 27th 2003
+# Whom: Erwin Lansing <erwin@lansing.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Attribute-Handlers
+PORTVERSION= 0.78
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Attribute
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@lansing.dk
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Attribute::Handlers.3
+
+.include <bsd.port.pre.mk>
+
+##
+## this port requires PERL 5.6.x or later
+##
+.if ${PERL_LEVEL} < 500600
+BROKEN= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Attribute-Handlers/distinfo b/devel/p5-Attribute-Handlers/distinfo
new file mode 100644
index 000000000000..eff84de6a956
--- /dev/null
+++ b/devel/p5-Attribute-Handlers/distinfo
@@ -0,0 +1 @@
+MD5 (Attribute-Handlers-0.78.tar.gz) = c935f240bee1baf4b46e7d69bf2f1636
diff --git a/devel/p5-Attribute-Handlers/pkg-comment b/devel/p5-Attribute-Handlers/pkg-comment
new file mode 100644
index 000000000000..4c26a6b9c26f
--- /dev/null
+++ b/devel/p5-Attribute-Handlers/pkg-comment
@@ -0,0 +1 @@
+Attribute::Handlers - Simpler definition of attribute handlers
diff --git a/devel/p5-Attribute-Handlers/pkg-descr b/devel/p5-Attribute-Handlers/pkg-descr
new file mode 100644
index 000000000000..ca1ac31da295
--- /dev/null
+++ b/devel/p5-Attribute-Handlers/pkg-descr
@@ -0,0 +1,9 @@
+This module, when inherited by a package, allows that package's
+class to define attribute handler subroutines for specific
+attributes. Variables and subroutines subsequently defined in
+that package, or in packages derived from that package may be
+given attributes with the same names as the attribute handler
+subroutines, which will then be called in one of the
+compilation phases (i.e. in a BEGIN, CHECK, INIT, or END block).
+
+WWW: http://search.cpan.org/dist/Attribute-Handlers/
diff --git a/devel/p5-Attribute-Handlers/pkg-plist b/devel/p5-Attribute-Handlers/pkg-plist
new file mode 100644
index 000000000000..9e8ab9a82d7e
--- /dev/null
+++ b/devel/p5-Attribute-Handlers/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/mach/auto/Attribute/Handlers/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Attribute/Handlers.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/mach/auto/Attribute/Handlers
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/mach/auto/Attribute
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/mach/auto 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Attribute