aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorimura <imura@FreeBSD.org>2000-02-25 00:09:50 +0800
committerimura <imura@FreeBSD.org>2000-02-25 00:09:50 +0800
commit38480e9cda986fcb5a4c82e4c83b82ecea9e7ff6 (patch)
treedeab173ca08efd9d039d0c29ae117c3c56ab3769 /devel
parentb5354e8162816efd9b1dbbb4fd928eaaf7156b5d (diff)
downloadfreebsd-ports-gnome-38480e9cda986fcb5a4c82e4c83b82ecea9e7ff6.tar.gz
freebsd-ports-gnome-38480e9cda986fcb5a4c82e4c83b82ecea9e7ff6.tar.zst
freebsd-ports-gnome-38480e9cda986fcb5a4c82e4c83b82ecea9e7ff6.zip
Small modification to respect $(CXX)
Obtained from: Will's Qt/KDE site.
Diffstat (limited to 'devel')
-rw-r--r--devel/qtarch/files/patch-aa13
1 files changed, 9 insertions, 4 deletions
diff --git a/devel/qtarch/files/patch-aa b/devel/qtarch/files/patch-aa
index 57de6c07917e..826434423d99 100644
--- a/devel/qtarch/files/patch-aa
+++ b/devel/qtarch/files/patch-aa
@@ -39,15 +39,18 @@
#CFLAGS = -O2 -fno-strength-reduce -W -Wtemplate-debugging -Wparentheses \
# -Wuninitialized -Wchar-subscripts -Wformat -Wtrigraphs -Wcomment \
# -Wswitch -Wunused -Wreturn-type -Wimplicit -Wpointer-arith -Wsynth \
-@@ -26,7 +26,7 @@
+@@ -26,9 +26,9 @@
bmp/libbmp.a \
layout/liblayout.a \
pixmap/libpixmap.a \
- -lfl -lqt -lstdc++ -ldl -rdynamic
+ -lfl -lqt -lstdc++ -lX11 -lm -rdynamic
ARFLAGS = -crs
- CC = g++
+-CC = g++
++CC = $(CXX)
AR = ar
+ FLEX = flex
+ MAKE = gmake
--- bmp/Makefile.orig Fri Jan 29 04:41:35 1999
+++ bmp/Makefile Sat May 8 00:50:27 1999
@@ -85,7 +85,7 @@
@@ -67,12 +70,14 @@
ifdef BUILD_RELEASE
CFLAGS = -O2 -fno-strength-reduce -Wall -W -pipe -fPIC
-@@ -6,7 +6,7 @@
+@@ -6,8 +6,8 @@
CFLAGS = -g -Wall -W -pipe -fPIC
endif
-LDFLAGS = -g -shared -L$(QTDIR)/lib -L/opt/kde/lib -lqt -lkdecore -lkdeui
+-CC = g++
+LDFLAGS = -g -shared -L$(X11BASE)/lib -L$(PREFIX)/lib -lqt -lkdecore -lkdeui
- CC = g++
++CC = $(CXX)
MOC = moc
QTARCHBIN = ../../qtarch
+