aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-04-01 16:54:22 +0800
committerpawel <pawel@FreeBSD.org>2014-04-01 16:54:22 +0800
commit398ec884f440c6b6d37467e7781ce435ed6a525f (patch)
tree405cd358b92f3370194eda1a77c51b952cc68438 /devel
parent7eb3284df96e051c691cf30334a84fd67b660b9a (diff)
downloadfreebsd-ports-gnome-398ec884f440c6b6d37467e7781ce435ed6a525f.tar.gz
freebsd-ports-gnome-398ec884f440c6b6d37467e7781ce435ed6a525f.tar.zst
freebsd-ports-gnome-398ec884f440c6b6d37467e7781ce435ed6a525f.zip
- Add staging support
- Remove support for Lua 5.0, no longer in the tree
Diffstat (limited to 'devel')
-rw-r--r--devel/lua-pty/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/devel/lua-pty/Makefile b/devel/lua-pty/Makefile
index d7cc41361bb0..9d1d56292c57 100644
--- a/devel/lua-pty/Makefile
+++ b/devel/lua-pty/Makefile
@@ -13,20 +13,11 @@ DISTFILES= pty.lua?rev=1.2 pty.c?rev=1.25
MAINTAINER= ports@FreeBSD.org
COMMENT= Pty (pseudo-terminal) bindings for Lua 5
-USE_LUA?= 5.1
-
-.if ${USE_LUA} == 5.0
-LUA_COMPS= compat51 lua
-BUILD_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
-COMPAT_SRC= `(cd ${PORTSDIR}/devel/lua50-compat51 && ${MAKE} -V WRKSRC)`
-MAKE_ENV= COMPATDIR="${COMPAT_SRC}"
-DISTFILES+= compat-5.1r5.tar.gz:compat
-.endif
+USE_LUA= 5.1
PLIST_FILES= %%LUA_MODSHAREDIR%%/pty.lua \
%%LUA_MODLIBDIR%%/lpty.so
-NO_STAGE= yes
do-extract:
@${MKDIR} ${WRKSRC}
.for file in ${DISTFILES:C,:.*,,}
@@ -35,7 +26,9 @@ do-extract:
@${CP} ${FILESDIR}/Makefile ${WRKSRC}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/lpty.so ${LUA_MODLIBDIR}
- ${INSTALL_DATA} ${WRKSRC}/pty.lua ${LUA_MODSHAREDIR}
+ @${MKDIR} ${STAGEDIR}${LUA_MODLIBDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/lpty.so ${STAGEDIR}${LUA_MODLIBDIR}
+ @${MKDIR} ${STAGEDIR}${LUA_MODSHAREDIR}
+ ${INSTALL_DATA} ${WRKSRC}/pty.lua ${STAGEDIR}${LUA_MODSHAREDIR}
.include <bsd.port.mk>