aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-04-23 23:21:26 +0800
committerdinoex <dinoex@FreeBSD.org>2010-04-23 23:21:26 +0800
commit3a83b8d9289ab377fe477a890dcd6455987c94cb (patch)
tree7ea2650b54570bea90cbeeceed2541a65812f4e5 /devel
parent8acb0d30a077bb5b154753df123084398030354f (diff)
downloadfreebsd-ports-gnome-3a83b8d9289ab377fe477a890dcd6455987c94cb.tar.gz
freebsd-ports-gnome-3a83b8d9289ab377fe477a890dcd6455987c94cb.tar.zst
freebsd-ports-gnome-3a83b8d9289ab377fe477a890dcd6455987c94cb.zip
- PHP 5.2 slave port
PR: 145772 Submitted by: Alex Keda
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/php52-pcre/Makefile14
-rw-r--r--devel/php52-pcre/files/patch-php_pcre.c13
3 files changed, 28 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ccf02cb642d7..9d9bd888c373 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2469,6 +2469,7 @@
SUBDIR += php5-sysvsem
SUBDIR += php5-sysvshm
SUBDIR += php5-tokenizer
+ SUBDIR += php52-pcre
SUBDIR += phpbt
SUBDIR += phptags
SUBDIR += physfs
diff --git a/devel/php52-pcre/Makefile b/devel/php52-pcre/Makefile
new file mode 100644
index 000000000000..8f7de55fe7bc
--- /dev/null
+++ b/devel/php52-pcre/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-pcre
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= devel
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -pcre
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/php52-pcre/files/patch-php_pcre.c b/devel/php52-pcre/files/patch-php_pcre.c
new file mode 100644
index 000000000000..4cab8e3aefaf
--- /dev/null
+++ b/devel/php52-pcre/files/patch-php_pcre.c
@@ -0,0 +1,13 @@
+--- php_pcre.c.orig 2009-03-06 10:58:43.000000000 +0100
++++ php_pcre.c 2009-03-06 10:58:56.000000000 +0100
+@@ -18,6 +18,10 @@
+
+ /* $Id: php_pcre.c,v 1.168.2.9.2.30 2009/01/13 19:23:31 andrei Exp $ */
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #include "php.h"
+ #include "php_ini.h"
+ #include "php_globals.h"