aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2008-08-25 11:05:46 +0800
committerkuriyama <kuriyama@FreeBSD.org>2008-08-25 11:05:46 +0800
commit3b879bf265526a6d1b7ca830aefc6566e11e7fa7 (patch)
tree9b3d26ec1b24db833f64990796262c3fea300cc6 /devel
parentf9854e78e938881350faa0251107d8a67aff3bb3 (diff)
downloadfreebsd-ports-gnome-3b879bf265526a6d1b7ca830aefc6566e11e7fa7.tar.gz
freebsd-ports-gnome-3b879bf265526a6d1b7ca830aefc6566e11e7fa7.tar.zst
freebsd-ports-gnome-3b879bf265526a6d1b7ca830aefc6566e11e7fa7.zip
- Temp fix to be built on tinderbox.
- Hopefully someone will grab maintainership of this port and do actually fix. Reported by: QA Tindy
Diffstat (limited to 'devel')
-rw-r--r--devel/php5-phing/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/devel/php5-phing/Makefile b/devel/php5-phing/Makefile
index 168b100f5da9..d56d8c02eb26 100644
--- a/devel/php5-phing/Makefile
+++ b/devel/php5-phing/Makefile
@@ -7,7 +7,7 @@
PORTNAME= phing
PORTVERSION= 2.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://pear.phing.info/get/
@@ -37,6 +37,7 @@ FILES= etc/log.xsl etc/phpunit2-noframes.xsl etc/phpunit2-frames.xsl \
BuildLogger.php TaskContainer.php BuildEvent.php Task.php \
TaskAdapter.php Phing.php RuntimeConfigurable.php BuildListener.php \
Project.php UnknownElement.php BuildException.php Target.php \
+ phing.php \
util/regexp/RegexpEngine.php util/regexp/Regexp.php \
util/regexp/PregEngine.php \
util/SourceFileScanner.php util/ExtendedFileStream.php \
@@ -219,18 +220,19 @@ FILES= etc/log.xsl etc/phpunit2-noframes.xsl etc/phpunit2-frames.xsl \
DOCS=
EXAMPLES= src/HelloWorldTest.php src/HelloWorld.php build.xml
SQLS=
-SCRIPTFILES=
+SCRIPTFILES= phing
TESTS=
post-extract:
${MV} ${WRKSRC}/example ${WRKSRC}/examples
+
+post-patch:
+ ${MKDIR} ${WRKSRC}/pear-bin
${SED} -e "s|/opt/phing|${PREFIX}/lib/php/phing|" \
-e "s|@PHP-BIN@|${PREFIX}/bin/php|" \
-e "s|@PEAR-DIR@|${PREFIX}/share/pear|" \
- ${WRKSRC}/bin/pear-phing > ${WRKSRC}/bin/pear-phing.new
- @${INSTALL_SCRIPT} ${WRKSRC}/bin/pear-phing.new ${PREFIX}/bin/phing
- ${INSTALL_DATA} ${WRKSRC}/bin/phing.php ${PREFIX}/share/pear/phing.php
- @${CHMOD} 755 ${PREFIX}/bin/phing
+ ${WRKSRC}/bin/pear-phing > ${WRKSRC}/pear-phing
+ ${CP} ${WRKSRC}/bin/phing.php ${WRKSRC}/phing.php
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"