aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2004-10-15 12:58:00 +0800
committerade <ade@FreeBSD.org>2004-10-15 12:58:00 +0800
commit3b9b97d4d1ff5d8548403ece7756be72b25d5356 (patch)
tree30399ff3cfc4b00e237693248c46ecfb6b57e807 /devel
parent3af96d3333917f75c13902e2c2e2d019d559029e (diff)
downloadfreebsd-ports-gnome-3b9b97d4d1ff5d8548403ece7756be72b25d5356.tar.gz
freebsd-ports-gnome-3b9b97d4d1ff5d8548403ece7756be72b25d5356.tar.zst
freebsd-ports-gnome-3b9b97d4d1ff5d8548403ece7756be72b25d5356.zip
Too clever for my own good. Unbreak libltdl15.
Submitted by: sf
Diffstat (limited to 'devel')
-rw-r--r--devel/gnu-libtool/Makefile7
-rw-r--r--devel/libtool15/Makefile7
2 files changed, 10 insertions, 4 deletions
diff --git a/devel/gnu-libtool/Makefile b/devel/gnu-libtool/Makefile
index c4af60d427b2..92a14c4fe74a 100644
--- a/devel/gnu-libtool/Makefile
+++ b/devel/gnu-libtool/Makefile
@@ -25,7 +25,10 @@ CONFIGURE_ARGS+= --program-suffix=${BUILD_VERSION}
CONFIGURE_ENV= PREFIX=${PREFIX} PACKAGE=libtool${BUILD_VERSION}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_REINPLACE= yes
+
+.if ${PORTNAME} == "libtool"
INFO= libtool${BUILD_VERSION}
+.endif
post-patch:
@(cd ${WRKSRC}/doc && \
@@ -44,8 +47,8 @@ post-install:
.for i in libtool libtoolize
@${LN} -sf ${PREFIX}/bin/${i}${BUILD_VERSION} ${PREFIX}/libexec/libtool${BUILD_VERSION}/${i}
.endfor
-.endif
-
@install-info ${PREFIX}/info/libtool${BUILD_VERSION}.info \
${PREFIX}/info/dir
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/libtool15/Makefile b/devel/libtool15/Makefile
index c4af60d427b2..92a14c4fe74a 100644
--- a/devel/libtool15/Makefile
+++ b/devel/libtool15/Makefile
@@ -25,7 +25,10 @@ CONFIGURE_ARGS+= --program-suffix=${BUILD_VERSION}
CONFIGURE_ENV= PREFIX=${PREFIX} PACKAGE=libtool${BUILD_VERSION}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_REINPLACE= yes
+
+.if ${PORTNAME} == "libtool"
INFO= libtool${BUILD_VERSION}
+.endif
post-patch:
@(cd ${WRKSRC}/doc && \
@@ -44,8 +47,8 @@ post-install:
.for i in libtool libtoolize
@${LN} -sf ${PREFIX}/bin/${i}${BUILD_VERSION} ${PREFIX}/libexec/libtool${BUILD_VERSION}/${i}
.endfor
-.endif
-
@install-info ${PREFIX}/info/libtool${BUILD_VERSION}.info \
${PREFIX}/info/dir
+.endif
+
.include <bsd.port.mk>