aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-01 03:47:30 +0800
committermiwi <miwi@FreeBSD.org>2009-03-01 03:47:30 +0800
commit3c6762b76105557e46c4b83346c0ef87682f6a2f (patch)
treefa041b07c52883712d1649548c05b985e7f1cf53 /devel
parent1926d34b01d54374798c3c6d1ff76a45a10fd1cf (diff)
downloadfreebsd-ports-gnome-3c6762b76105557e46c4b83346c0ef87682f6a2f.tar.gz
freebsd-ports-gnome-3c6762b76105557e46c4b83346c0ef87682f6a2f.tar.zst
freebsd-ports-gnome-3c6762b76105557e46c4b83346c0ef87682f6a2f.zip
This module provides a faster but less secure version of Class::Std.
WWW: http://search.cpan.org/dist/Class-Std-Fast/ PR: ports/132197 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Std-Fast/Makefile27
-rw-r--r--devel/p5-Class-Std-Fast/distinfo3
-rw-r--r--devel/p5-Class-Std-Fast/pkg-descr3
-rw-r--r--devel/p5-Class-Std-Fast/pkg-plist9
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 455a15cfb4f5..322c63f3e8a0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1076,6 +1076,7 @@
SUBDIR += p5-Class-Spiffy
SUBDIR += p5-Class-StateMachine
SUBDIR += p5-Class-Std
+ SUBDIR += p5-Class-Std-Fast
SUBDIR += p5-Class-StrongSingleton
SUBDIR += p5-Class-Tangram
SUBDIR += p5-Class-Throwable
diff --git a/devel/p5-Class-Std-Fast/Makefile b/devel/p5-Class-Std-Fast/Makefile
new file mode 100644
index 000000000000..596dbab04144
--- /dev/null
+++ b/devel/p5-Class-Std-Fast/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Class-Std-Fast
+# Date created: 28 Feb, 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Std-Fast
+DISTVERSION= v0.0.8
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Faster but less secure than Class::Std
+
+BUILD_DEPENDS= p5-Test-Simple>=0.86:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
+ p5-Class-Std>=0.0.9:${PORTSDIR}/devel/p5-Class-Std \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Data-Dumper>=2.121:${PORTSDIR}/devel/p5-Data-Dumper
+
+PERL_CONFIGURE= YES
+
+MAN3= Class::Std::Fast.3 Class::Std::Fast::Storable.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Std-Fast/distinfo b/devel/p5-Class-Std-Fast/distinfo
new file mode 100644
index 000000000000..e58e305eff82
--- /dev/null
+++ b/devel/p5-Class-Std-Fast/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-Std-Fast-v0.0.8.tar.gz) = d06d084cb84f295b0aabf2eee78ef746
+SHA256 (Class-Std-Fast-v0.0.8.tar.gz) = 1bd43763c6a373183097a30e787f5d6713b0db27511c52d533266b59d2cfa780
+SIZE (Class-Std-Fast-v0.0.8.tar.gz) = 20915
diff --git a/devel/p5-Class-Std-Fast/pkg-descr b/devel/p5-Class-Std-Fast/pkg-descr
new file mode 100644
index 000000000000..59122caf824e
--- /dev/null
+++ b/devel/p5-Class-Std-Fast/pkg-descr
@@ -0,0 +1,3 @@
+This module provides a faster but less secure version of Class::Std.
+
+WWW: http://search.cpan.org/dist/Class-Std-Fast/
diff --git a/devel/p5-Class-Std-Fast/pkg-plist b/devel/p5-Class-Std-Fast/pkg-plist
new file mode 100644
index 000000000000..83ac1291dfaa
--- /dev/null
+++ b/devel/p5-Class-Std-Fast/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/mach/auto/Class/Std/Fast/.packlist
+%%SITE_PERL%%/Class/Std/Fast.pm
+%%SITE_PERL%%/Class/Std/Fast/Storable.pm
+@dirrm %%SITE_PERL%%/mach/auto/Class/Std/Fast
+@dirrmtry %%SITE_PERL%%/mach/auto/Class/Std
+@dirrmtry %%SITE_PERL%%/mach/auto/Class
+@dirrmtry %%SITE_PERL%%/Class/Std/Fast
+@dirrmtry %%SITE_PERL%%/Class/Std
+@dirrmtry %%SITE_PERL%%/Class