aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-07-07 02:51:11 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-07-07 02:51:11 +0800
commit3d54e67bd16314c435b0ec6bf90a406f41fc6dd9 (patch)
tree571649ef29a7f00b92f3ea0f9130ecee6f011b7b /devel
parente11895bd4e5ca5fd0629b74615dbdbeaa875a082 (diff)
downloadfreebsd-ports-gnome-3d54e67bd16314c435b0ec6bf90a406f41fc6dd9.tar.gz
freebsd-ports-gnome-3d54e67bd16314c435b0ec6bf90a406f41fc6dd9.tar.zst
freebsd-ports-gnome-3d54e67bd16314c435b0ec6bf90a406f41fc6dd9.zip
- Add LICENSE
- Sort PLIST - Reformat pkg-descr
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-File-Slurp-Tree/Makefile5
-rw-r--r--devel/p5-File-Slurp-Tree/pkg-descr10
-rw-r--r--devel/p5-File-Slurp-Tree/pkg-plist4
3 files changed, 11 insertions, 8 deletions
diff --git a/devel/p5-File-Slurp-Tree/Makefile b/devel/p5-File-Slurp-Tree/Makefile
index 4e2012bdfa81..9bee3da6bc0e 100644
--- a/devel/p5-File-Slurp-Tree/Makefile
+++ b/devel/p5-File-Slurp-Tree/Makefile
@@ -10,11 +10,14 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Slurp and emit file trees as nested hashes
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
BUILD_DEPENDS= p5-File-Find-Rule>=0:${PORTSDIR}/devel/p5-File-Find-Rule \
p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
USE_PERL5= configure
+USES= perl5
.include <bsd.port.mk>
diff --git a/devel/p5-File-Slurp-Tree/pkg-descr b/devel/p5-File-Slurp-Tree/pkg-descr
index 0f8341f3ff40..54f9e92f84f7 100644
--- a/devel/p5-File-Slurp-Tree/pkg-descr
+++ b/devel/p5-File-Slurp-Tree/pkg-descr
@@ -1,5 +1,5 @@
-File::Slurp::Tree provides functions for slurping and emitting trees
-of files and directories.
+File::Slurp::Tree provides functions for slurping and emitting trees of files
+and directories.
# an example of use in a test suite
use Test::More tests => 1;
@@ -7,8 +7,8 @@ of files and directories.
is_deeply( slurp_tree( "t/some_path" ), { foo => {}, bar => "sample\n" },
"some_path contains a directory called foo, and a file bar" );
-The tree data structure is a hash of hashes. The keys of each hash are
-names of directories or files. Directories have hash references as
-their value, files have a scalar which holds the contents of the file.
+The tree data structure is a hash of hashes. The keys of each hash are names of
+directories or files. Directories have hash references as their value, files
+have a scalar which holds the contents of the file.
WWW: http://search.cpan.org/dist/File-Slurp-Tree/
diff --git a/devel/p5-File-Slurp-Tree/pkg-plist b/devel/p5-File-Slurp-Tree/pkg-plist
index 472b1f9b9efb..085c01057e8b 100644
--- a/devel/p5-File-Slurp-Tree/pkg-plist
+++ b/devel/p5-File-Slurp-Tree/pkg-plist
@@ -1,7 +1,7 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Slurp/Tree/.packlist
%%SITE_PERL%%/File/Slurp/Tree.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Slurp/Tree/.packlist
%%PERL5_MAN3%%/File::Slurp::Tree.3.gz
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Slurp/Tree
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Slurp/Tree
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Slurp
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
@dirrmtry %%SITE_PERL%%/File/Slurp