aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2011-05-26 02:00:36 +0800
committerbeech <beech@FreeBSD.org>2011-05-26 02:00:36 +0800
commit435ed178f5e3d9b41227bc940f5fa44fa96eb34c (patch)
treedc366d1b15eb28b3ca334db7526bb0e84f525639 /devel
parent71d95274648ada7f2bb7941f120368c4e462267f (diff)
downloadfreebsd-ports-gnome-435ed178f5e3d9b41227bc940f5fa44fa96eb34c.tar.gz
freebsd-ports-gnome-435ed178f5e3d9b41227bc940f5fa44fa96eb34c.tar.zst
freebsd-ports-gnome-435ed178f5e3d9b41227bc940f5fa44fa96eb34c.zip
-New port horde4-dateparser-1.0.0
-Horde Date Parser. Library for natural-language date parsing, with support for multiple languages and locales. Approved By: itetcu (mentor)(implicit)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/horde4-dateparser/.Makefile.kate-swpbin0 -> 161 bytes
-rw-r--r--devel/horde4-dateparser/Makefile48
-rw-r--r--devel/horde4-dateparser/distinfo2
-rw-r--r--devel/horde4-dateparser/files/pkg-message.in7
-rw-r--r--devel/horde4-dateparser/pkg-descr5
-rw-r--r--devel/horde4-dateparser/pkg-plist41
7 files changed, 104 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 43802018ed02..b6644c643430 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -554,6 +554,7 @@
SUBDIR += horde-whups
SUBDIR += horde4-content
SUBDIR += horde4-date
+ SUBDIR += horde4-dateparser
SUBDIR += horde4-rdo
SUBDIR += hp48cc
SUBDIR += hp48xgcc
diff --git a/devel/horde4-dateparser/.Makefile.kate-swp b/devel/horde4-dateparser/.Makefile.kate-swp
new file mode 100644
index 000000000000..9da2fa19efbd
--- /dev/null
+++ b/devel/horde4-dateparser/.Makefile.kate-swp
Binary files differ
diff --git a/devel/horde4-dateparser/Makefile b/devel/horde4-dateparser/Makefile
new file mode 100644
index 000000000000..e87e48bc46db
--- /dev/null
+++ b/devel/horde4-dateparser/Makefile
@@ -0,0 +1,48 @@
+# Ports collection makefile for: horde4-dateparser
+# Date created: Tue May 24, 2011
+# Whom: Beech Rintoul (<beech@FreeBSD.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= dateparser
+PORTVERSION= 1.0.0
+DISTVERSIONPREFIX=
+DISTVERSIONSUFFIX=
+CATEGORIES= devel www
+MASTER_SITES= http://pear.horde.org/get/ \
+ LOCAL/beech
+PKGNAMEPREFIX= horde4-
+DISTNAME= Horde_Date_Parser-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= beech@FreeBSD.org
+COMMENT= Library for natural-language date parsing
+
+USE_HORDE= base
+USE_GETTEXT= yes
+DATEDIR= Date
+HORDIR+= ${HORBAS}${DATEDIR:S|^|/|:S|/horde||}
+EXAMPLESDIR= ${PREFIX}/share/examples/horde
+
+RUN_DEPENDS+= ${HORBAS}/Date.php:${PORTSDIR}/devel/horde4-date
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/config && ${TOUCH} ${WRKSRC}/config/placeholder.dist
+
+do-install:
+ @${INSTALL} -d ${HORDIR}/
+ @${INSTALL} -d ${EXAMPLESDIR}/
+ @${CP} ${WRKSRC}/lib/Horde/Date/Parser.php ${HORDIR}/
+ @${CP} -Rp ${WRKSRC}/lib/Horde/Date/Parser ${HORDIR}/
+ cd ${WRKSRC}/examples/Horde/ && ${COPYTREE_SHARE} Date ${EXAMPLESDIR}
+ @${ECHO_CMD} @exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} %D/${HORDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ @${ECHO_CMD} @exec ${CHMOD} -R o-rwx %D/${HORDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${TOUCH} ${HORLOG};${CHOWN} ${WWWOWN}:${WWWGRP} ${HORLOG}" >> ${TMPPLIST}
+
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include "${.CURDIR}/../../www/horde4-base/bsd.horde4.mk"
+.include <bsd.port.mk>
diff --git a/devel/horde4-dateparser/distinfo b/devel/horde4-dateparser/distinfo
new file mode 100644
index 000000000000..093990c56bcb
--- /dev/null
+++ b/devel/horde4-dateparser/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Horde_Date_Parser-1.0.0.tgz) = d432b965923fd061c6a4ce45f7b93c3f606804226af6970b8d612d5e7dfeb897
+SIZE (Horde_Date_Parser-1.0.0.tgz) = 19765
diff --git a/devel/horde4-dateparser/files/pkg-message.in b/devel/horde4-dateparser/files/pkg-message.in
new file mode 100644
index 000000000000..af7a5654b78f
--- /dev/null
+++ b/devel/horde4-dateparser/files/pkg-message.in
@@ -0,0 +1,7 @@
+************************************************************************
+Date-Parser has been installed in %%HORDIR%%/.
+
+Horde must be configured and the tables created; if not, see
+`pkg_info -Dx horde-base'.
+
+************************************************************************
diff --git a/devel/horde4-dateparser/pkg-descr b/devel/horde4-dateparser/pkg-descr
new file mode 100644
index 000000000000..27fc3f88a310
--- /dev/null
+++ b/devel/horde4-dateparser/pkg-descr
@@ -0,0 +1,5 @@
+Horde Date Parser. Library for natural-language date parsing, with support for
+multiple languages and locales.
+
+
+WWW: http://www.horde.org
diff --git a/devel/horde4-dateparser/pkg-plist b/devel/horde4-dateparser/pkg-plist
new file mode 100644
index 000000000000..c0312121ea94
--- /dev/null
+++ b/devel/horde4-dateparser/pkg-plist
@@ -0,0 +1,41 @@
+%%EXAMPLESDIR%%/Date/Parser/parse.php
+%%HORDIR%%/Parser.php
+%%HORDIR%%/Parser/Exception.php
+%%HORDIR%%/Parser/Handler.php
+%%HORDIR%%/Parser/Locale/Base.php
+%%HORDIR%%/Parser/Locale/Base/Grabber.php
+%%HORDIR%%/Parser/Locale/Base/Ordinal.php
+%%HORDIR%%/Parser/Locale/Base/Pointer.php
+%%HORDIR%%/Parser/Locale/Base/Repeater.php
+%%HORDIR%%/Parser/Locale/Base/Scalar.php
+%%HORDIR%%/Parser/Locale/Base/Separator.php
+%%HORDIR%%/Parser/Locale/Base/Timezone.php
+%%HORDIR%%/Parser/Locale/De.php
+%%HORDIR%%/Parser/Locale/De/Grabber.php
+%%HORDIR%%/Parser/Locale/De/Ordinal.php
+%%HORDIR%%/Parser/Locale/De/Pointer.php
+%%HORDIR%%/Parser/Locale/De/Repeater.php
+%%HORDIR%%/Parser/Locale/De/Scalar.php
+%%HORDIR%%/Parser/Locale/De/Separator.php
+%%HORDIR%%/Parser/Locale/De/Timezone.php
+%%HORDIR%%/Parser/Locale/Pt.php
+%%HORDIR%%/Parser/Locale/Pt/Grabber.php
+%%HORDIR%%/Parser/Locale/Pt/Ordinal.php
+%%HORDIR%%/Parser/Locale/Pt/Pointer.php
+%%HORDIR%%/Parser/Locale/Pt/Repeater.php
+%%HORDIR%%/Parser/Locale/Pt/Scalar.php
+%%HORDIR%%/Parser/Locale/Pt/Separator.php
+%%HORDIR%%/Parser/Locale/Pt/Timezone.php
+%%HORDIR%%/Parser/Result.php
+%%HORDIR%%/Parser/Token.php
+@dirrm %%HORDIR%%/Parser/Locale/Pt
+@dirrm %%HORDIR%%/Parser/Locale/De
+@dirrm %%HORDIR%%/Parser/Locale/Base
+@dirrm %%HORDIR%%/Parser/Locale
+@dirrm %%HORDIR%%/Parser
+@dirrmtry %%HORDIR%%
+@dirrm %%EXAMPLESDIR%%/Date/Parser
+@dirrmtry %%EXAMPLESDIR%%/Date
+@dirrmtry %%EXAMPLESDIR%%
+@dirrmtry %%HORBAS%%
+