aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
committerale <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
commit48d5fb51023dbbe8f2a70121c289e1849e7e14eb (patch)
treefd816d2c8b34ef7db2d6bcabe7358eaa7fb2d04f /devel
parent19160cd533a64299fc9d3710c4d21307ce72df91 (diff)
downloadfreebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.tar.gz
freebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.tar.zst
freebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.zip
Welcome PHP 5.5!
Future steps: - rename current php5 ports to php54 - make php55 the default one after an exp-run
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile9
-rw-r--r--devel/php55-gettext/Makefile10
-rw-r--r--devel/php55-gettext/files/patch-config.m417
-rw-r--r--devel/php55-json/Makefile10
-rw-r--r--devel/php55-pcntl/Makefile10
-rw-r--r--devel/php55-readline/Makefile10
-rw-r--r--devel/php55-readline/files/patch-config.m438
-rw-r--r--devel/php55-readline/files/patch-readline_cli.c13
-rw-r--r--devel/php55-shmop/Makefile10
-rw-r--r--devel/php55-sysvmsg/Makefile10
-rw-r--r--devel/php55-sysvsem/Makefile10
-rw-r--r--devel/php55-sysvshm/Makefile10
-rw-r--r--devel/php55-tokenizer/Makefile10
13 files changed, 167 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7ef61a972f2f..6e9a8f0b26e8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3293,6 +3293,15 @@
SUBDIR += php53-sysvsem
SUBDIR += php53-sysvshm
SUBDIR += php53-tokenizer
+ SUBDIR += php55-gettext
+ SUBDIR += php55-json
+ SUBDIR += php55-pcntl
+ SUBDIR += php55-readline
+ SUBDIR += php55-shmop
+ SUBDIR += php55-sysvmsg
+ SUBDIR += php55-sysvsem
+ SUBDIR += php55-sysvshm
+ SUBDIR += php55-tokenizer
SUBDIR += phpbt
SUBDIR += phpsh
SUBDIR += phptags
diff --git a/devel/php55-gettext/Makefile b/devel/php55-gettext/Makefile
new file mode 100644
index 000000000000..b759d61a398d
--- /dev/null
+++ b/devel/php55-gettext/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= devel
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -gettext
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/php55-gettext/files/patch-config.m4 b/devel/php55-gettext/files/patch-config.m4
new file mode 100644
index 000000000000..2b497d366574
--- /dev/null
+++ b/devel/php55-gettext/files/patch-config.m4
@@ -0,0 +1,17 @@
+--- config.m4.orig Tue Jul 27 23:58:02 2004
++++ config.m4 Tue Jul 27 23:59:44 2004
+@@ -30,7 +30,6 @@
+ AC_MSG_ERROR(Unable to find required gettext library)
+ ])
+ )
+- LDFLAGS=$O_LDFLAGS
+
+ AC_DEFINE(HAVE_LIBINTL,1,[ ])
+ PHP_NEW_EXTENSION(gettext, gettext.c, $ext_shared)
+@@ -46,5 +45,6 @@
+ AC_CHECK_LIB($GETTEXT_CHECK_IN_LIB, dngettext, [AC_DEFINE(HAVE_DNGETTEXT, 1, [ ])])
+ AC_CHECK_LIB($GETTEXT_CHECK_IN_LIB, dcngettext, [AC_DEFINE(HAVE_DCNGETTEXT, 1, [ ])])
+ AC_CHECK_LIB($GETTEXT_CHECK_IN_LIB, bind_textdomain_codeset, [AC_DEFINE(HAVE_BIND_TEXTDOMAIN_CODESET, 1, [ ])])
++ LDFLAGS=$O_LDFLAGS
+
+ fi
diff --git a/devel/php55-json/Makefile b/devel/php55-json/Makefile
new file mode 100644
index 000000000000..8c52ee45170f
--- /dev/null
+++ b/devel/php55-json/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= devel
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -json
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/php55-pcntl/Makefile b/devel/php55-pcntl/Makefile
new file mode 100644
index 000000000000..8bc2847f0d62
--- /dev/null
+++ b/devel/php55-pcntl/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= devel
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -pcntl
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/php55-readline/Makefile b/devel/php55-readline/Makefile
new file mode 100644
index 000000000000..e2b6417d3224
--- /dev/null
+++ b/devel/php55-readline/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= devel
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -readline
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/php55-readline/files/patch-config.m4 b/devel/php55-readline/files/patch-config.m4
new file mode 100644
index 000000000000..9c0d4fc95033
--- /dev/null
+++ b/devel/php55-readline/files/patch-config.m4
@@ -0,0 +1,38 @@
+--- config.m4.orig 2011-09-06 17:07:24.000000000 +0200
++++ config.m4 2012-03-02 14:29:51.000000000 +0100
+@@ -5,13 +5,8 @@
+ PHP_ARG_WITH(libedit,for libedit readline replacement,
+ [ --with-libedit[=DIR] Include libedit readline replacement (CLI/CGI only)])
+
+-if test "$PHP_LIBEDIT" = "no"; then
+ PHP_ARG_WITH(readline,for readline support,
+ [ --with-readline[=DIR] Include readline support (CLI/CGI only)])
+-else
+- dnl "register" the --with-readline option to preven invalid "unknown configure option" warning
+- php_with_readline=no
+-fi
+
+ if test "$PHP_READLINE" && test "$PHP_READLINE" != "no"; then
+ for i in $PHP_READLINE /usr/local /usr; do
+@@ -67,6 +62,13 @@
+ -L$READLINE_DIR/$PHP_LIBDIR $PHP_READLINE_LIBS
+ ])
+
++ PHP_CHECK_LIBRARY(readline, rl_completion_matches,
++ [
++ AC_DEFINE(HAVE_RL_COMPLETION_MATCHES, 1, [ ])
++ ],[],[
++ -L$READLINE_DIR/$PHP_LIBDIR $PHP_READLINE_LIBS
++ ])
++
+ AC_DEFINE(HAVE_LIBREADLINE, 1, [ ])
+
+ elif test "$PHP_LIBEDIT" != "no"; then
+@@ -118,7 +120,6 @@
+ fi
+
+ if test "$PHP_READLINE" != "no" || test "$PHP_LIBEDIT" != "no"; then
+- AC_CHECK_FUNCS([rl_completion_matches])
+ PHP_NEW_EXTENSION(readline, readline.c readline_cli.c, $ext_shared, cli)
+ PHP_SUBST(READLINE_SHARED_LIBADD)
+ fi
diff --git a/devel/php55-readline/files/patch-readline_cli.c b/devel/php55-readline/files/patch-readline_cli.c
new file mode 100644
index 000000000000..02f55974f9b0
--- /dev/null
+++ b/devel/php55-readline/files/patch-readline_cli.c
@@ -0,0 +1,13 @@
+--- readline_cli.c.orig 2012-03-02 16:40:26.000000000 +0100
++++ readline_cli.c 2012-03-02 16:40:43.000000000 +0100
+@@ -19,6 +19,10 @@
+
+ /* $Id: readline_cli.c 321634 2012-01-01 13:15:04Z felipe $ */
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #include "php.h"
+
+ #ifndef HAVE_RL_COMPLETION_MATCHES
diff --git a/devel/php55-shmop/Makefile b/devel/php55-shmop/Makefile
new file mode 100644
index 000000000000..59a106243a64
--- /dev/null
+++ b/devel/php55-shmop/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= devel
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -shmop
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/php55-sysvmsg/Makefile b/devel/php55-sysvmsg/Makefile
new file mode 100644
index 000000000000..a3ea35125f18
--- /dev/null
+++ b/devel/php55-sysvmsg/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= devel
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -sysvmsg
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/php55-sysvsem/Makefile b/devel/php55-sysvsem/Makefile
new file mode 100644
index 000000000000..678b6b58780b
--- /dev/null
+++ b/devel/php55-sysvsem/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= devel
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -sysvsem
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/php55-sysvshm/Makefile b/devel/php55-sysvshm/Makefile
new file mode 100644
index 000000000000..198aed43ed07
--- /dev/null
+++ b/devel/php55-sysvshm/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= devel
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -sysvshm
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/php55-tokenizer/Makefile b/devel/php55-tokenizer/Makefile
new file mode 100644
index 000000000000..b8c65762fc89
--- /dev/null
+++ b/devel/php55-tokenizer/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= devel
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -tokenizer
+
+.include "${MASTERDIR}/Makefile"