aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-10-13 03:25:53 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-10-13 03:25:53 +0800
commit48ecf193cd5a310f8026a4e72c2ba06e5743b935 (patch)
treee59d77fbb7ae7985c1adca076e227b22830cea02 /devel
parentd088599c95457077ba876cd8fe93c36a3aecbf51 (diff)
downloadfreebsd-ports-gnome-48ecf193cd5a310f8026a4e72c2ba06e5743b935.tar.gz
freebsd-ports-gnome-48ecf193cd5a310f8026a4e72c2ba06e5743b935.tar.zst
freebsd-ports-gnome-48ecf193cd5a310f8026a4e72c2ba06e5743b935.zip
- Support STAGEDIR
Diffstat (limited to 'devel')
-rw-r--r--devel/nant/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/devel/nant/Makefile b/devel/nant/Makefile
index c2fa3c18cd68..7fe735c4fbec 100644
--- a/devel/nant/Makefile
+++ b/devel/nant/Makefile
@@ -13,12 +13,12 @@ COMMENT= .NET build tool inspired by Ant
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
+BUILD_DEPENDS= ${LOCALBASE}/bin/mono:${PORTSDIR}/lang/mono
RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= DOCS EXAMPLES
-INSTALL_TARGET= install prefix=${PREFIX}
+INSTALL_TARGET= install destdir=${STAGEDIR} prefix=${PREFIX}
MAKE_JOBS_UNSAFE= yes
USES= gmake pkgconfig
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -26,7 +26,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
DATADIR= ${PREFIX}/share/NAnt
DOCSDIR= ${PREFIX}/share/doc/NAnt
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -37,8 +36,8 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}/
- cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR}/
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
+ cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}/
.endif
regression-test test: build