aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-17 17:36:54 +0800
committerkrion <krion@FreeBSD.org>2004-03-17 17:36:54 +0800
commit4c322361157a65f0dd2e0b9512e52cc51dd0596a (patch)
tree4c82884dd8229db394700027f5152643d1d61260 /devel
parent2f06b8f2ff2ce0a0363c50ae9747abc1f31fa9a8 (diff)
downloadfreebsd-ports-gnome-4c322361157a65f0dd2e0b9512e52cc51dd0596a.tar.gz
freebsd-ports-gnome-4c322361157a65f0dd2e0b9512e52cc51dd0596a.tar.zst
freebsd-ports-gnome-4c322361157a65f0dd2e0b9512e52cc51dd0596a.zip
- Fix build on 4-x alpha
PR: ports/64362 Submitted by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/cppadvio/Makefile6
-rw-r--r--devel/cppadvio/files/patch-TCPstream.cc11
2 files changed, 12 insertions, 5 deletions
diff --git a/devel/cppadvio/Makefile b/devel/cppadvio/Makefile
index 04c3feb54ae7..561f0cdc3881 100644
--- a/devel/cppadvio/Makefile
+++ b/devel/cppadvio/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cppadvio
PORTVERSION= 2.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel net
MASTER_SITES= http://okmij.org/ftp/packages/ \
${MASTER_SITE_LOCAL}
@@ -23,10 +23,6 @@ USE_GCC= 2.95
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= "Does not compile on alpha 4.x"
-.endif
-
post-patch:
@( cd ${WRKSRC}; ${MV} c++ c++.orig; \
${SED} -e 's|^ *gcc|${CXX} ${CXXFLAGS}|' c++.orig > c++; ${CHMOD} +x c++ )
diff --git a/devel/cppadvio/files/patch-TCPstream.cc b/devel/cppadvio/files/patch-TCPstream.cc
new file mode 100644
index 000000000000..14c81a0639fd
--- /dev/null
+++ b/devel/cppadvio/files/patch-TCPstream.cc
@@ -0,0 +1,11 @@
+--- TCPstream.cc.orig Wed Mar 17 10:34:32 2004
++++ TCPstream.cc Wed Mar 17 10:34:50 2004
+@@ -44,7 +44,7 @@
+ {
+ // Convertion between the host and the network
+ // byte orders
+-#if !defined(htons) && !defined(linux)
++#if !defined(htons) && !defined(linux) && !defined(_MACHINE_ENDIAN_H_)
+ unsigned short htons(unsigned int data); // For a short data item
+ unsigned short ntohs(unsigned int data); // For a short data item
+ unsigned long htonl(unsigned long data); // For a long data item