aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-03-15 21:28:13 +0800
committergahr <gahr@FreeBSD.org>2013-03-15 21:28:13 +0800
commit4d7b75c4605ae46baa484f3c6e7c429cca8e1d78 (patch)
tree82b4d97dade8fd2908a401cb8606e731d7c68fa2 /devel
parent724ee9c9c6455ae7971bf2566252beb0167fe4f8 (diff)
downloadfreebsd-ports-gnome-4d7b75c4605ae46baa484f3c6e7c429cca8e1d78.tar.gz
freebsd-ports-gnome-4d7b75c4605ae46baa484f3c6e7c429cca8e1d78.tar.zst
freebsd-ports-gnome-4d7b75c4605ae46baa484f3c6e7c429cca8e1d78.zip
- Respect NOPORTDOCS [1]
- Trim Makefile header - Remove shared library version from LIB_DEPENDS Reported by: bapt [1]
Diffstat (limited to 'devel')
-rw-r--r--devel/dcmtk/Makefile17
-rw-r--r--devel/dcmtk/pkg-plist20
2 files changed, 10 insertions, 27 deletions
diff --git a/devel/dcmtk/Makefile b/devel/dcmtk/Makefile
index 847c432dbab1..5fcfcfba73dc 100644
--- a/devel/dcmtk/Makefile
+++ b/devel/dcmtk/Makefile
@@ -1,9 +1,5 @@
-# New ports collection Makefile for: dcmtk
-# Date created: 26 July 2010
-# Whom: gahr
-#
+# Created by: gahr
# $FreeBSD$
-#
PORTNAME= dcmtk
DISTVERSION= 3.6.0
@@ -14,14 +10,15 @@ MASTER_SITES= ftp://dicom.offis.de/pub/dicom/offis/software/${PORTNAME}/${PORTNA
MAINTAINER= gahr@FreeBSD.org
COMMENT= A toolkit to work with DICOM files
-LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
+LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
png15:${PORTSDIR}/graphics/png \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+ jpeg:${PORTSDIR}/graphics/jpeg
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_CMAKE= yes
CMAKE_OUTSOURCE=yes
+CMAKE_ARGS+= -DDCMTK_WITH_DOXYGEN:BOOL=OFF
SHLIBS= dcmdata dcmdsig dcmimage dcmimgle dcmjpeg dcmnet \
dcmpstat dcmqrdb dcmsr dcmtls dcmwlm ijg8 ijg12 \
@@ -30,6 +27,8 @@ SHLIBS= dcmdata dcmdsig dcmimage dcmimgle dcmjpeg dcmnet \
SHLIBVER= ${PORTVERSION:R:R}
PLIST_SUB= SHLIBVER=${SHLIBVER}
+PORTDOCS= *
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
@@ -38,6 +37,10 @@ CFLAGS+= -fPIC
post-patch:
${FIND} ${WRKSRC} -name "*.h.orig" -delete
+.if !${PORT_OPTIONS:MDOCS}
+ ${FIND} ${WRKSRC} -name CMakeLists.txt | ${XARGS} \
+ ${REINPLACE_CMD} -e '/INSTALL_DOCDIR/d'
+.endif
post-install:
.for shlib in ${SHLIBS}
diff --git a/devel/dcmtk/pkg-plist b/devel/dcmtk/pkg-plist
index 3fd3cab479a9..deacde084fa9 100644
--- a/devel/dcmtk/pkg-plist
+++ b/devel/dcmtk/pkg-plist
@@ -614,30 +614,10 @@ lib/libofstd.so.%%SHLIBVER%%
%%DATADIR%%/wlistqry/wlistqry7.dump
%%DATADIR%%/wlistqry/wlistqry8.dump
%%DATADIR%%/wlistqry/wlistqry9.dump
-%%DOCSDIR%%/config.txt
-%%DOCSDIR%%/envvars.txt
-%%DOCSDIR%%/modules.txt
-%%DOCSDIR%%/dirstruc.txt
-%%DOCSDIR%%/macros.txt
-%%DOCSDIR%%/datadict.txt
-%%DOCSDIR%%/ciphers.txt
-%%DOCSDIR%%/randseed.txt
-%%DOCSDIR%%/asconfig.txt
-%%DOCSDIR%%/testing.txt
-%%DOCSDIR%%/dcmqrcnf.txt
-%%DOCSDIR%%/dcmqrset.txt
-%%DOCSDIR%%/wwwapp.txt
-%%DOCSDIR%%/ANNOUNCE.360
-%%DOCSDIR%%/CHANGES.360
-%%DOCSDIR%%/COPYRIGHT
-%%DOCSDIR%%/FAQ
-%%DOCSDIR%%/HISTORY
-%%DOCSDIR%%/VERSION
@dirrm %%DATADIR%%/wlistdb/OFFIS
@dirrm %%DATADIR%%/wlistqry
@dirrm %%DATADIR%%/wlistdb
@dirrm %%DATADIR%%
-@dirrm %%DOCSDIR%%/html
@dirrm %%DOCSDIR%%
@dirrm etc/dcmtk
@dirrm bin/dcmtk