aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2011-10-21 00:00:04 +0800
committerwxs <wxs@FreeBSD.org>2011-10-21 00:00:04 +0800
commit4da712f23f27094a4a55b7b1405e4ecb7d2222df (patch)
treee5c51c9676be76ce66d70db00b7730840bbb0472 /devel
parent042996d4b2d6af2c45af4aeef4319f81c89da28d (diff)
downloadfreebsd-ports-gnome-4da712f23f27094a4a55b7b1405e4ecb7d2222df.tar.gz
freebsd-ports-gnome-4da712f23f27094a4a55b7b1405e4ecb7d2222df.tar.zst
freebsd-ports-gnome-4da712f23f27094a4a55b7b1405e4ecb7d2222df.zip
Remove dependency upon devel/subversion. We already depend upon
devel/p5-subversion which will bring in devel/subversion for us. Furthermore, devel/p5-subversion already honors the WITH_SUBVERSION_VER knob so there is no need to duplicate that functionality here just to pick the correct version of subversion. Discussed with: avg@
Diffstat (limited to 'devel')
-rw-r--r--devel/git/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 67ca24f11da0..41de5caad609 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -275,9 +275,13 @@ PLIST_SUB+= GUI="@comment "
MAKE_ARGS+= NO_TCLTK=yes
.endif
+# While this port does not explicity honor WITH_SUBVERSION_VER knob it does
+# depend upon devel/p5-subversion, which does honor that knob. If you want
+# to have git use devel/subversion16 it will be brought in through
+# devel/p5-subversion if you set WITH_SUBVERSION_VER=16. Otherwise
+# devel/subversion will be brought in.
.ifdef (WITH_SVN)
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
-RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion \
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/p5-subversion
PLIST_SUB+= SVN=""
MAN1+= git-svn.1