aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-09-14 05:47:22 +0800
committermiwi <miwi@FreeBSD.org>2007-09-14 05:47:22 +0800
commit4df00ae7af7e03e7145824d2dd62490984d998cf (patch)
tree888c9831c2f4b9f65d800f00d6cce65cc0270b5d /devel
parent320d6d5aa507dcf354b908aa833120e60b4cdf4d (diff)
downloadfreebsd-ports-gnome-4df00ae7af7e03e7145824d2dd62490984d998cf.tar.gz
freebsd-ports-gnome-4df00ae7af7e03e7145824d2dd62490984d998cf.tar.zst
freebsd-ports-gnome-4df00ae7af7e03e7145824d2dd62490984d998cf.zip
Params::Coerce - Allows your classes to do coercion of parameters
WWW: http://search.cpan.org/dist/Params-Coerce/ PR: ports/116215 Submitted by: Cory R. King <coryking at mozimedia.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Params-Coerce/Makefile27
-rw-r--r--devel/p5-Params-Coerce/distinfo3
-rw-r--r--devel/p5-Params-Coerce/pkg-descr3
-rw-r--r--devel/p5-Params-Coerce/pkg-plist4
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6f61b8ac545e..6dcc9094e542 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1414,6 +1414,7 @@
SUBDIR += p5-Params-CallbackRequest
SUBDIR += p5-Params-Check
SUBDIR += p5-Params-Classify
+ SUBDIR += p5-Params-Coerce
SUBDIR += p5-Params-Util
SUBDIR += p5-Params-Validate
SUBDIR += p5-Parse-CPAN-Packages
diff --git a/devel/p5-Params-Coerce/Makefile b/devel/p5-Params-Coerce/Makefile
new file mode 100644
index 000000000000..f4d3ad7eb5f9
--- /dev/null
+++ b/devel/p5-Params-Coerce/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Params-Coerce
+# Date created: 08 September 2007
+# Whom: Cory R. King <coryking@mozimedia.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Params-Coerce
+PORTVERSION= 0.14
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Params
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= coryking@mozimedia.com
+COMMENT= Allows your classes to do coercion of parameters (Params::Coerce)
+
+BUILD_DEPENDS= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Params-Util>=0.20:${PORTSDIR}/devel/p5-Params-Util
+RUN_DEPENDS= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Params-Util>=0.20:${PORTSDIR}/devel/p5-Params-Util
+
+PERL_CONFIGURE= yes
+
+MAN3= Params::Coerce.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Params-Coerce/distinfo b/devel/p5-Params-Coerce/distinfo
new file mode 100644
index 000000000000..58761fb40a04
--- /dev/null
+++ b/devel/p5-Params-Coerce/distinfo
@@ -0,0 +1,3 @@
+MD5 (Params-Coerce-0.14.tar.gz) = a8439ea6777c9156424ef6dd74c83945
+SHA256 (Params-Coerce-0.14.tar.gz) = 5c67b11b9859e8d0d048c1c529e16ff49458fe4a98a16ccbfec6cd66e49b7713
+SIZE (Params-Coerce-0.14.tar.gz) = 26566
diff --git a/devel/p5-Params-Coerce/pkg-descr b/devel/p5-Params-Coerce/pkg-descr
new file mode 100644
index 000000000000..88b5961b3978
--- /dev/null
+++ b/devel/p5-Params-Coerce/pkg-descr
@@ -0,0 +1,3 @@
+Params::Coerce - Allows your classes to do coercion of parameters
+
+WWW: http://search.cpan.org/dist/Params-Coerce/
diff --git a/devel/p5-Params-Coerce/pkg-plist b/devel/p5-Params-Coerce/pkg-plist
new file mode 100644
index 000000000000..bfd11ee8810e
--- /dev/null
+++ b/devel/p5-Params-Coerce/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Params/Coerce.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Params/Coerce/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Params
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Params/Coerce