aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2008-09-07 10:03:26 +0800
committerchinsan <chinsan@FreeBSD.org>2008-09-07 10:03:26 +0800
commit4f5895359d2c5008b5c120ca007bc5749ef9cdb7 (patch)
tree414f72b42ed01b81c6020bcc9a05ddfdeed50825 /devel
parent53cb86d11715ae9b7ea687d4770416fb4f70319d (diff)
downloadfreebsd-ports-gnome-4f5895359d2c5008b5c120ca007bc5749ef9cdb7.tar.gz
freebsd-ports-gnome-4f5895359d2c5008b5c120ca007bc5749ef9cdb7.tar.zst
freebsd-ports-gnome-4f5895359d2c5008b5c120ca007bc5749ef9cdb7.zip
Add p5-File-Path, create or remove directory trees.
WWW: http://search.cpan.org/dist/File-Path/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-Path/Makefile21
-rw-r--r--devel/p5-File-Path/distinfo3
-rw-r--r--devel/p5-File-Path/pkg-descr3
-rw-r--r--devel/p5-File-Path/pkg-plist5
5 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ac3c17cfdfb7..54bd060445ae 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1300,6 +1300,7 @@
SUBDIR += p5-File-Monitor
SUBDIR += p5-File-NCopy
SUBDIR += p5-File-NFSLock
+ SUBDIR += p5-File-Path
SUBDIR += p5-File-Path-Expand
SUBDIR += p5-File-PathConvert
SUBDIR += p5-File-Pid
diff --git a/devel/p5-File-Path/Makefile b/devel/p5-File-Path/Makefile
new file mode 100644
index 000000000000..af5313105367
--- /dev/null
+++ b/devel/p5-File-Path/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-File-Path
+# Date created: 2008/09/06
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Path
+PORTVERSION= 2.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Create or remove directory trees
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Path.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Path/distinfo b/devel/p5-File-Path/distinfo
new file mode 100644
index 000000000000..7028336c3845
--- /dev/null
+++ b/devel/p5-File-Path/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-Path-2.04.tar.gz) = 1fbfa1af162a3c87af1a607a019b8442
+SHA256 (File-Path-2.04.tar.gz) = 2d8881966fbe76b63731fa6816eed698eea346c6b13513ff60228fa7ea881ad0
+SIZE (File-Path-2.04.tar.gz) = 17167
diff --git a/devel/p5-File-Path/pkg-descr b/devel/p5-File-Path/pkg-descr
new file mode 100644
index 000000000000..61551b8b1618
--- /dev/null
+++ b/devel/p5-File-Path/pkg-descr
@@ -0,0 +1,3 @@
+File::Path - Create or remove directory trees
+
+WWW: http://search.cpan.org/dist/File-Path/
diff --git a/devel/p5-File-Path/pkg-plist b/devel/p5-File-Path/pkg-plist
new file mode 100644
index 000000000000..168311d891e1
--- /dev/null
+++ b/devel/p5-File-Path/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/File/Path.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Path/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Path
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/File