aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-12-12 19:25:50 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-12-12 19:25:50 +0800
commit4fdf1b16876d07328bf9bd1a4214e285d535bac4 (patch)
treebdd77837b76e3bbd55d84f3e47393f395cc799bd /devel
parentf4bdcf8c9605863feb3ca249c7123b08b3a8334f (diff)
downloadfreebsd-ports-gnome-4fdf1b16876d07328bf9bd1a4214e285d535bac4.tar.gz
freebsd-ports-gnome-4fdf1b16876d07328bf9bd1a4214e285d535bac4.tar.zst
freebsd-ports-gnome-4fdf1b16876d07328bf9bd1a4214e285d535bac4.zip
- Add p5-MouseX-App-Cmd 0.08
MouseX::App::Cmd marries App::Cmd with MouseX::Getopt. It is a direct port of MooseX::App::Cmd to Mouse. Use it like App::Cmd advises (especially see App::Cmd::Tutorial), swapping App::Cmd::Command for MouseX::App::Cmd::Command. Then you can write your Mouse commands as Mouse classes, with MouseX::Getopt defining the options for you instead of opt_spec returning a Getopt::Long::Descriptive spec. WWW: http://search.cpan.org/dist/MouseX-App-Cmd/ Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-MouseX-App-Cmd/Makefile40
-rw-r--r--devel/p5-MouseX-App-Cmd/distinfo2
-rw-r--r--devel/p5-MouseX-App-Cmd/pkg-descr11
-rw-r--r--devel/p5-MouseX-App-Cmd/pkg-plist9
5 files changed, 63 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f7b19f72520d..31647272b99c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2097,6 +2097,7 @@
SUBDIR += p5-MooseX-Types-Structured
SUBDIR += p5-MooseX-Types-VariantTable
SUBDIR += p5-Mouse
+ SUBDIR += p5-MouseX-App-Cmd
SUBDIR += p5-MouseX-AttributeHelpers
SUBDIR += p5-MouseX-ConfigFromFile
SUBDIR += p5-MouseX-Foreign
diff --git a/devel/p5-MouseX-App-Cmd/Makefile b/devel/p5-MouseX-App-Cmd/Makefile
new file mode 100644
index 000000000000..ba237faae9c1
--- /dev/null
+++ b/devel/p5-MouseX-App-Cmd/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-MouseX-App-Cmd
+# Date created: 2011-12-12
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MouseX-App-Cmd
+PORTVERSION= 0.08
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MJGARDNER
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Mashes up MouseX::Getopt and App::Cmd
+
+BUILD_DEPENDS= p5-App-Cmd>=0.300:${PORTSDIR}/devel/p5-App-Cmd \
+ p5-Getopt-Long-Descriptive>=0:${PORTSDIR}/devel/p5-Getopt-Long-Descriptive \
+ p5-Mouse>=0.86:${PORTSDIR}/devel/p5-Mouse \
+ p5-MouseX-ConfigFromFile>=0:${PORTSDIR}/devel/p5-MouseX-ConfigFromFile \
+ p5-MouseX-Getopt>=0.1800:${PORTSDIR}/devel/p5-MouseX-Getopt \
+ p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+TEST_DEPENDS= p5-Test-Output>=0:${PORTSDIR}/devel/p5-Test-Output \
+ p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
+
+PERL_CONFIGURE= yes
+
+MAN3= MouseX::App::Cmd.3 \
+ MouseX::App::Cmd::Command.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501200
+TEST_DEPENDS+= p5-Test-Simple>=0.94:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-MouseX-App-Cmd/distinfo b/devel/p5-MouseX-App-Cmd/distinfo
new file mode 100644
index 000000000000..06ffb3c6fc58
--- /dev/null
+++ b/devel/p5-MouseX-App-Cmd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MouseX-App-Cmd-0.08.tar.gz) = 769cd3a2c8001a09665275120641ca6b7164636fe96aa47fd45b0cabb0972f8a
+SIZE (MouseX-App-Cmd-0.08.tar.gz) = 20981
diff --git a/devel/p5-MouseX-App-Cmd/pkg-descr b/devel/p5-MouseX-App-Cmd/pkg-descr
new file mode 100644
index 000000000000..68d4c5217fbc
--- /dev/null
+++ b/devel/p5-MouseX-App-Cmd/pkg-descr
@@ -0,0 +1,11 @@
+MouseX::App::Cmd marries App::Cmd with MouseX::Getopt. It is a direct port of
+MooseX::App::Cmd to Mouse.
+
+Use it like App::Cmd advises (especially see App::Cmd::Tutorial), swapping
+App::Cmd::Command for MouseX::App::Cmd::Command.
+
+Then you can write your Mouse commands as Mouse classes, with MouseX::Getopt
+defining the options for you instead of opt_spec returning a
+Getopt::Long::Descriptive spec.
+
+WWW: http://search.cpan.org/dist/MouseX-App-Cmd/
diff --git a/devel/p5-MouseX-App-Cmd/pkg-plist b/devel/p5-MouseX-App-Cmd/pkg-plist
new file mode 100644
index 000000000000..41e4072e1633
--- /dev/null
+++ b/devel/p5-MouseX-App-Cmd/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/MouseX/App/Cmd.pm
+%%SITE_PERL%%/MouseX/App/Cmd/Command.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MouseX/App/Cmd/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MouseX/App/Cmd
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MouseX/App
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MouseX
+@dirrm %%SITE_PERL%%/MouseX/App/Cmd
+@dirrmtry %%SITE_PERL%%/MouseX/App
+@dirrmtry %%SITE_PERL%%/MouseX