aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-07-31 18:04:59 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-07-31 18:04:59 +0800
commit53cb1bdf359a0a9f433eea5a2c6f237ec4517216 (patch)
treea1c06e0d4b13cd88fce15360cac5480b08d823bd /devel
parentfdc2dfe4023c3fb4745cc493468ee2cc14de9de1 (diff)
downloadfreebsd-ports-gnome-53cb1bdf359a0a9f433eea5a2c6f237ec4517216.tar.gz
freebsd-ports-gnome-53cb1bdf359a0a9f433eea5a2c6f237ec4517216.tar.zst
freebsd-ports-gnome-53cb1bdf359a0a9f433eea5a2c6f237ec4517216.zip
- Add LICENSE
- Fix *_DEPENDS: Test::More 0.44+ is already in all supported Perl releases - Bump PORTREVISION for dependency change - Sort PLIST - Reformat pkg-descr
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Test-Singleton/Makefile10
-rw-r--r--devel/p5-Test-Singleton/pkg-descr12
-rw-r--r--devel/p5-Test-Singleton/pkg-plist4
3 files changed, 14 insertions, 12 deletions
diff --git a/devel/p5-Test-Singleton/Makefile b/devel/p5-Test-Singleton/Makefile
index 309ba35a93bc..8c2ce3d154a7 100644
--- a/devel/p5-Test-Singleton/Makefile
+++ b/devel/p5-Test-Singleton/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Test-Singleton
PORTVERSION= 1.03
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:TPG
@@ -11,11 +12,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Test for Singleton classes
-RUN_DEPENDS= p5-Class-Singleton>=0:${PORTSDIR}/devel/p5-Class-Singleton \
- p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+LICENSE= GPLv2
+
+BUILD_DEPENDS= p5-Class-Singleton>=0:${PORTSDIR}/devel/p5-Class-Singleton
+RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
USE_PERL5= configure
+USES= perl5
.include <bsd.port.mk>
diff --git a/devel/p5-Test-Singleton/pkg-descr b/devel/p5-Test-Singleton/pkg-descr
index 213814f0cb94..aba554adc462 100644
--- a/devel/p5-Test-Singleton/pkg-descr
+++ b/devel/p5-Test-Singleton/pkg-descr
@@ -1,11 +1,11 @@
** If you are unfamiliar with testing read Test::Tutorial first! **
-This is a simple, basic module for checking whether a class is a
-Singleton. A Singleton describes an object class that can have only
-one instance in any system. An example of a Singleton might be a print
-spooler or system registry, or any kind of central dispatcher.
+This is a simple, basic module for checking whether a class is a Singleton. A
+Singleton describes an object class that can have only one instance in any
+system. An example of a Singleton might be a print spooler or system registry,
+or any kind of central dispatcher.
-For a description and discussion of the Singleton class, see "Design
-Patterns", Gamma et al, Addison-Wesley, 1995, ISBN 0-201-63361-2.
+For a description and discussion of the Singleton class, see "Design Patterns",
+Gamma et al, Addison-Wesley, 1995, ISBN 0-201-63361-2.
WWW: http://search.cpan.org/dist/Test-Singleton/
diff --git a/devel/p5-Test-Singleton/pkg-plist b/devel/p5-Test-Singleton/pkg-plist
index d11e05725344..def5c79b6841 100644
--- a/devel/p5-Test-Singleton/pkg-plist
+++ b/devel/p5-Test-Singleton/pkg-plist
@@ -1,6 +1,6 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Singleton/.packlist
%%SITE_PERL%%/Test/Singleton.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Singleton/.packlist
%%PERL5_MAN3%%/Test::Singleton.3.gz
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Singleton
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Singleton
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
@dirrmtry %%SITE_PERL%%/Test