aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2007-03-04 04:54:51 +0800
committermezz <mezz@FreeBSD.org>2007-03-04 04:54:51 +0800
commit54a20d775a789752f582fa3759ff8b3f9b2cb3bb (patch)
tree94cac7e2481d28844efcc21df87b2d42e090e2f5 /devel
parentd339703bfc09e4668f533edc5ed3e5eab5a3a230 (diff)
downloadfreebsd-ports-gnome-54a20d775a789752f582fa3759ff8b3f9b2cb3bb.tar.gz
freebsd-ports-gnome-54a20d775a789752f582fa3759ff8b3f9b2cb3bb.tar.zst
freebsd-ports-gnome-54a20d775a789752f582fa3759ff8b3f9b2cb3bb.zip
Fix the build if devel/libffi is installed in system.
PR: ports/109774 Reported by: Kostas Blekos <mplekos@physics.upatras.gr>
Diffstat (limited to 'devel')
-rw-r--r--devel/g-wrap/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/g-wrap/Makefile b/devel/g-wrap/Makefile
index 2e3687f03ee2..feffd828e19d 100644
--- a/devel/g-wrap/Makefile
+++ b/devel/g-wrap/Makefile
@@ -5,6 +5,7 @@
#
# $FreeBSD$
# $MCom: ports/devel/g-wrap/Makefile,v 1.6 2006/12/24 18:45:08 ahze Exp $
+#
PORTNAME= g-wrap
PORTVERSION= 1.9.6
@@ -31,6 +32,8 @@ USE_GNOME= glib20 gnomehack
post-patch:
@${REINPLACE_CMD} -e 's|"glib"|"glib-2.0"|' \
${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|(GUILE_CFLAGS) $$(LIBFFI_CFLAGS)|(LIBFFI_CFLAGS) $$(GUILE_CFLAGS)|g'
pre-install:
@${REINPLACE_CMD} -e 's|libffi||' ${WRKSRC}/${MAKEFILE}
@@ -38,7 +41,8 @@ pre-install:
post-install:
${MKDIR} ${PREFIX}/include/g-wrap/ffi
.for f in ffi.h ffitarget.h
- ${INSTALL_DATA} ${WRKSRC}/libffi/include/${f} ${PREFIX}/include/g-wrap/ffi
+ ${INSTALL_DATA} ${WRKSRC}/libffi/include/${f} \
+ ${PREFIX}/include/g-wrap/ffi
.endfor
.include <bsd.port.mk>